Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » Look and Chameleon Technology » Unable to locate theme engine
Unable to locate theme engine [message #35035] Sat, 31 December 2011 20:47
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
Hello,

I am using UPP4193 under Ubuntu 11.10 and I get the following error when I start my program from a terminal:

(OpenWind:9339): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
The program 'OpenWind' received an X Window System error.
This probably reflects a bug in the program.
The error was 'RenderBadPicture (invalid Picture parameter)'.
  (Details: serial 122 error_code 160 request_code 150 minor_code 7)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)


when I set a breakpoint on the first line of the constructor of my main window, it doesn't appear to get that far so the problem appears to be before my code even gets a chance to run.

Also, I tried to find the function gdk_x_error() in the uppsrc and it doesn't show up.

Strangely, the window never appears but the CPU for my process runs at 100% indefinitely.

I am posting in this forum because of the "theme" warning given above but I really have no idea what could cause it or how to go about fixing it.

Any ideas?

Nick

EDIT: fixed the pixmap warning by installing gtk2-engines-pixbuf but the main error persists and is reported elsewhere for various software on different distros.

EDIT: am trying to find an example which gives the same error. I tried to build and run ImageView from the examples and got this


----- ImageView ( GUI MAIN GCC SHARED LINUX POSIX ) (12 / 12)
Linking...
/home/nick/.upp/_out/examples/GCC.Gui.Shared/ImageView (1869800 B) linked in (0:00.53)

OK. (0:00.66)
Executing: "/home/nick/.upp/_out/examples/GCC.Gui.Shared/ImageView" 

** (ImageView:13978): CRITICAL **: os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(ImageView:13978): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (ImageView:13978): CRITICAL **: os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed

** (ImageView:13978): CRITICAL **: os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(ImageView:13978): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (ImageView:13978): CRITICAL **: os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed

** (ImageView:13978): CRITICAL **: os_pager_hide: assertion `OS_IS_PAGER (pager)' failed

(ImageView:13978): Gtk-CRITICAL **: IA__gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

** (ImageView:13978): CRITICAL **: os_pager_set_parent: assertion `OS_IS_PAGER (pager)' failed



and that also happens with UWord although both examples do run.

[Updated on: Sat, 31 December 2011 21:40]

Report message to a moderator

Previous Topic: UPP with Tango look
Next Topic: RichTextView and Chameleon with a dark background.
Goto Forum:
  


Current Time: Sat Jan 23 17:17:58 CET 2021

Total time taken to generate the page: 0.01464 seconds