Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Compiling, Linking, Debugging of your packages » First compilling under Linux; /usr/bin/ld: cannot find
First compilling under Linux; /usr/bin/ld: cannot find [message #39471] Mon, 18 March 2013 20:18 Go to next message
Alexander_Ag is currently offline  Alexander_Ag
Messages: 4
Registered: March 2013
Location: Georgia
Junior Member
Its first trying compile simple project under Linux, under Windows i have no problem with compiling and linking.
So project ask for some header files, I've added some lines to "SETUP" => "Build methods.." => "INCLUDE directories" :

/usr/include
/usr/include/freetype2
/usr/include/gtk-2.0
/usr/include/glib-2.0
/usr/lib/i386-linux-gnu/glib-2.0/include
/usr/include/cairo
/usr/include/pango-1.0
/usr/lib/i386-linux-gnu/gtk-2.0/include
/usr/include/gdk-pixbuf-2.0
/usr/include/atk-1.0

After that no questions about "someHeader.h", but I got next message:

/*********************************************************/

----- RichText ( GUI SSE2 GCC DEBUG DEBUG_MINIMAL BLITZ LINUX POSIX ) (6 / 9)
----- Core ( GUI SSE2 GCC DEBUG DEBUG_MINIMAL BLITZ LINUX POSIX ) (7 / 9)
----- plugin/png ( GUI SSE2 GCC DEBUG DEBUG_MINIMAL BLITZ LINUX POSIX ) (8 / 9)
----- example ( GUI SSE2 MAIN GCC DEBUG DEBUG_MINIMAL BLITZ LINUX POSIX ) (9 / 9)
main.cpp
example: 1 file(s) built in (0:03.07), 3072 msecs / file, duration = 3077 msecs
Linking...
/usr/bin/ld: cannot find -latk-1.0
/usr/bin/ld: cannot find -lgdk_pixbuf-2.0
/home/sas/.upp/_out/MyApps/Core/GCC.Debug.Debug_Minimal.Gui. Sse2/$blitz.o: In function `CheckDll__(char const*, char const* const*, Upp::Ve
ctor<void*>&)':
$blitz.cpp:(.text+0x56a81): warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the gli
bc version used for linking
collect2: ld returned 1 exit status

There were errors. (0:05.95)


/****************************************************/

I check that libraries and links :

apt-file search libatk-1.0
libatk1.0-0: /usr/lib/i386-linux-gnu/libatk-1.0.so.0
libatk1.0-0: /usr/lib/i386-linux-gnu/libatk-1.0.so.0.20409.1
libatk1.0-dbg: /usr/lib/debug/usr/lib/i386-linux-gnu/libatk-1.0.so.0.20409. 1
libatk1.0-dev: /usr/lib/i386-linux-gnu/libatk-1.0.so

ls -l /usr/lib/i386-linux-gnu/libatk-1.0*
lrwxrwxrwx 1 root root 23 Mar 28 2012 /usr/lib/i386-linux-gnu/libatk-1.0.so -> libatk-1.0.so.0.20409.1
lrwxrwxrwx 1 root root 23 Sep 13 2012 /usr/lib/i386-linux-gnu/libatk-1.0.so.0 -> libatk-1.0.so.0.20409.1
-rw-r--r-- 1 root root 124620 Mar 28 2012 /usr/lib/i386-linux-gnu/libatk-1.0.so.0.20409.1


apt-file search libgdk_pixbuf-2.0
libgdk-pixbuf2.0-0: /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so.0
libgdk-pixbuf2.0-0: /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so.0.2600.1
libgdk-pixbuf2.0-dev: /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so

ls -l /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0*
lrwxrwxrwx 1 root root 29 Apr 16 2012 /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so -> libgdk_pixbuf-2.0.so.0.2600.1
lrwxrwxrwx 1 root root 29 Sep 13 2012 /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so.0 -> libgdk_pixbuf-2.0.so.0.2600.1
-rw-r--r-- 1 root root 128964 Apr 16 2012 /usr/lib/i386-linux-gnu/libgdk_pixbuf-2.0.so.0.2600.1


All libs and links is OK
I add lines to "LIB directories" :
/usr/lib
/usr/lib/i386-linux-gnu

But got the same error ... any help

uname -a
Linux sas-Presario 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:41:14 UTC 2012 i686 athlon i386 GNU/Linux



Re: First compilling under Linux; /usr/bin/ld: cannot find [message #39473 is a reply to message #39471] Tue, 19 March 2013 09:35 Go to previous messageGo to next message
Alexander_Ag is currently offline  Alexander_Ag
Messages: 4
Registered: March 2013
Location: Georgia
Junior Member
Solved! so simple --> USE SHARED LIBS as say compiler!

warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking

Thanks for everyone who has read Smile
Re: First compilling under Linux; /usr/bin/ld: cannot find [message #39475 is a reply to message #39471] Tue, 19 March 2013 18:36 Go to previous message
Novo is currently offline  Novo
Messages: 893
Registered: December 2006
Experienced Contributor
In case of "Use shared libs" you will not have any problems with dlopen. You will have them in "All static" configuration, which is hard to link on Linux any way. In case of "All shared" TheIDE will create a shared library instead of an executable. But executable in Linux is a shared library, and shared libraries are executables ... Smile

Regards,
Novo
Previous Topic: MSC compiling messages in English
Next Topic: [BUG] TheIDE prevents using MSC Incremental link
Goto Forum:
  


Current Time: Sun Dec 15 09:58:37 CET 2019

Total time taken to generate the page: 0.00924 seconds