Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Installation error for tarball upp-x11-src-8756.tar.gz (Compilation error -- missing file)
Installation error for tarball upp-x11-src-8756.tar.gz [message #44937] Mon, 27 July 2015 07:09 Go to next message
jfranks is currently offline  jfranks
Messages: 36
Registered: September 2014
Location: Houston, Texas
Member
Compilation failed very early in building TheIDE -- missing file error as follows:

c++ -c -x c++ -O3 -ffunction-sections -fdata-sections -I./ -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -I/usr/X11R6/include/gtk-2.0 -I/usr/X11R6/include/glib-2.0 -I/usr/X11R6/lib/glib-2.0/include -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include/cairo -I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include/atk-1.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gtkglext-1.0 -I/usr/lib/gtkglext-1.0/include -I/usr/lib/i386-linux-gnu/glib-2.0/include -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/lib/i386-linux-gnu/gtk-2.0/include -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -DflagGUI -DflagMT -DflagGCC -DflagSHARED -DflagLINUX -DflagPOSIX -DflagMAIN ide/About.cpp -o _out/ide//home/upp/Scripts/GCCMK.bm-Gcc-Gui-Linux-Main-Mt-Po six-Shared/About.o
ide/About.cpp:11:24: fatal error: build_info.h: No such file or directory
#include <build_info.h>
^
compilation terminated.
make[1]: *** [_out/ide//home/upp/Scripts/GCCMK.bm-Gcc-Gui-Linux-Main-Mt-P osix-Shared/About.o] Error 1
make[1]: Leaving directory `/home/svn/P101/trunk/Upp/upp-x11-src-8756/uppsrc'
cp: cannot stat 'uppsrc/ide.out': No such file or directory
make: *** [all] Error 1
Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44938 is a reply to message #44937] Mon, 27 July 2015 07:30 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Hi jfranks,

File build_info.h is generated by TheIDE when building. It should be overridden by -Dbm{YEAR,DAY,...} on command-line when building from source. But it is not, judging by the error you posted. I'll look at it tonight when I get home from work and try to figure out why.

This code hasn't been touched for months, it is weird that you'd be first to notice that it is broken Smile

Best regards,
Honza
Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44939 is a reply to message #44938] Mon, 27 July 2015 14:40 Go to previous messageGo to next message
jfranks is currently offline  jfranks
Messages: 36
Registered: September 2014
Location: Houston, Texas
Member
Hi Honza,

Maybe this will help . . .

The upp-x11-8227-src.tar.gz stable release compiles without error.

--jlf
Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44941 is a reply to message #44939] Mon, 27 July 2015 16:00 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 644
Registered: September 2012
Location: Poland, Kraków
Contributor
Hi Honza,

It is probably broken due to additional information in "About" window about compilation time. It is introduce in version 8730, so it is generally new bug.

When you change makefile infrastructure please add support for multi core compilations (We discussed this in another thread some time ago). I remember that compilation upp in one thread can took ages.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.

[Updated on: Mon, 27 July 2015 16:02]

Report message to a moderator

Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44942 is a reply to message #44938] Mon, 27 July 2015 16:33 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12122
Registered: November 2005
Ultimate Member
dolik.rce wrote on Mon, 27 July 2015 07:30
Hi jfranks,

File build_info.h is generated by TheIDE when building. It should be overridden by -Dbm{YEAR,DAY,...} on command-line when building from source. But it is not, judging by the error you posted. I'll look at it tonight when I get home from work and try to figure out why.

This code hasn't been touched for months, it is weird that you'd be first to notice that it is broken Smile

Best regards,
Honza


Sorry, I have touched it recently... My error, with unintended consequences Sad

For now, I remove that include. We can live without compilation date for some more time... Smile

Mirek
Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44944 is a reply to message #44942] Mon, 27 July 2015 17:43 Go to previous messageGo to next message
jfranks is currently offline  jfranks
Messages: 36
Registered: September 2014
Location: Houston, Texas
Member
Mirek,

Thank you for responding.

This may help to narrow down the issue . . .
I have determined that the nightly build of upp-x11-src-8741.tar.gz
is where the compile issue started.

The nightly build of upp-x11-src-8726.tar.gz compiles okay.

--jlf
Re: Installation error for tarball upp-x11-src-8756.tar.gz [message #44946 is a reply to message #44944] Mon, 27 July 2015 21:46 Go to previous message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
Am I right in thinking that UPP will not build/install under KDE?

I just tried to get upp running on a CentOS 6.4 VM and am not having any luck and I am now thinking that this is the reason.

Nick
Previous Topic: IDE not retaining SDK path
Next Topic: Installing UPP on Centos 6.4
Goto Forum:
  


Current Time: Wed Dec 11 18:34:26 CET 2019

Total time taken to generate the page: 0.01115 seconds