Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Mac OSX » theide.app with apple style menus
Re: theide.app with apple style menus [message #50772 is a reply to message #50766] Fri, 14 December 2018 15:19 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 702
Registered: December 2006
Contributor
mirek wrote on Fri, 14 December 2018 03:52
Keys issue should be now fixed in trunk. (I forgot to implement menu hotkeys at U++ side with Cocoa menus...)

Thanks!
Keys work fine now.
Menu works when ide is launched from "Aplications".
When it is launched from command line I need to switch to another app and back to make it work.
Another observation: there is something, probably, wrong with dependency tracking because I was getting the "Invalid memory access!" error message after I compiled new code and tried to launch ide. Complete recompilation fixed the problem.


Regards,
Novo
Re: theide.app with apple style menus [message #50773 is a reply to message #50772] Fri, 14 December 2018 16:02 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11671
Registered: November 2005
Ultimate Member
Novo wrote on Fri, 14 December 2018 15:19
mirek wrote on Fri, 14 December 2018 03:52
Keys issue should be now fixed in trunk. (I forgot to implement menu hotkeys at U++ side with Cocoa menus...)

Thanks!
Keys work fine now.
Menu works when ide is launched from "Aplications".
When it is launched from command line I need to switch to another app and back to make it work.


Yes, I have actually spent on this about two weeks before I have found that menu does not work right in command-line....

Quote:

Another observation: there is something, probably, wrong with dependency tracking because I was getting the "Invalid memory access!" error message after I compiled new code and tried to launch ide. Complete recompilation fixed the problem.


Yes, the CtrlCore code seems to be too confusing for current dependency system. "known issue".

Mirek

[Updated on: Fri, 14 December 2018 16:02]

Report message to a moderator

Re: theide.app with apple style menus [message #50797 is a reply to message #50747] Fri, 21 December 2018 18:20 Go to previous message
mirek is currently offline  mirek
Messages: 11671
Registered: November 2005
Ultimate Member
unodgs wrote on Tue, 11 December 2018 20:58
Looks very nice! But there is a problem with dark mode:
Normal buttons have no label and overall contrast is too high.


Label fixed, however the appearance of buttons looks like bug in MacOS (they forgot to update the only API they provide for GUI styling).

From what I have seen on the web Qt apps have same ugly buttons in dark. Maybe Qt guys will push Apple to fix that...

One possible solution is to forget about reading styling data from OS and just provide two Mac themes (normal and dark).

Mirek
Previous Topic: The last roadbloack... workaround for NSMenu issue
Goto Forum:
  


Current Time: Sun Jan 20 16:22:01 CET 2019

Total time taken to generate the page: 0.00657 seconds