Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Mac OS » Mac OSX: How to setup U++
Mac OSX: How to setup U++ [message #51349] Wed, 13 March 2019 18:24 Go to next message
forlano is currently offline  forlano
Messages: 1039
Registered: March 2006
Location: Italy
Experienced Contributor
Hello!

I am writing from my new mac mini 2014 Mojave. I switched to mac mini after reading our guru advice. It's a nice machine not expensive.

The question: what to do to setup a U++ workstation?

I need some hint and then I fill the gap... I can't wait to compile my application Cool

Thanks!
Luigi
Re: Mac OSX: How to setup U++ [message #51358 is a reply to message #51349] Thu, 14 March 2019 19:56 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 726
Registered: December 2006
Contributor
Useful links:

How to Install Command Line Tools in Mac OS X (Without Xcode)
Homebrew

Hope this helps.


Regards,
Novo
Re: Mac OSX: How to setup U++ [message #51361 is a reply to message #51358] Fri, 15 March 2019 19:46 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1039
Registered: March 2006
Location: Italy
Experienced Contributor
Novo wrote on Thu, 14 March 2019 19:56
Useful links:

How to Install Command Line Tools in Mac OS X (Without Xcode)
Homebrew

Hope this helps.


Thank you for the reply.

After installing the previous tools I have downloaded the upp-macos.zip. It appeared in the folder Download as theide.app.
At the first run it required me to unlock something to let this external app to run. After it Theide appeared! Cool
I selected the HelloWorld package and it run without problem till the end (there were some warnings although). The HelloWorld app run as expected.

Then I created my MyApps folder with my packages. Then tried to compile one of my program. No success Shocked
In fact all previous assembly (example, bazaar, tutorial, uppsrc) disappeared... or at least became empty in Theide. I was not able to locate them.

Then I have deleted everything and started a fresh download again hoping to recreate the magic. But again Theide was not able to locate all others assembly. What am I missing?

The first thought is that the installation needs some improvement. Now I am trying to do something but whithout to know what to do exactly. Any hint would be very appreciated.

Thanks,
Luigi

EDIT: I have used "Setup / Checkout SVN..." and then downloaded everything. The assembly appeared! Now I am trying to compile my program.
Rolling Eyes

[Updated on: Fri, 15 March 2019 20:42]

Report message to a moderator

Re: Mac OSX: How to setup U++ [message #51401 is a reply to message #51361] Thu, 21 March 2019 22:07 Go to previous message
forlano is currently offline  forlano
Messages: 1039
Registered: March 2006
Location: Italy
Experienced Contributor
Hello,

I was able to compile my package (now testing it).

To compile X11 program I had to install Xquartz

https://www.xquartz.org/index.html

that provide a X11 replacement that is not included in Mojave.
Then I needed to run in the terminal the command

ln -s /opt/X11/include/X11 /usr/local/include/X11

to let the compiler find the files.
Then I needed to modify the include and library path in Theide to point correctly to the include and lib folder.

Luigi
Previous Topic: Cannot compile plugin/ftp
Goto Forum:
  


Current Time: Fri Mar 22 00:53:24 CET 2019

Total time taken to generate the page: 0.01187 seconds