Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Other Features Wishlist and/or Bugs » ide/editor usability issues
Re: ide/editor usability issues [message #51266 is a reply to message #51265] Tue, 26 February 2019 09:44 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 163
Registered: July 2009
Experienced Member

okay just done that and all seem to work as it should:
check-box appears in the menu
code-wordwrap is disabled by default
toggles with menu-select and with alt+w, and wraps when set

What is different when the svn is compiled that makes it not work?
different compiler-flags?
missed includes in the makefile-scripts?
..
Re: ide/editor usability issues [message #51267 is a reply to message #51266] Tue, 26 February 2019 10:10 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11822
Registered: November 2005
Ultimate Member
slashupp wrote on Tue, 26 February 2019 09:44

okay just done that and all seem to work as it should:
check-box appears in the menu
code-wordwrap is disabled by default
toggles with menu-select and with alt+w, and wraps when set

What is different when the svn is compiled that makes it not work?
different compiler-flags?
missed includes in the makefile-scripts?
..


I really would like to know... But at least at this point we know there is a problem.

Perhaps you can try with more recent tarball for starters?

Mirek
Re: ide/editor usability issues [message #51268 is a reply to message #51267] Tue, 26 February 2019 10:20 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 163
Registered: July 2009
Experienced Member

okay getting 12799 - will post when done (3G connection + compile + test ~~~ 1 hour)
Re: ide/editor usability issues [message #51269 is a reply to message #51268] Tue, 26 February 2019 11:16 Go to previous messageGo to next message
slashupp is currently offline  slashupp
Messages: 163
Registered: July 2009
Experienced Member

done testing
still wraps code, no check-box, and cannot toggle wordwrap
Re: ide/editor usability issues [message #51378 is a reply to message #51232] Sun, 17 March 2019 10:12 Go to previous message
mirek is currently offline  mirek
Messages: 11822
Registered: November 2005
Ultimate Member
slashupp wrote on Sun, 24 February 2019 09:11


- rescan file while editing - suggest a tool-button for this because lately there is a lag, half-a-sec to a sec,
between typing and the character appearing on-screen because of rescanning being busy



I believe that I might have optimized something there. In fact, the issue might not have been assist, but updating the main toolbar.

Please test Smile

Mirek
Previous Topic: Disable Assits++ scan on certain files
Goto Forum:
  


Current Time: Fri Apr 19 00:37:47 CEST 2019

Total time taken to generate the page: 0.00846 seconds