Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Layout (Forms) Designer » Layout with raspberry (When i put widget on layout there is compiler error)
Layout with raspberry [message #49550] Tue, 27 February 2018 09:19 Go to next message
picoprof is currently offline  picoprof
Messages: 5
Registered: February 2018
Location: france
Promising Member
Hello,
I'm teacher and I use the ide with my student to learn c++ on windows.
Last month i want to migrate any exercices on raspberry. When a create program without layout designer it was great and all is right.
I create project with layout and the ide launch layout designer with the main design
But when i put widget on layout in layout designer there is Fatal error
i can read /usr/bin/xmessage on console, but the ide crash
What the problem, i'm newbie on raspberry Sad
Re: Layout with raspberry [message #49551 is a reply to message #49550] Tue, 27 February 2018 22:48 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 640
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello and welcome on our forum,

We will investigate the problem - the crash is critical for us. Here is the redmine ticket for the issue - #1848.

Personally, I didn't test layout designer on Rasberry PI, but I will try. I will look at your issue in the next week. To clarify things - you use native build of TheIDE (ARM). Do you? Can you post a screen-shot of crash?

I am glad somebody learns about our framework. Thanks! And don't worry about your skill on Raspberry, everything will come with time Smile

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: Layout with raspberry [message #50425 is a reply to message #49551] Fri, 26 October 2018 13:55 Go to previous messageGo to next message
uppjj is currently offline  uppjj
Messages: 9
Registered: February 2018
Location: France
Promising Member
Hello

I got similar problem.
I'am using Raspberry PI 3B+ with Rasbian Stretch V4.14 (2018-10-9), today the latest version.

With Ultimate++ version 2018.1 (build 11873) the Ide always crash immediately when openning any project for the 2nd time, with this message :
"Fatal error Invalid memory access"

Similar event had already been fixed in 2014, see message 42030 and next, but it seems to appear again with 2018.1 on RPI.

This problem do not exists with Ide version 2017.2 so I recommend to use this version on RPI

JJ

Re: Layout with raspberry [message #52676 is a reply to message #50425] Sat, 09 November 2019 11:23 Go to previous message
uppjj is currently offline  uppjj
Messages: 9
Registered: February 2018
Location: France
Promising Member
Good news, this problem is now solved with the new raspbian 10 "Buster" .

RPI crashed only with raspbian 9 "Stretch" but not with older "Jessie", whatever the version of UPP, contrary to what I indicated in my previous post.

I have tested successfully Theide with RPI3 and RPI4 and "Buster". HYDRA threads must always be reduced to 2 to avoid CPU blocking on the RPI3, but
it's a real pleasure to develop UPP applications with the RPI4 whose power is now approaching PCs .

jj
Previous Topic: [SOLVED] Strange issue with layout
Next Topic: Designer: Tutorial for beginners
Goto Forum:
  


Current Time: Tue Nov 19 06:14:13 CET 2019

Total time taken to generate the page: 0.01622 seconds