Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » U++ Library : Other (not classified elsewhere) » lzma compression does not seem to work
lzma compression does not seem to work [message #53358] Mon, 30 March 2020 20:17 Go to next message
aftershock is currently offline  aftershock
Messages: 141
Registered: May 2008
Experienced Member
#include <Core/Core.h>

using namespace Upp;
#include "plugin/lzma/lzma.h"
CONSOLE_APP_MAIN
{
StringStream ss("something");
StringStream so;
ss.SetLoading();
ss.Seek(0);
/* GZCompress ( so, ss, ss.GetSize(), [](int64 a, int64 b) {
return false;
} );*/
LZMACompress(so,ss,6);
so.SetLoading();
so.Seek(0);
StringStream s2;
// LZMADecompress(s2,so);
// GZDecompress(s2,so);
LZMADecompress(s2,so);
if (ss.GetResult()!=s2.GetResult())
{
int b =3;
}
}

This will execute b= 3, not if you change lines for gz....it does not happen.
This seems to happen when compression level is explicitly given.

[Updated on: Mon, 30 March 2020 20:25]

Report message to a moderator

Re: lzma compression does not seem to work [message #53377 is a reply to message #53358] Tue, 31 March 2020 17:39 Go to previous message
mirek is currently offline  mirek
Messages: 12536
Registered: November 2005
Ultimate Member
int64  LZMACompress(Stream& out, Stream& in, int64 size, Gate2<int64, int64> progress = false, int lvl = 6);


(20 minutes wasted... never mind Smile

[Updated on: Tue, 31 March 2020 17:39]

Report message to a moderator

Previous Topic: cannot use oracle from dll
Next Topic: Core/SSL Having issue with Lets encrypt certificate
Goto Forum:
  


Current Time: Sun Jun 07 08:29:04 CEST 2020

Total time taken to generate the page: 0.00985 seconds