Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Compiling, Linking, Debugging of your packages » [BUG] Umk/TheIDE Last trunk on debian compilation error
[BUG] Umk/TheIDE Last trunk on debian compilation error [message #55758] Tue, 08 December 2020 14:41 Go to next message
Xemuth is currently offline  Xemuth
Messages: 310
Registered: August 2018
Location: France
Senior Member
I just grabbed lastest Nightybuild for Linux/BSD/Solaris
I have checkout my folder with the lastest SVN trunk
then I have run ./install to create umk/TheIDE.

Here is what happen : https://i.imgur.com/RoLIBpF.png


/usr/lib/gcc/i686-linux-gnu/8/include/emmintrin.h:701:1: error: inlining failed in call to always_inline '__m128i _mm_loadu_si128(const __m128i_u*)': target specific option mismatch
 _mm_loadu_si128 (__m128i_u const *__P)
 ^~~~~~~~~~~~~~~

if I do make theide same error happen.

Do the problem come from my system or it come from U++ ?

PS: my system is a fresh Debian + KDE plasma (all dependencies have been installed same for linux-headers)


[Updated on: Tue, 08 December 2020 23:27] by Moderator

Report message to a moderator

Re: Umk/TheIDE Last trunk on debian compilation error [message #55760 is a reply to message #55758] Tue, 08 December 2020 21:41 Go to previous messageGo to next message
Xemuth is currently offline  Xemuth
Messages: 310
Registered: August 2018
Location: France
Senior Member
Found a fix,

according to this post
have to add -msse4.1 to C++ compilation option
(edit makefile and add "-msse4.1" to CXXFLAGS)

PS: of course you can pass this to umk modifying the install.sh file but in my case, since I have modified makefile I had to use "make" in the Upp folder instead of using install.sh


[Updated on: Tue, 08 December 2020 21:43]

Report message to a moderator

Re: Umk/TheIDE Last trunk on debian compilation error [message #55761 is a reply to message #55760] Tue, 08 December 2020 23:26 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 830
Registered: September 2012
Location: Poland, Kraków
Experienced Contributor
Hello Xemuth,

Your porblem is not fixed! We need to make sure that trunk version compiles without any errors, so the finaly user should not apply any patches manually. Thanks for reporting this problem.

I created the ticket #2126 on redmine to track the problem. I also change the thread title from RESOLVED to BUG.

Klugier


Ultimate++ - one framework to rule them all.

[Updated on: Tue, 08 December 2020 23:28]

Report message to a moderator

Re: Umk/TheIDE Last trunk on debian compilation error [message #55775 is a reply to message #55760] Fri, 11 December 2020 17:22 Go to previous messageGo to next message
mirek is currently online  mirek
Messages: 13054
Registered: November 2005
Ultimate Member
I think this is caused by the fact that you are using 32-bit Linux. Is that correct?
Re: Umk/TheIDE Last trunk on debian compilation error [message #55777 is a reply to message #55775] Fri, 11 December 2020 19:27 Go to previous messageGo to next message
Xemuth is currently offline  Xemuth
Messages: 310
Registered: August 2018
Location: France
Senior Member
mirek wrote on Fri, 11 December 2020 17:22
I think this is caused by the fact that you are using 32-bit Linux. Is that correct?

You are right, it's a 32bit system ! I didnt pay attention to the iso I get Confused I will resetup a fresh 64 bit linux and will tell if the build method work


Re: [BUG] Umk/TheIDE Last trunk on debian compilation error [message #55779 is a reply to message #55758] Sat, 12 December 2020 00:20 Go to previous messageGo to next message
Xemuth is currently offline  Xemuth
Messages: 310
Registered: August 2018
Location: France
Senior Member
problem dont occure in a 64bit system

Re: [BUG] Umk/TheIDE Last trunk on debian compilation error [message #55808 is a reply to message #55779] Wed, 16 December 2020 11:17 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 830
Registered: September 2012
Location: Poland, Kraków
Experienced Contributor
Hello Mirek,

Do we want to abandon 32-bit Linux? I think the current approch is to do not provied binaries for Windows, but TheIDE should be able to create 32-bit binary without the problem. 2019.2 release 32-bit TheIDE should be able to work with latest sources.

My question here is - do we want to fix this compilation issue or we just wanted to said that 32-bit linux is not supported any more?

Klugier


Ultimate++ - one framework to rule them all.
Re: [BUG] Umk/TheIDE Last trunk on debian compilation error [message #55809 is a reply to message #55808] Wed, 16 December 2020 15:56 Go to previous message
mirek is currently online  mirek
Messages: 13054
Registered: November 2005
Ultimate Member
Klugier wrote on Wed, 16 December 2020 11:17
Hello Mirek,

Do we want to abandon 32-bit Linux? I think the current approch is to do not provied binaries for Windows, but TheIDE should be able to create 32-bit binary without the problem. 2019.2 release 32-bit TheIDE should be able to work with latest sources.

My question here is - do we want to fix this compilation issue or we just wanted to said that 32-bit linux is not supported any more?

Klugier


I think there is a trivial fix by disabling SSE2 routines in CPU_32/POSIX combo.
Previous Topic: MtRpcServer package compilation fail
Goto Forum:
  


Current Time: Wed Jan 27 17:17:34 CET 2021

Total time taken to generate the page: 0.01564 seconds