Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » UppHub » GDAL status
GDAL status [message #59509] Tue, 10 January 2023 15:58 Go to next message
Tom1
Messages: 1221
Registered: March 2007
Senior Contributor
Hi,

I have been using GDAL for quite some time. Several years ago I switched from GDAL source distribution to using U++ package plugin/gdal. This was a great improvement. I also managed to enable support for some file formats not initially supported. After some time I even upgraded the GDAL source code to version 2.4.4. However, now I tried to upgrade the source tree to gdal-3.6.2, but missing dependencies and other complications are becoming overwhelming for me to solve. Are there any plans to upgrade the current UppHub package for plugin/gdal?

As an alternative, I'm looking at using gdal 2.4.4 package as is and just create U++ package for latest geotiff and bind to latest libtiff 4.5.0. However, it is not clear to me how should I proceed in a smart way to avoid any trouble.

Any suggestions?

Best regards,

Tom

Re: GDAL status [message #59518 is a reply to message #59509] Sat, 14 January 2023 13:22 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13995
Registered: November 2005
Ultimate Member
Tom1 wrote on Tue, 10 January 2023 15:58
Hi,

I have been using GDAL for quite some time. Several years ago I switched from GDAL source distribution to using U++ package plugin/gdal. This was a great improvement. I also managed to enable support for some file formats not initially supported. After some time I even upgraded the GDAL source code to version 2.4.4. However, now I tried to upgrade the source tree to gdal-3.6.2, but missing dependencies and other complications are becoming overwhelming for me to solve. Are there any plans to upgrade the current UppHub package for plugin/gdal?

As an alternative, I'm looking at using gdal 2.4.4 package as is and just create U++ package for latest geotiff and bind to latest libtiff 4.5.0. However, it is not clear to me how should I proceed in a smart way to avoid any trouble.

Any suggestions?

Best regards,

Tom



If I remember well, the problem with gdal is that they have added dependency on sqlite and external database. Which completly destroys it for our (now speaking about my paying job) purposes. Therefore I decided to stick with obsolete version...

Mirek
Re: GDAL status [message #59519 is a reply to message #59518] Sun, 15 January 2023 00:10 Go to previous message
Tom1
Messages: 1221
Registered: March 2007
Senior Contributor
Hi Mirek,

OK, I see. (I can send you my modified plugin/GDAL with GDAL 2.4.4 if you like, but it's getting old too. I'm also using some OGR parts for vector formats.)

As for the future, I wonder if we could push the plugin/TIF a bit further with GeoTIFFs... Here's my recent post about it:

https://www.ultimatepp.org/forums/index.php?t=msg&th=120 07&goto=59517&#msg_59517

And maybe also upgrade it to using latest libtiff (4.5.0)?

Best regards,

Tom
Previous Topic: Splash screen package
Next Topic: MessageCtrl: A passive notifications ctrl and manager.
Goto Forum:
  


Current Time: Fri Jul 19 20:58:08 CEST 2024

Total time taken to generate the page: 0.01436 seconds