Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Extra libraries, Code snippets, applications etc. » OS Problems etc., Win32, POSIX, MacOS, FreeBSD, X11 etc » Why glibc-2.4 and not glibc-2.3 is needed for U++ on Linux?
Why glibc-2.4 and not glibc-2.3 is needed for U++ on Linux? [message #8231] Thu, 22 February 2007 12:48 Go to next message
mikisha is currently offline  mikisha
Messages: 2
Registered: February 2007
Junior Member
Hi All,
Why glibc-2.4 and not glibc-2.3 is needed for U++ on Linux? I have checked that today only a few distros are packaged with glibc-2.4, for instance Ubuntu Edge. I would like to give U++ a try on Linux. I have been using Debian Etch for a long time but Etch lacks of glibc-2.4 and it has glibc-2.3.6 instead. I am satisfied with it and I do not want now to change it for Ubuntu Edge only for giving U++ a try.
So my question is: Is it possible somehow to run U++ on Linux distro with glibc-2.3? Of course I know I could run Ubuntu Edge from live dvd without installing (of course, I have to get it first) but I would like to run it on my Debian Etch.
Re: Why glibc-2.4 and not glibc-2.3 is needed for U++ on Linux? [message #8232 is a reply to message #8231] Thu, 22 February 2007 14:12 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Try the latest deb. It works on glib-2.3 systems too.
I'm running Debian unstable.

Once you got a working copy of TheIDE, you can easily
upgrade from sources later on, if you want to. Don't
need to, though.
The toolkit has to be build locally with every upgrade
anyhow. The packages only have TheIDE in binary form.

Guido
Re: Why glibc-2.4 and not glibc-2.3 is needed for U++ on Linux? [message #8235 is a reply to message #8232] Fri, 23 February 2007 01:29 Go to previous message
mikisha is currently offline  mikisha
Messages: 2
Registered: February 2007
Junior Member
Thank you for your suggestion. The latest development u++ deb package works in my Debian Etch. I must have missed it during my previous tries. During install '#dpkg -i <pkg.deb>' it wanted the following depends: stdlibc6++-dev >=3.4.6 and g++-3.4 >=3.4.6 but for unknown reason I could not manage to install them. Anyhow u++ package has been installed and now I can run it and test it. Thanks once more for your quick reply.
Previous Topic: some drawing problems in X11
Next Topic: Building with LSB-SDK
Goto Forum:
  


Current Time: Fri Oct 18 15:20:07 CEST 2019

Total time taken to generate the page: 0.00902 seconds