Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Coffee corner » MSC9 and c++11
MSC9 and c++11 [message #49186] Thu, 04 January 2018 12:19 Go to next message
forlano is currently offline  forlano
Messages: 1049
Registered: March 2006
Location: Italy
Experienced Contributor
Hello,

on an old laptop I have a MSC9 compiler installed in 2014.
I tried to compile the latest U++ but it fails:

C:\upp/uppsrc\Core/Core.h (45): fatal error C1189: #error : This version of U++ REQUIRES C++11

I tried to add the compiler option

/std:c++11

and still complain:

cl : Command line warning D9002 : ignoring unknown option '/std:c++11'

Can that version compile the new U++ or I must get rid it?
Thanks,
Luigi
Re: MSC9 and c++11 [message #49187 is a reply to message #49186] Thu, 04 January 2018 12:40 Go to previous message
Klugier is currently offline  Klugier
Messages: 615
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello,

You must update your compiler. MSC9 is too old to work with the latest version of the U++, it is even to old for the previous release. Just grab Visual Studio 2017 community edition and enjoy latest version of U++ Smile

Please read following topic: https://www.ultimatepp.org/app$ide$install$en-us.html.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.

[Updated on: Thu, 04 January 2018 12:43]

Report message to a moderator

Previous Topic: some good audio library?
Next Topic: Windows Meltdown patch and compilation speed
Goto Forum:
  


Current Time: Thu Apr 25 04:42:17 CEST 2019

Total time taken to generate the page: 0.01221 seconds