Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Mac OSX » theide.app with apple style menus
theide.app with apple style menus [message #50735] Tue, 11 December 2018 11:34 Go to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
https://drive.google.com/open?id=1GL54WNMKRpEPLsafkDbNvXGw1w SG_Z4Z

I see the light at the end of the tunnel Smile

Only two major issues to resolve now:

- converting exported icons to bundle icns file
- debugger support

Re: theide.app with apple style menus [message #50737 is a reply to message #50735] Tue, 11 December 2018 14:29 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 590
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello,

Today, I try to launch new ide executable and i found following problem while running the app (TheIDE doesn't start):
Process:               newide2 [663]
Path:                  /Users/USER/*/theide.app/Contents/MacOS/newide2
Identifier:            newide2
Version:               0
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           newide2 [663]
User ID:               502

Date/Time:             2018-12-11 14:25:01.556 +0100
OS Version:            Mac OS X 10.14.2 (18C54)
Report Version:        12
Bridge OS Version:     3.2 (16P2542)
Anonymous UUID:        3F4FE116-7AB0-CA0A-63D1-63D585F746EE


Time Awake Since Boot: 320 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Library not loaded: /usr/local/opt/libpng/lib/libpng16.16.dylib
  Referenced from: /Users/USER/*/theide.app/Contents/MacOS/newide2
  Reason: image not found

Binary Images:
       0x101028000 -        0x101afcff7 +newide2 (0) <C79FF830-85DE-38CC-BA55-03DCE86CD8F1> /Users/USER/*/theide.app/Contents/MacOS/newide2
       0x10ad29000 -        0x10ada7a67  dyld (640.2) <289AB27E-F09F-3384-A14A-100431139559> /usr/lib/dyld
    0x7fff2cdb4000 -     0x7fff2cdb4fff  com.apple.Carbon (158 - 158) <D6170F31-7A8A-3D4F-91DA-E11CF33E62B4> /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon
    0x7fff2d2cf000 -     0x7fff2d2cffff  com.apple.Cocoa (6.11 - 23) <D0BED932-C061-33E9-9F59-ECE0BA9F7EEB> /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa
    0x7fff2fe77000 -     0x7fff30245fff  com.apple.Foundation (6.9 - 1561) <27FD022F-F0E3-3053-BADA-DF9BF856CA85> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
    0x7fff581e3000 -     0x7fff581e4ffb  libSystem.B.dylib (1252.200.5) <25F4A1F5-6551-312F-B397-C8D45ACC530A> /usr/lib/libSystem.B.dylib
    0x7fff5842e000 -     0x7fff5843cfff  libbz2.1.0.dylib (38.200.3) <4DEC3797-087F-3C8D-815B-48E895813251> /usr/lib/libbz2.1.0.dylib
    0x7fff5ab6d000 -     0x7fff5ab7fffb  libz.1.dylib (70.200.4) <15F7B40A-424C-33BB-BF2C-7E8195128B78> /usr/lib/libz.1.dylib



It seems that the following problem cause the crash:
Dyld Error Message:
  Library not loaded: /usr/local/opt/libpng/lib/libpng16.16.dylib
  Referenced from: /Users/USER/*/theide.app/Contents/MacOS/newide2
  Reason: image not found


Sincerely,
Klugier


Ultimate++ - one framework to rule them all.

[Updated on: Tue, 11 December 2018 14:45]

Report message to a moderator

Re: theide.app with apple style menus [message #50738 is a reply to message #50735] Tue, 11 December 2018 17:45 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
mirek wrote on Tue, 11 December 2018 05:34

I see the light at the end of the tunnel Smile


Thank you.

When I launched newly recompiled ide, I was unable to use both menu and keyboard. For example, I was unable to change main package using keyboard. After some period of random clicking, pressing keys, and switching windows I managed to make menu and keyboard work. After some time I got into situation when menu works but keyboard doesn't.

I couldn't figure out a pattern.


Regards,
Novo
Re: theide.app with apple style menus [message #50739 is a reply to message #50738] Tue, 11 December 2018 18:13 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Novo wrote on Tue, 11 December 2018 17:45
mirek wrote on Tue, 11 December 2018 05:34

I see the light at the end of the tunnel Smile


Thank you.

When I launched newly recompiled ide, I was unable to use both menu and keyboard. For example, I was unable to change main package using keyboard. After some period of random clicking, pressing keys, and switching windows I managed to make menu and keyboard work. After some time I got into situation when menu works but keyboard doesn't.

I couldn't figure out a pattern.


Did you recompile or have you downloaded the recent one? It looks like due to apple bug, menu does not work unless it is application bundle (which now theide generates).

Mirek

Re: theide.app with apple style menus [message #50740 is a reply to message #50739] Tue, 11 December 2018 18:29 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
mirek wrote on Tue, 11 December 2018 12:13
Novo wrote on Tue, 11 December 2018 17:45
mirek wrote on Tue, 11 December 2018 05:34

I see the light at the end of the tunnel Smile


Thank you.

When I launched newly recompiled ide, I was unable to use both menu and keyboard. For example, I was unable to change main package using keyboard. After some period of random clicking, pressing keys, and switching windows I managed to make menu and keyboard work. After some time I got into situation when menu works but keyboard doesn't.

I couldn't figure out a pattern.


Did you recompile or have you downloaded the recent one? It looks like due to apple bug, menu does not work unless it is application bundle (which now theide generates).

Mirek



I recompiled it (I always do). My setup:

/Users/XXX/dvlp/cpp/code/upp/git/out/uppsrc/CLANG.Blitz.Gui.Nogtk.Shared/ide.app/Contents/MacOS/ide (15260788 B) is up to date.

$ which ide
/Users/XXX/local/bin/ide
$ ls -l /Users/XXX/local/bin/ide
lrwxr-xr-x  1 XXX  staff  104 Nov 27 19:38 /Users/XXX/local/bin/ide -> /Users/XXX/dvlp/cpp/code/upp/git/out/uppsrc/CLANG.Blitz.Gui.Nogtk.Shared/ide.app/Contents/MacOS/ide


Is there something wrong with my setup?


Regards,
Novo
Re: theide.app with apple style menus [message #50741 is a reply to message #50740] Tue, 11 December 2018 18:44 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Novo wrote on Tue, 11 December 2018 18:29
mirek wrote on Tue, 11 December 2018 12:13
Novo wrote on Tue, 11 December 2018 17:45
mirek wrote on Tue, 11 December 2018 05:34

I see the light at the end of the tunnel Smile


Thank you.

When I launched newly recompiled ide, I was unable to use both menu and keyboard. For example, I was unable to change main package using keyboard. After some period of random clicking, pressing keys, and switching windows I managed to make menu and keyboard work. After some time I got into situation when menu works but keyboard doesn't.

I couldn't figure out a pattern.


Did you recompile or have you downloaded the recent one? It looks like due to apple bug, menu does not work unless it is application bundle (which now theide generates).

Mirek



I recompiled it (I always do). My setup:

/Users/XXX/dvlp/cpp/code/upp/git/out/uppsrc/CLANG.Blitz.Gui.Nogtk.Shared/ide.app/Contents/MacOS/ide (15260788 B) is up to date.

$ which ide
/Users/XXX/local/bin/ide
$ ls -l /Users/XXX/local/bin/ide
lrwxr-xr-x  1 XXX  staff  104 Nov 27 19:38 /Users/XXX/local/bin/ide -> /Users/XXX/dvlp/cpp/code/upp/git/out/uppsrc/CLANG.Blitz.Gui.Nogtk.Shared/ide.app/Contents/MacOS/ide


Is there something wrong with my setup?


The recompile again using the new ide...

(Or download from the link).

Mirek
Re: theide.app with apple style menus [message #50742 is a reply to message #50741] Tue, 11 December 2018 19:48 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
mirek wrote on Tue, 11 December 2018 12:44
The recompile again using the new ide...

(Or download from the link).


Tried to recompile with a newly compiled ide ...
Tried downloaded version (copied over config files from the old ide) ...

Got the same result in both cases: menu and keyboard (at least command-key) do not work (at least initially).

MacOS High Sierra
Version 10.13.6
-std=c++14


Regards,
Novo
Re: theide.app with apple style menus [message #50743 is a reply to message #50742] Tue, 11 December 2018 20:09 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
Tried to copy your precompiled app into Application - it won't event launch because it requires macOS 10.14 (can be launched from command line).
Tried to copy my recompiled app into Application - menu works, but keyboard (at least command-m) doesn't.


Regards,
Novo
Re: theide.app with apple style menus [message #50744 is a reply to message #50743] Tue, 11 December 2018 20:27 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Novo wrote on Tue, 11 December 2018 20:09
Tried to copy your precompiled app into Application - it won't event launch because it requires macOS 10.14 (can be launched from command line).
Tried to copy my recompiled app into Application - menu works, but keyboard (at least command-m) doesn't.


Thanks. Thats weird - info.plist requires 10.13, please check...

I can put about anything to info.plist - if you find the right combination, I will gladly use it. Just be aware that stupic Mac is caching it, so simply changing info.plist is not enough (I really do not know what IS enough, but google search recommends moving .app to another folder in Finder, as stupid as it sounds).
Re: theide.app with apple style menus [message #50745 is a reply to message #50744] Tue, 11 December 2018 20:28 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
P.S.: Please do not upgrade to 10.14 before we resolve this Smile

Mirek
Re: theide.app with apple style menus [message #50746 is a reply to message #50745] Tue, 11 December 2018 20:29 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
P.P.S.: Some keys do not work right now, it is "todo".
Re: theide.app with apple style menus [message #50747 is a reply to message #50746] Tue, 11 December 2018 20:58 Go to previous messageGo to next message
unodgs is currently offline  unodgs
Messages: 1353
Registered: November 2005
Location: Poland
Senior Contributor

Looks very nice! But there is a problem with dark mode:
index.php?t=getfile&id=5724&private=0
Normal buttons have no label and overall contrast is too high.

Re: theide.app with apple style menus [message #50748 is a reply to message #50747] Tue, 11 December 2018 21:30 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Here comes a new version:

https://drive.google.com/open?id=1amN6e1lNw3urd2kGRSM1D0z0z3 iqL5rv

libpng dependency removed, and we now have icns...
Re: theide.app with apple style menus [message #50749 is a reply to message #50747] Tue, 11 December 2018 21:34 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Well, if dark mode would be the worst issue, I would be glad... Smile Will fix it in time..
Re: theide.app with apple style menus [message #50750 is a reply to message #50744] Tue, 11 December 2018 21:35 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
mirek wrote on Tue, 11 December 2018 14:27

Thanks. Thats weird - info.plist requires 10.13, please check...

I do not know where this is coming from. Output of "otool -L" looks fine.

index.php?t=getfile&id=5725&private=0


Regards,
Novo
Re: theide.app with apple style menus [message #50751 is a reply to message #50746] Tue, 11 December 2018 21:43 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
mirek wrote on Tue, 11 December 2018 14:29
P.P.S.: Some keys do not work right now, it is "todo".

New discoveries:

command-m
command-/
command-\
These three do not work till you click on the "File" menu. It looks like it "enables" these combinations.

ESC doesn't work in any case...

command-b works without clicking on "Edit".


Regards,
Novo
Re: theide.app with apple style menus [message #50752 is a reply to message #50749] Tue, 11 December 2018 21:55 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 590
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello Mirek and Daniel,

The dark mode requires changes under the application layer. One of the reason why dark themes doesn't look cool (on Linux or on mac) is that we do not have monochromatic icons or alternative icons set for dark. Moreover, we should also support dark mode for the "Standard" theme. Some users, might want to use dark ide without explicitly switching colors in system settings. I think now with wide support of dark themes all over the operating system word, this behavior will be less common. However, in my opinion dark "Standard" theme is something that we should support in the future.

Backing to macOS, I am relay glad to see community engagement in testing Mireks new binaries. Just after several hours after posting so many people tested it and provide constructive feedback. Awesome job guys Wink

I will test png issue tomorrow.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: theide.app with apple style menus [message #50754 is a reply to message #50747] Tue, 11 December 2018 22:13 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 706
Registered: December 2006
Contributor
unodgs wrote on Tue, 11 December 2018 14:58
Looks very nice! But there is a problem with dark mode:

There is also a problem with the GridCtrl Smile
There is no grid at all, at least in my case with GridCtrlTest ...


Regards,
Novo
Re: theide.app with apple style menus [message #50764 is a reply to message #50754] Thu, 13 December 2018 20:35 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 590
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello Mirek,

I just noticed that tab bar in build methods doesn't work. It doesn't allow to change tabs. I don't know it is general problem with TabBar, beacuse the tab switching works correctly inside TheIDE.

Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: theide.app with apple style menus [message #50766 is a reply to message #50743] Fri, 14 December 2018 09:52 Go to previous messageGo to previous message
mirek is currently offline  mirek
Messages: 11700
Registered: November 2005
Ultimate Member
Novo wrote on Tue, 11 December 2018 20:09
Tried to copy your precompiled app into Application - it won't event launch because it requires macOS 10.14 (can be launched from command line).
Tried to copy my recompiled app into Application - menu works, but keyboard (at least command-m) doesn't.


Keys issue should be now fixed in trunk. (I forgot to implement menu hotkeys at U++ side with Cocoa menus...)
Previous Topic: The last roadbloack... workaround for NSMenu issue
Next Topic: LLDB showstopper
Goto Forum:
  


Current Time: Sat Feb 16 12:10:44 CET 2019

Total time taken to generate the page: 0.00721 seconds