Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Coffee corner » GLCtrl Linux dependency
GLCtrl Linux dependency [message #56763] Mon, 12 April 2021 09:52 Go to next message
Tom1
Messages: 956
Registered: March 2007
Experienced Contributor
Hi,

I just compiled reference/OpenGL on Linux Mint for testing if pen works on GLCtrl. Well, the pen worked, but in order to compile this reference code (or anything else using GLCtrl), I had to install an additional dependency with:
sudo apt-get install libglu1-mesa-dev

So the question is: Should this be installed with default U++ POSIX installer? Or is it intentionally left out as it is not required for building TheIDE?

Best regards,

Tom
Re: GLCtrl Linux dependency [message #56768 is a reply to message #56763] Wed, 14 April 2021 13:30 Go to previous messageGo to next message
Xemuth is currently offline  Xemuth
Messages: 365
Registered: August 2018
Location: France
Senior Member
Hello Tom1,

If I remember well, the fact you need to install mesa to allow openGL to work depend on your linux distribution.
Some come with everything to compile the GLCtrl example. I will give it a try on my debian to see if I encounter the same problem


Re: GLCtrl Linux dependency [message #56769 is a reply to message #56768] Wed, 14 April 2021 14:55 Go to previous messageGo to next message
Tom1
Messages: 956
Registered: March 2007
Experienced Contributor
Hi Xemuth,

It's interesting to hear if Debian comes with GLU by default. (It is really just GLU needed by GLEW that is missing here.)

However, I guess this is mostly a policy question for U++ POSIX installation script maintainers to decide, if OpenGL dependencies required for GLCtrl should be included in the script or not. I.e. if it is enough to only satisfy dependencies for TheIDE and umk, or alternatively for all packages included in uppsrc.

Thanks and best regards,

Tom
Re: GLCtrl Linux dependency [message #56774 is a reply to message #56769] Thu, 15 April 2021 08:57 Go to previous messageGo to next message
mirek is currently online  mirek
Messages: 13441
Registered: November 2005
Ultimate Member
Tom1 wrote on Wed, 14 April 2021 14:55
Hi Xemuth,

It's interesting to hear if Debian comes with GLU by default. (It is really just GLU needed by GLEW that is missing here.)

However, I guess this is mostly a policy question for U++ POSIX installation script maintainers to decide, if OpenGL dependencies required for GLCtrl should be included in the script or not. I.e. if it is enough to only satisfy dependencies for TheIDE and umk, or alternatively for all packages included in uppsrc.

Thanks and best regards,

Tom


Not, for simple reason: there are too many variations, it is hard enough to get theide requirements half-right...
Re: GLCtrl Linux dependency [message #56778 is a reply to message #56774] Thu, 15 April 2021 09:54 Go to previous message
Tom1
Messages: 956
Registered: March 2007
Experienced Contributor
Hi Mirek,

Thanks for your words. It's fine with me it's not included by default. Just wanted to point it out just in case this was not the intended policy.

For those looking for missing dependencies on Ubuntu family of Linux systems may benefit from using dpkg command as follows to find the missing packages. Here's an example for finding a package containing GL/glu.h:
$ dpkg -S GL/glu.h
libglu1-mesa-dev:amd64: /usr/include/GL/glu.h

Best regards,

Tom
Previous Topic: Load dll with U++
Next Topic: operation with ascii table character (Pascal x C++/U++)
Goto Forum:
  


Current Time: Tue Oct 19 19:36:30 CEST 2021

Total time taken to generate the page: 0.01018 seconds