Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » TabCtrl » Problems with the visualization of tabctrl in 608-dev1
Problems with the visualization of tabctrl in 608-dev1 [message #4819] Wed, 23 August 2006 01:44 Go to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
Hello,

the application now does not crash, but all my beautiful tabctrls are disappeared and I cannot use the app!

In 607-dev1 I used
tabs.Set(2, false);
to set the focus on page 2 but now seems I must remove the second argument. The layout file now looks darker than previous version.
The "TabCtrl tabs" is connected with the splitter in this way:
VegaMain::VegaMain()
{
	CtrlLayout(*this, VERSION);
	spls.Vert();
	spls.SetPos(8500);
	spls.Add(tabs);
	spls.Add(consoleFrame);
   
	SetBars();
	SetTabs();
	Init();
	BackPaint();
	this->WhenClose = THISBACK(Exit); // prevent the closure
}

that should be OK. So for the moment I'm a bit confused. Tomorrow I'll inquire better to understand why the tabctrl are not displayed with the splitter with some minimalist example.

Luigi
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4834 is a reply to message #4819] Wed, 23 August 2006 12:00 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11713
Registered: November 2005
Ultimate Member
BTW, what was the cause of crashing?

All of my TabCtrls are still working well; I am waiting for example.

I am sorry for causing troubles.

Mirek
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4836 is a reply to message #4819] Wed, 23 August 2006 12:07 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
forlano wrote on Wed, 23 August 2006 01:44

Hello,

the application now does not crash, but all my beautiful tabctrls are disappeared and I cannot use the app!

In 607-dev1 I used
tabs.Set(2, false);
to set the focus on page 2 but now seems I must remove the second argument. The layout file now looks darker than previous version.
The "TabCtrl tabs" is connected with the splitter in this way:
VegaMain::VegaMain()
{
	CtrlLayout(*this, VERSION);
	spls.Vert();
	spls.SetPos(8500);
	spls.Add(tabs);
	spls.Add(consoleFrame);
   
	SetBars();
	SetTabs();
	Init();
	BackPaint();
	this->WhenClose = THISBACK(Exit); // prevent the closure
}

that should be OK. So for the moment I'm a bit confused. Tomorrow I'll inquire better to understand why the tabctrl are not displayed with the splitter with some minimalist example.

Luigi


I'm afraid there is some serius problem in the interaction between splitter and tabctrl. Attached is my old example code posted somewhere in the forum that worked nicely. The relevant file in main.cpp. With respect the previous version I have added the IsNull() in place of '=='. The tabctrl simply do not longer appear with 608-dev1.

I do not think it is the setting of my compiler. I'll be grateful if somebody running 608-dev1 could check how it looks (is there a tabctrl at the start of the application?).

Luigi
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4838 is a reply to message #4834] Wed, 23 August 2006 12:12 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
luzr wrote on Wed, 23 August 2006 12:00

BTW, what was the cause of crashing?


I removed that cause (a C style string passed to a function that waited a String). Now works but not as it should work.
I'm sorry for wasting your time but it looks very strange. Same compiler, same code, same procedure to install the distro, but opposite result.

Luigi
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4840 is a reply to message #4838] Wed, 23 August 2006 13:11 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
I've just run your app. Try to click on maximize button and check if all the functionality returns.
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4843 is a reply to message #4840] Wed, 23 August 2006 13:33 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Wed, 23 August 2006 13:11

I've just run your app. Try to click on maximize button and check if all the functionality returns.

Yes, it works! even the real application works. Then clik again and come to standard dimension with all functions.
What is it happening?
Thank you

Luigi
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4851 is a reply to message #4843] Wed, 23 August 2006 14:58 Go to previous messageGo to next message
fudadmin is currently offline  fudadmin
Messages: 1298
Registered: November 2005
Location: London, UK
Senior Contributor
Administrator
forlano wrote on Wed, 23 August 2006 12:33

fudadmin wrote on Wed, 23 August 2006 13:11

I've just run your app. Try to click on maximize button and check if all the functionality returns.

Yes, it works! even the real application works. Then clik again and come to standard dimension with all functions.
What is it happening?
Thank you

Luigi


I don't know what's happening... Smile but
for the new 608 this should help:


VegaMain::VegaMain()
{
	CtrlLayout(*this, "Forlano Vega Main");
	spls.Vert();
	spls.SetPos(8000);
	spls.Add(tabs);
	spls.Add(consoleFrame);
	spls.AddFrame(NullFrame()); //FIX for 608 or add any frame
...


P.S if this dosn't help, tell (maybe I've forgotten more...)
Aris
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4852 is a reply to message #4851] Wed, 23 August 2006 15:04 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
fudadmin wrote on Wed, 23 August 2006 14:58


I don't know what's happening... Smile but
for the new 608 this should help:


VegaMain::VegaMain()
{
	CtrlLayout(*this, "Forlano Vega Main");
	spls.Vert();
	spls.SetPos(8000);
	spls.Add(tabs);
	spls.Add(consoleFrame);
	spls.AddFrame(NullFrame()); //FIX for 608 or add any frame
...





Yes, it works!
One day I'll understand why, but for the moment I'm Very Happy and it is enough.
Thanks,
Luigi
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4899 is a reply to message #4852] Thu, 24 August 2006 17:16 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11713
Registered: November 2005
Ultimate Member
VegaMain::VegaMain()
{
	CtrlLayout(*this, "Forlano Vega Main");
	spls.Vert();
	spls.SetPos(8000);
	spls.Vert(tabs, consoleFrame); // <<<<<<!!!!!
//	spls.Add(tabs);
//	spls.Add(consoleFrame);
	rubbish = " ";

	SetBars();
	SetTabs();
	Init();
	BackPaint();
}


However, this seems to be a kind of glitch in U++ (because Splitter allows more than two panes and you would be required to call Horz or Vert at the end), therefore I have fixed U++ to work even with original code.

Mirek
Re: Problems with the visualization of tabctrl in 608-dev1 [message #4901 is a reply to message #4899] Thu, 24 August 2006 18:12 Go to previous message
forlano is currently offline  forlano
Messages: 1031
Registered: March 2006
Location: Italy
Experienced Contributor
luzr wrote on Thu, 24 August 2006 17:16


However, this seems to be a kind of glitch in U++ (because Splitter allows more than two panes and you would be required to call Horz or Vert at the end), therefore I have fixed U++ to work even with original code.

Mirek


Thanks!
Luigi
Previous Topic: how to move the focus from one tab page to another one
Next Topic: How to get this?
Goto Forum:
  


Current Time: Sat Feb 23 08:08:25 CET 2019

Total time taken to generate the page: 0.00850 seconds