Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » U++ community news and announcements » Upp 610-dev2 released
Upp 610-dev2 released [message #5779] Sun, 15 October 2006 23:51 Go to next message
unodgs is currently offline  unodgs
Messages: 1354
Registered: November 2005
Location: Poland
Senior Contributor

+ Layout designer .usc scripts now able to get images from .iml files
+ Beeps (Information/Exclamation/Error) now implemented in Linux
- "Oversized dialogs" in Linux problem now should be resolved
+ Two new RichText utilities:
RichObject CreateImageObject(const Image& img);
String AsQTF(const RichObject& obj);
+ Added autosetup support for new Windows SDK

Re: Upp 610-dev2 released [message #5800 is a reply to message #5779] Mon, 16 October 2006 20:13 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Could you supply working compile options for gcc/Linux, please!

upp apps segfault here, right after opening the first window.

I'm following development loosely, but picked up, -fexceptions is needed now. I did use this option. So is there something else?

Guido

Re: Upp 610-dev2 released [message #5802 is a reply to message #5800] Mon, 16 October 2006 22:54 Go to previous messageGo to next message
unodgs is currently offline  unodgs
Messages: 1354
Registered: November 2005
Location: Poland
Senior Contributor

I'm sorry, but I'm not a Linux maintainer. However last time I worked with upp in my arch-linux I used standard compilation flags including fexceptions. Everything worked fine.
Re: Upp 610-dev2 released [message #5810 is a reply to message #5802] Tue, 17 October 2006 18:50 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Thanks!
Went into the debugger with it and found the culprit.
In TopWinX11.cpp -> TopWindow:Open() there is a safe-guard missing, when retreiving the frame extents:

Vector<int> fe = GetPropertyInts(top->window, XAtom("_NET_FRAME_EXTENTS"));
	if (fe != NULL)
	{
		windowFrameMargin.left = max(windowFrameMargin.left, fe[0]);
		windowFrameMargin.right = max(windowFrameMargin.right, fe[1]);
		windowFrameMargin.top = max(windowFrameMargin.top, fe[2]);
		windowFrameMargin.bottom = max(windowFrameMargin.bottom, fe[3]);
	}


My window-manager didn't support this hint. So without the pointer safe-guard, like you see I added above, it'll crash.
I made the window-manager support the hint meanwhile. Still, that's reckless programming style Evil or Very Mad

Guido
Re: Upp 610-dev2 released [message #5817 is a reply to message #5810] Wed, 18 October 2006 01:13 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12098
Registered: November 2005
Ultimate Member
Thanks. I am sorry about the style... (OTOH, at least you were forced to add it Smile

BTW, should rather be if(p.GetCount() >= 4)....

Mirek

[Updated on: Wed, 18 October 2006 01:15]

Report message to a moderator

Re: Upp 610-dev2 released [message #5819 is a reply to message #5817] Wed, 18 October 2006 01:51 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Mirek, another problem.

The print dialog stopped being populated at some point - even for old versions of upp, where it used to work. Upgrading to CUPS 1.2.4 might be the cause of breakage, but I'm not sure. I wager the cli interface of the cups tools has changed slightly Confused

Please give me the printer control commands used, so I can try them in a terminal and report back.

Guido
Re: Upp 610-dev2 released [message #5820 is a reply to message #5819] Wed, 18 October 2006 03:11 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
guido wrote on Wed, 18 October 2006 01:51

Mirek, another problem.

The print dialog stopped being populated at some point - even for old versions of upp, where it used to work. Upgrading to CUPS 1.2.4 might be the cause of breakage, but I'm not sure. I wager the cli interface of the cups tools has changed slightly Confused

Please give me the printer control commands used, so I can try them in a terminal and report back.



Got it Cool

The following item in the cups-1.2.4 changelog caught my attention:

- The command-line applications did not convert
command-line strings to UTF-8 as needed (STR #1958)


adding LANG=C to the commands fixes upp printing for me:

"LANG=C lpoptions -l -d "
"LANG=C lpstat -p"
"LANG=C lpstat -d"

Don't know, if that's a proper fix or only a work-around character encoding issues.

Guido

Re: Upp 610-dev2 released [message #5840 is a reply to message #5820] Fri, 20 October 2006 15:27 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12098
Registered: November 2005
Ultimate Member
guido wrote on Tue, 17 October 2006 21:11

guido wrote on Wed, 18 October 2006 01:51

Mirek, another problem.

The print dialog stopped being populated at some point - even for old versions of upp, where it used to work. Upgrading to CUPS 1.2.4 might be the cause of breakage, but I'm not sure. I wager the cli interface of the cups tools has changed slightly Confused

Please give me the printer control commands used, so I can try them in a terminal and report back.



Got it Cool

The following item in the cups-1.2.4 changelog caught my attention:

- The command-line applications did not convert
command-line strings to UTF-8 as needed (STR #1958)


adding LANG=C to the commands fixes upp printing for me:

"LANG=C lpoptions -l -d "
"LANG=C lpstat -p"
"LANG=C lpstat -d"

Don't know, if that's a proper fix or only a work-around character encoding issues.

Guido





Interesting - what is the name of your printer?

(Patch applied).

Mirek

[Updated on: Fri, 20 October 2006 15:33]

Report message to a moderator

Re: Upp 610-dev2 released [message #5844 is a reply to message #5840] Fri, 20 October 2006 16:41 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Hi Mirek!

guido@Sid:~$ lpstat -d
System Standardziel: EPSON_Stylus_Photo_R240_USB_1
guido@Sid:~$ lpstat -p
Drucker EPSON_Stylus_Photo_R240_USB_1 ist frei. freigegeben seit Do 05 Okt 2006 00:37:07 CEST
Drucker r240 ist frei. freigegeben seit Do 05 Okt 2006 17:31:39 CEST

No non-ASCII characters there.
Maybe a line parsing problem, not unicode trouble.

Guido
Re: Upp 610-dev2 released [message #5847 is a reply to message #5844] Fri, 20 October 2006 17:43 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12098
Registered: November 2005
Ultimate Member
Really strange, should not be affected by encoding...

Mirek
Re: Upp 610-dev2 released [message #5848 is a reply to message #5847] Fri, 20 October 2006 22:52 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
luzr wrote on Fri, 20 October 2006 17:43

Really strange, should not be affected by encoding...

Mirek


Ok, upon a closer look, it's really trivial.
The match for "printer" will obviously break in non-English locales:
Vector<String> l = Split(System("lpstat -p"), '\n');
for(int i = 0; i < l.GetCount(); i++) {
	Vector<String> w = Split(l[i], ' ');
	if(w[0] == "printer" && w.GetCount() > 1)
            printer.Add(w[1]);
}



Maybe lpstad -a is easier to parse. Although I'm not quite sure I understand the semantic differences from the -p option:

Vector<String> l = Split(System("lpstat -a"), '\n');
for(int i = 0; i < l.GetCount(); i++) {
	Vector<String> w = Split(l[i], ' ');
	printer.Add(w[0]);
}


Guido
Re: Upp 610-dev2 released [message #5850 is a reply to message #5848] Sat, 21 October 2006 03:20 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12098
Registered: November 2005
Ultimate Member
OK, "-a" then...

Mirek
Re: Upp 610-dev2 released [message #5864 is a reply to message #5850] Sat, 21 October 2006 10:50 Go to previous messageGo to next message
fallingdutch is currently offline  fallingdutch
Messages: 258
Registered: July 2006
Experienced Member
It seems like the Makefile for theIDE is out of date:

It asks for files that aren't included in the uppsrc, like Draw/PixelArray.h and they aren't listed in Draw.upp.

So i guess the zip-archive contains all needed Files.

[update:]
at the beginnin of the Makefile:

OutFile = /home/cxl/ide

should be

OutFile = $(OutDir)ide

Bas

[Updated on: Sat, 21 October 2006 10:54]

Report message to a moderator

Re: Upp 610-dev2 released [message #5867 is a reply to message #5864] Sat, 21 October 2006 14:46 Go to previous message
mirek is currently offline  mirek
Messages: 12098
Registered: November 2005
Ultimate Member
Still the same answer: For development (with *dev* in name) releases, makefile is not maintained. You are supposed to use previous version of TheIDE to build it.
Previous Topic: Quick start issues for new users
Next Topic: Upp 610-dev3 released
Goto Forum:
  


Current Time: Wed Nov 13 13:22:24 CET 2019

Total time taken to generate the page: 0.01513 seconds