Well, I was thinking about all those problems with uderstanding "package" concept and whether they are actually related to bad terminology (I am not native english). Maybe it is time to consider terminology change.
What about "package" -> "unit"? It would remind Deplhi "unit" which is +/- quite correct (AFAIK there is similarity with "uses", and dissimilarity with file vs directory).
What the "nest" should be I am not sure, maybe "folder" or "unit folder" would do.
and I'm especially good at taking every opportunity to misunderstand something - though I still feel the "set main package" option on the file menu is non-intuitive - which is why I tried to emphasize the concept of "main package" in those docs I wrote because the meaning of "main package" is fundamental to U++ and is unheard of in any other IDE where a package usually corresponds to a project. In MS Visual studio, a "solution" is a container for projects.
However I do not think changing package to unit would be an improvement. In C++ Builder (and Delphi) a unit is a pair of source files (.cpp .h or just .pas) and if there is an associated form then there is a .dfm file as well - whereas in U++ a package is a group of source files with an associated package definition file that lists all the source files - i.e. not like a BCB unit at all.
If I had time I would try to find out what wxWidgets calls the groups of source files that build to their own lib.
Apart from "project", the only alternative names I can think of right now are "module" or "component" - neither of which seem like an improvement on package. Changing "package" to "project" would be more intuitive for newbies.
I agree "assembly" is a reasonable name. In the MS dot net world an assembly is "a logical DLL or EXE" - to quote a book I have.
As for "nest" - the only objection I have to that is that it conjures up images of nature and reproduction ... like when Tomas started going on about droppings and feathers
The main place the term "nest" appears is in the docs I wrote - and that was mainly to have a handle to use to describe the include path mechanism - apart from that, you don't see the term "nest" anywhere except the assembly setup dialog and there it could be changed from "Package nests" to "Package root folders", "Package paths" or "Package group paths". I would have to think about how I could remove the term "nest" from those docs if you wanted to change to "package group folder". I have a suspicion I screwed up the use of "top level nest folder" in those articles a little - I was planning to fix that one of these days ...
That's my opinion as of this moment, but it could change at any time