Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: CodeEditor, Assist++, Topic++ » CodeEditor: Character en-coding problem [BUG]?
CodeEditor: Character en-coding problem [BUG]? [message #8671] Fri, 23 March 2007 12:53 Go to next message
Lance is currently offline  Lance
Messages: 347
Registered: March 2007
Senior Member
Sympton: Bad charaters open file in utf-8 encoding

System info: Gentoo Linux, upp installed (emerged) with ebuild provided by ebojd. locale setting: LC_ALL=zh_CN.utf8

Btw, I changed editor's default charset to utf8, but it didn't solve the problem.

Thanks!
Re: CodeEditor: Character en-coding problem [BUG]? [message #8672 is a reply to message #8671] Fri, 23 March 2007 13:28 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
What is "bad character"? Too little information to draw any conclusions...

Mirek

Re: CodeEditor: Character en-coding problem [BUG]? [message #8792 is a reply to message #8672] Sat, 31 March 2007 19:11 Go to previous messageGo to next message
Lance is currently offline  Lance
Messages: 347
Registered: March 2007
Senior Member
Thanks Mirek.

Please refer to the screen shot. This is when I open the AddressBook example.

It's probably not something common to user who use English only.
Re: CodeEditor: Character en-coding problem [BUG]? [message #8839 is a reply to message #8792] Mon, 02 April 2007 23:34 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
Lance wrote on Sat, 31 March 2007 13:11

Thanks Mirek.

Please refer to the screen shot. This is when I open the AddressBook example.

It's probably not something common to user who use English only.


Wow, interesting, never seen that before Smile

Do you think you can try to change the editor font in the Setup/Environment?

Mirek
Re: CodeEditor: Character en-coding problem [BUG]? [message #8840 is a reply to message #8839] Tue, 03 April 2007 00:52 Go to previous messageGo to next message
Lance is currently offline  Lance
Messages: 347
Registered: March 2007
Senior Member
I didn't really think it would work. But when I changed the first font from monospace to Courier, it did the magic.

Fantastic! Thank you Mirek, you have been so helpful.
Re: CodeEditor: Character en-coding problem [BUG]? [message #8841 is a reply to message #8840] Tue, 03 April 2007 07:16 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
Lance wrote on Mon, 02 April 2007 18:52

I didn't really think it would work. But when I changed the first font from monospace to Courier, it did the magic.

Fantastic! Thank you Mirek, you have been so helpful.


Well, that was not really a fix, just getting a clue Smile

How is your "monospace" defined? (It should be in /etc/fonts)

Mirek
Re: CodeEditor: Character en-coding problem [BUG]? [message #8869 is a reply to message #8841] Wed, 04 April 2007 13:11 Go to previous messageGo to next message
Lance is currently offline  Lance
Messages: 347
Registered: March 2007
Senior Member
 ~ $ ls /etc/fonts
conf.avail  conf.d  fonts.conf  fonts.dtd  local.conf


I set font to Monospace in gedit, and it looks ok.

Then in OpenOffice.writer, I cannot locate monospace font.

Thanks. And by the way, my upp is still not ok. It appears the directory setting is blank. I added g++ as command, and some include directory, but apparently my directory list is not complete.

Isn't GCC.bom supposed to solve the directory problem? or are there other files missing?

Thanks a ton Smile
Re: CodeEditor: Character en-coding problem [BUG]? [message #8947 is a reply to message #8869] Mon, 09 April 2007 17:00 Go to previous message
mirek is currently offline  mirek
Messages: 12105
Registered: November 2005
Ultimate Member
Lance wrote on Wed, 04 April 2007 07:11

 ~ $ ls /etc/fonts
conf.avail  conf.d  fonts.conf  fonts.dtd  local.conf


I set font to Monospace in gedit, and it looks ok.

Then in OpenOffice.writer, I cannot locate monospace font.

Thanks. And by the way, my upp is still not ok. It appears the directory setting is blank. I added g++ as command, and some include directory, but apparently my directory list is not complete.

Isn't GCC.bom supposed to solve the directory problem? or are there other files missing?

Thanks a ton Smile


Yes, GCC.bm is part of trick. However, recent .deb and .rpm version (2007.1rc5) should setup everything; what version are you using?

Mirek
Previous Topic: B605-dev1: Assist++: Incorrect evaluation
Next Topic: Non-overlapping Find window [FEATURE REQUEST]
Goto Forum:
  


Current Time: Thu Nov 21 15:07:16 CET 2019

Total time taken to generate the page: 0.01130 seconds