Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Installation of U++ in Debian problem
Installation of U++ in Debian problem [message #16728] Tue, 08 July 2008 19:03 Go to next message
lectus is currently offline  lectus
Messages: 329
Registered: September 2006
Location: Brazil
Senior Member
Hi!

I'm trying to set up a development machine with Debian Lenny and Ultimate++.
Everything goes well with dependencies except for libstdc++6-dev that dpkg complains.

How can I solve this so I can install the .deb provided at the U++ website?

Thanks for your attention
Re: Installation of U++ in Debian problem [message #16735 is a reply to message #16728] Tue, 08 July 2008 22:01 Go to previous messageGo to next message
captainc is currently offline  captainc
Messages: 278
Registered: December 2006
Location: New Jersey, USA
Experienced Member
lectus wrote on Tue, 08 July 2008 13:03

Hi!

I'm trying to set up a development machine with Debian Lenny and Ultimate++.
Everything goes well with dependencies except for libstdc++6-dev that dpkg complains.

How can I solve this so I can install the .deb provided at the U++ website?

Thanks for your attention


What was the complaint (error message)?
Re: Installation of U++ in Debian problem [message #16738 is a reply to message #16735] Wed, 09 July 2008 01:42 Go to previous messageGo to next message
lectus is currently offline  lectus
Messages: 329
Registered: September 2006
Location: Brazil
Senior Member
captainc wrote on Tue, 08 July 2008 16:01

What was the complaint (error message)?


# aptitude install libstdc++6-dev libxft-dev zlib1g-dev libpng12-dev libfontconfig1-dev libxrender-dev libfreetype6-dev libexpat1-dev libgtk2.0-dev libglib2.0-dev

# dpkg -i upp-2007.1_i386.deb
Selecionando pacote previamente não selecionado upp.
(Lendo banco de dados ... 123974 arquivos e diretórios atualmente instalados).
Desempacotando upp (de upp-2007.1_i386.deb) ...
dpkg: problemas de dependência impedem a configuração de upp:
upp depende de libstdc++6-dev (>= 3.4.6); porém:
Pacote libstdc++6-dev não está instalado.
dpkg: erro processando upp (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
upp

Basically it says upp depends on libstdc++6-dev (>= 3.4.6) but libstdc++6-dev is not installed.

But it is installed as libstdc++6.4.3-dev and also I requested it to install above.

I don't understand why this. Any idea?



[Updated on: Wed, 09 July 2008 01:43]

Report message to a moderator

Re: Installation of U++ in Debian problem [message #16748 is a reply to message #16738] Wed, 09 July 2008 18:34 Go to previous messageGo to next message
captainc is currently offline  captainc
Messages: 278
Registered: December 2006
Location: New Jersey, USA
Experienced Member
Maybe it's a link problem?
I am using libstdc++6-4.1-dev and it is working.

[Updated on: Wed, 09 July 2008 18:34]

Report message to a moderator

Re: Installation of U++ in Debian problem [message #16750 is a reply to message #16738] Wed, 09 July 2008 19:41 Go to previous messageGo to next message
guido is currently offline  guido
Messages: 169
Registered: April 2006
Experienced Member
Debian has recently renamed libstc++-dev to include a version number in the package identifier. Looks like we need two packages now, one for old (Etch), one for new (>=Lenny) Debian/Ubuntu.
Re: Installation of U++ in Debian problem [message #16776 is a reply to message #16750] Thu, 10 July 2008 23:17 Go to previous messageGo to next message
lectus is currently offline  lectus
Messages: 329
Registered: September 2006
Location: Brazil
Senior Member
Yeah. I think they renamed. Any way to solve this?
I think if the u++ developers remove the version requirement in the u++ deb this problem would get solved.

What do you think?

[Updated on: Fri, 11 July 2008 04:10]

Report message to a moderator

Re: Installation of U++ in Debian problem [message #16800 is a reply to message #16728] Sat, 12 July 2008 00:54 Go to previous messageGo to next message
lectus is currently offline  lectus
Messages: 329
Registered: September 2006
Location: Brazil
Senior Member
Hey guys!
I got U++ working on Debian Lenny! I had to use libstdc++6-dev from Debian Etch repos.

Anyone trying to get U++ working on Debian Lenny should try this! Anyway, I hope this little problem will be solved soon since Lenny is to be released this year to become the new debian stable.

Thanks for this nice tool called Ultimate++!

BTW... I started creating an application for storing data for my sister's medical clinic. Ultimate++ here helps creating a professional and easy to use GUI.
If eveything goes well and she likes I'll post more comments here. Wink

[Updated on: Sat, 12 July 2008 01:00]

Report message to a moderator

Re: Installation of U++ in Debian problem [message #16803 is a reply to message #16800] Sat, 12 July 2008 10:18 Go to previous messageGo to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
lectus wrote on Sat, 12 July 2008 00:54

Hey guys!
I got U++ working on Debian Lenny! I had to use libstdc++6-dev from Debian Etch repos.
Anyone trying to get U++ working on Debian Lenny should try this! Anyway, I hope this little problem will be solved soon since Lenny is to be released this year to become the new debian stable.


Well, that's a workaround, but I'd like to know if there's a 'cleaner' way to build an universal upp debian package....
If you tell me the *exact* libstdc that comes with lenny (I've got no time to build a lenny setup....), I can try to change my debian script to use it as an alternative of current one.
Than you could test it on a 'clean' lenny ...

Max
Re: Installation of U++ in Debian problem [message #16816 is a reply to message #16803] Sun, 13 July 2008 00:43 Go to previous messageGo to next message
lectus is currently offline  lectus
Messages: 329
Registered: September 2006
Location: Brazil
Senior Member
Yes, this is a (very dirty) workaround, since aptitude keeps asking if you want to upgrade.

The version available in Lenny is libstdc++6-4.3-dev. But there are also libstdc++6-4.1-dev and libstdc++6-4.2-dev, but unfortanatelly none have the meta-package libstdc++6-dev in Lenny.

BTW... if you run debian etch you don't need to setup a full debian Lenny to check this out. Just edit your /etc/apt/sources.list and change from etch to lenny and do apt-get update && apt-caches search libstdc++.

[Updated on: Sun, 13 July 2008 00:44]

Report message to a moderator

Re: Installation of U++ in Debian problem [message #17035 is a reply to message #16816] Sat, 26 July 2008 02:13 Go to previous message
bytefield is currently offline  bytefield
Messages: 210
Registered: December 2007
Experienced Member
Please read this, it maybe solve the Debian problem...

cdabbd745f1234c2751ee1f932d1dd75
Previous Topic: ubuntu 8.04 problems?
Next Topic: Ultimate++ on Solaris 10 ia86
Goto Forum:
  


Current Time: Sat Dec 14 20:28:52 CET 2019

Total time taken to generate the page: 0.01405 seconds