Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » RichText,QTF,RTF... » QTF table borders disappering on Report/Perform()
QTF table borders disappering on Report/Perform() [message #23381] Thu, 15 October 2009 16:09 Go to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
I have created a table dynamically and then use Report/Perform() to display/print the report. However, sometimes the borders display and other times they do not. If I resize the window it changes which borders appear. Sometimes you can get it just right so that all the borders appear.

Excuse the longer example but it has QTF code to show the problem:

Report r;
r << "[ $$0,0#00000000000000000000000000000000:Default]"
"[{_} "
"[ {{1755:848:856:846:834:869:795:3197@7|2 [s0;=%% [*2 Points]]"
"::|2 [s0;=%% [*2 CH]]"
":: [s0;=%% [*2 Dist]]"
":: [s0;=%% [*2 GS]]"
":: [s0;=%% [*2 ETE]]"
":: [s0;=%% [*2 ETA]]"
":: [s0;=%% [*2 Fuel U]]"
"::|2 [s0;=%% [*2 Notes]]"
"::@2 [s0; ]"
":: [s0; ]"
"::@7 [s0;=%% [*2 Rem]]"
":: [s0;=%% [*2 Act]]"
":: [s0;=%% [*2 ATE]]"
":: [s0;=%% [*2 ATA]]"
":: [s0;=%% [*2 Fuel R]]"
"::@2 [s0; ]"
":: [s0; ]"
":: [s0; ]"
"::@7 [s0;=%% [*2 `@TD]]"
":: [s0;=%% [*2 <`- Tot]]"
":: [s0;=%% [*2 Off `->]]"
"::@2 [s0;=*2%% ]"
"::@7 [s0;=%% [*2 `@FT]]"
"::@2 [s0; ]"
":: [s0;= `@SP]"
"::|1 [s0;= `@CH]"
":: [s0;=%% `@D]"
":: [s0;=%% `@GS]"
":: [s0;=%% `@E]"
":: [s0;=%% ]"
":: [s0;=%% `@FU]"
"::|1 [s0; `@N]"
"::|1 [s0;= `@P]"
":: [s0; ]"
":: [s0;=%% `@DR]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% `@FR]"
":: [s0; ]"
":: [s0; ]"
"::|1 [s0;= `@CH]"
":: [s0;=%% `@D]"
":: [s0;=%% `@GS]"
":: [s0;=%% `@E]"
":: [s0;=%% ]"
":: [s0;=%% `@FU]"
"::|1 [s0; `@N]"
"::|1 [s0;= `@P]"
":: [s0; ]"
":: [s0;=%% `@DR]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% `@FR]"
":: [s0; ]"
":: [s0; ]"
"::@7 [s0;= [*2 Totals]]"
"::@2 [s0;=%% `@DT]"
":: [s0;=%% `@GA]"
":: [s0;=%% `@ET]"
":: [s0;=%% `-]"
":: [s0;=%% `@FT]"
":: [s0; `-]}}]";
	
Perform(r);


Is there a way to fix this?

Jeremy
Re: QTF table borders disappering on Report/Perform() [message #23407 is a reply to message #23381] Sat, 17 October 2009 13:28 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11991
Registered: November 2005
Ultimate Member
jeremy_c wrote on Thu, 15 October 2009 10:09

I have created a table dynamically and then use Report/Perform() to display/print the report. However, sometimes the borders display and other times they do not. If I resize the window it changes which borders appear. Sometimes you can get it just right so that all the borders appear.

Excuse the longer example but it has QTF code to show the problem:

Report r;
r << "[ $$0,0#00000000000000000000000000000000:Default]"
"[{_} "
"[ {{1755:848:856:846:834:869:795:3197@7|2 [s0;=%% [*2 Points]]"
"::|2 [s0;=%% [*2 CH]]"
":: [s0;=%% [*2 Dist]]"
":: [s0;=%% [*2 GS]]"
":: [s0;=%% [*2 ETE]]"
":: [s0;=%% [*2 ETA]]"
":: [s0;=%% [*2 Fuel U]]"
"::|2 [s0;=%% [*2 Notes]]"
"::@2 [s0; ]"
":: [s0; ]"
"::@7 [s0;=%% [*2 Rem]]"
":: [s0;=%% [*2 Act]]"
":: [s0;=%% [*2 ATE]]"
":: [s0;=%% [*2 ATA]]"
":: [s0;=%% [*2 Fuel R]]"
"::@2 [s0; ]"
":: [s0; ]"
":: [s0; ]"
"::@7 [s0;=%% [*2 `@TD]]"
":: [s0;=%% [*2 <`- Tot]]"
":: [s0;=%% [*2 Off `->]]"
"::@2 [s0;=*2%% ]"
"::@7 [s0;=%% [*2 `@FT]]"
"::@2 [s0; ]"
":: [s0;= `@SP]"
"::|1 [s0;= `@CH]"
":: [s0;=%% `@D]"
":: [s0;=%% `@GS]"
":: [s0;=%% `@E]"
":: [s0;=%% ]"
":: [s0;=%% `@FU]"
"::|1 [s0; `@N]"
"::|1 [s0;= `@P]"
":: [s0; ]"
":: [s0;=%% `@DR]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% `@FR]"
":: [s0; ]"
":: [s0; ]"
"::|1 [s0;= `@CH]"
":: [s0;=%% `@D]"
":: [s0;=%% `@GS]"
":: [s0;=%% `@E]"
":: [s0;=%% ]"
":: [s0;=%% `@FU]"
"::|1 [s0; `@N]"
"::|1 [s0;= `@P]"
":: [s0; ]"
":: [s0;=%% `@DR]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% ]"
":: [s0;=%% `@FR]"
":: [s0; ]"
":: [s0; ]"
"::@7 [s0;= [*2 Totals]]"
"::@2 [s0;=%% `@DT]"
":: [s0;=%% `@GA]"
":: [s0;=%% `@ET]"
":: [s0;=%% `-]"
":: [s0;=%% `@FT]"
":: [s0; `-]}}]";
	
Perform(r);


Is there a way to fix this?

Jeremy


It is because it scales down too much -> the width drops bellow 1 pixel.

Interestingly, there is simple way to fix the problem - add Painter package to your project. That will activate high-quality subpixel accuracy software rendering of Reports and thin lines will be drawn just fine (as gray).

Mirek

Re: QTF table borders disappering on Report/Perform() [message #23409 is a reply to message #23407] Sat, 17 October 2009 15:00 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
Thank you, that is much better!

Jeremy
Re: QTF table borders disappering on Report/Perform() [message #23416 is a reply to message #23407] Sun, 18 October 2009 01:42 Go to previous messageGo to next message
jeremy_c is currently offline  jeremy_c
Messages: 175
Registered: August 2007
Location: Ohio, USA
Experienced Member
Is there a way to fix this when exporting to PDF?

Jeremy
  • Attachment: fp.pdf
    (Size: 63.36KB, Downloaded 200 times)

[Updated on: Sun, 18 October 2009 01:43]

Report message to a moderator

Re: QTF table borders disappering on Report/Perform() [message #23434 is a reply to message #23416] Mon, 19 October 2009 09:40 Go to previous message
mirek is currently offline  mirek
Messages: 11991
Registered: November 2005
Ultimate Member
jeremy_c wrote on Sat, 17 October 2009 19:42

Is there a way to fix this when exporting to PDF?

Jeremy



Interesting, looks like acrobat reader tries to fight with the very same issue...

Note that if you go into preferences (in AR) and put "Enhance thin lines" flag off, they reappear.

Frankly, I am not sure what to do with this.... Certainly, part of problem is how lines in tables are composed together (using 3 adjacent lines - grid line and bordering cells borders), but....
Previous Topic: Does a Ctrl may be a RichObject ?
Next Topic: Page Totals in a table?
Goto Forum:
  


Current Time: Tue Aug 20 21:18:04 CEST 2019

Total time taken to generate the page: 0.01267 seconds