Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » theide does not link since r1728 with GCC 4.4
theide does not link since r1728 with GCC 4.4 [message #23946] Wed, 09 December 2009 12:54 Go to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
Hi Mirek,

the revision r1728 adds calls to the Csizeinit() static member function to X11App.cpp and Win32Wnd.cpp. Csizeinit() was previously used only in Ctrl.cpp but with these new calls, GCC 4.4.1 (on Ubuntu) refuses to link:

_out/CtrlCore/GCCMK-Gcc-Gui-Linux-Posix-Shared/CtrlCore.a(X11App.o): In function `Upp::Ctrl::InitX11(char const*)':
X11App.cpp:(.text._ZN3Upp4Ctrl7InitX11EPKc+0x1ca): undefined reference to `Upp::Ctrl::Csizeinit()'


I understand the need of the static keyword so that you don't need to instanciate a Ctrl object, so I am not sure what the solution is...

What do you think ?
Re: theide does not link since r1728 with GCC 4.4 [message #23948 is a reply to message #23946] Wed, 09 December 2009 13:36 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3033
Registered: August 2008
Ultimate Member
Hello chickenk

In an Ubuntu 8.04 with svn 1793 it compiles well.

Best regards
Koldo


Best regards
Iñaki
Re: theide does not link since r1728 with GCC 4.4 [message #23949 is a reply to message #23948] Wed, 09 December 2009 13:56 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
This is an Ubuntu 9.10 with GCC 4.4.1:

$ gcc --version
gcc (Ubuntu 4.4.1-4ubuntu8) 4.4.1

and the upp sources were taken from http://upp-mirror.googlecode.com/files/upp-x11-src-1793.tar. gz

I untarred and launched 'make', simply.

I did the same instructions under Fedora 11 and I get the same problem.

$ gcc --version
gcc (GCC) 4.4.1 20090725 (Red Hat 4.4.1-2)

BUT !!!

Using my already compiled theide to compile the 'ide' package on the Fedora works, with up to date sources at revision 1793. I'm gonna check the differences in the compiler options...

Lionel
Re: theide does not link since r1728 with GCC 4.4 [message #23950 is a reply to message #23949] Wed, 09 December 2009 14:08 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
Damn. I found the culprit. Shocked

When compiling with -O3, it links. When compiling with -O1 it does not...

Seems that -O3 activates some options regarding inline functions. Quite surprising that it happens only to me... are you all using -O3 ???

Lionel
Re: theide does not link since r1728 with GCC 4.4 [message #23951 is a reply to message #23950] Wed, 09 December 2009 15:18 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3033
Registered: August 2008
Ultimate Member
chickenk wrote on Wed, 09 December 2009 14:08

Damn. I found the culprit. Shocked

When compiling with -O3, it links. When compiling with -O1 it does not...

Seems that -O3 activates some options regarding inline functions. Quite surprising that it happens only to me... are you all using -O3 ???

Lionel


Wow.

I am using an already compiled theIde.

Best regards
Koldo


Best regards
Iñaki
Re: theide does not link since r1728 with GCC 4.4 [message #25633 is a reply to message #23951] Thu, 04 March 2010 21:23 Go to previous messageGo to next message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
Hi,

I use ubuntu and as there are no .deb installs anymore I am trying to create an installation of theIDe under a fresh install ubuntu 9.10 64bit plus g++. In the readme it says to just use make but this does not work (also domake does not work) and throws tons of errors. I have tried

make -O3 as implied in this thread but that doesn't work either. I use theIDE because I like to use IDEs and am not used to command line compiling and linking. Can anyone provide any clues to how to go about taking the latest tgz and building what I need to install theIDE please?

EDIT: ok I found another thread in which it says to install an older version of theIDE first and that this will then mean that all the things that make needs will be installed. It might be an idea to put this in the readme that ships with the source code.

EDIT: with 64 bit IDE installed it appears to build a lot of stuff. However it stops with
mkdir -p _out/plugin/png/GCCMK-Gcc-Gui-Linux-Posix-Shared/
c++ -c -x c++ -O3 -ffunction-sections -fdata-sections  -I./ -I/usr/include/freetype2 -I/usr/include/gtk-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -I/usr/X11R6/include/gtk-2.0 -I/usr/X11R6/include/glib-2.0 -I/usr/X11R6/lib/glib-2.0/include -I/usr/X11R6/lib/gtk-2.0/include -I/usr/X11R6/include/cairo -I/usr/X11R6/include/pango-1.0 -I/usr/X11R6/include/atk-1.0 -DflagGUI -DflagGCC -DflagSHARED -DflagLINUX -DflagPOSIX  CtrlLib/TrayIconX11.cpp -o _out/CtrlLib/GCCMK-Gcc-Gui-Linux-Posix-Shared/TrayIconX11.o
CtrlLib/TrayIconX11.cpp:9:31: error: libnotify/notify.h: No such file or directory
CtrlLib/TrayIconX11.cpp: In member function ‘void Upp::TrayIcon::Message(int, const char*, const char*, int)’:
CtrlLib/TrayIconX11.cpp:99: error: ‘notify_init’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:101: error: ‘NotifyNotification’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:101: error: ‘notification’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:107: error: ‘notify_notification_new’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:108: error: ‘notify_notification_set_timeout’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:109: error: ‘notify_notification_show’ was not declared in this scope
CtrlLib/TrayIconX11.cpp:110: error: ‘notify_uninit’ was not declared in this scope
make[1]: *** [_out/CtrlLib/GCCMK-Gcc-Gui-Linux-Posix-Shared/TrayIconX11.o] Error 1
make[1]: Leaving directory `/home/nix/upp-x11-src-2171/uppsrc'
cp: omitting directory `uppsrc/ide.out'
make: *** [all] Error 1


Nick


[Updated on: Thu, 04 March 2010 22:23]

Report message to a moderator

Re: theide does not link since r1728 with GCC 4.4 [message #25634 is a reply to message #25633] Fri, 05 March 2010 08:27 Go to previous messageGo to next message
andrei_natanael is currently offline  andrei_natanael
Messages: 262
Registered: January 2009
Experienced Member
nixnixnix wrote on Thu, 04 March 2010 22:23

I use ubuntu and as there are no .deb installs anymore I am trying to create an installation of theIDe under a fresh install ubuntu 9.10 64bit plus g++.


Hi Nick,
The deb packages have been moved to launchpad because is more accessible to update from there and keep your system updated without having to install upp manually.
Right now there are 2 ppa one for nightly and one for stable builds, still the nightly have last package built 9 days ago so it's not really updated because AFAIK Mirek and Jan are working to automate build process.
https://launchpad.net/~dolik-rce/+archive/upp-nightly
https://launchpad.net/~dolik-rce/+archive/upp

Andrei
Re: theide does not link since r1728 with GCC 4.4 [message #25664 is a reply to message #25634] Sun, 07 March 2010 00:29 Go to previous messageGo to next message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
Thanks Andrei,

I have installed the software source. Is there any way to know if the updates are working? When I start up theIDE I still see version 1713.

Nick
Re: theide does not link since r1728 with GCC 4.4 [message #25675 is a reply to message #25664] Sun, 07 March 2010 14:38 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Hi Nick,
If you installed theide from PPA repository correctly, theide should say something like "2070~ppa1~karmic1". Please note that just adding the source is not enough, you also have to install the package:
sudo apt-get install upp
After this updates should work. The repository is still not updated nightly, not sure why, I think that Mirek is just too busy lately.

Best regards,
Honza
Re: theide does not link since r1728 with GCC 4.4 [message #25738 is a reply to message #25675] Wed, 10 March 2010 01:01 Go to previous message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
duh! thanks Smile
Previous Topic: theIDE compile problem under Linux since FindInFiles structure
Next Topic: Problem installing theIDE 2224
Goto Forum:
  


Current Time: Fri Nov 22 21:23:52 CET 2019

Total time taken to generate the page: 0.01560 seconds