Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » LineEdit, EditFields, DocEdit » [Not a bug] EditString::SetData sets text properly
[Not a bug] EditString::SetData sets text properly [message #26280] Tue, 20 April 2010 17:21 Go to next message
Mindtraveller is currently offline  Mindtraveller
Messages: 916
Registered: August 2007
Location: Russia, Moscow rgn.
Experienced Contributor

It looks like
EditString::SetData and EditString::SetText operate to different values while working with SetData/GetData is a common way of operating internal control value for all other controls. I believe EditString::SetData should set control's text.

[Updated on: Tue, 20 April 2010 19:13]

Report message to a moderator

Re: Why EditString::SetData doesn't set text value of control? [message #26283 is a reply to message #26280] Tue, 20 April 2010 18:47 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 11843
Registered: November 2005
Ultimate Member
Mindtraveller wrote on Tue, 20 April 2010 11:21

It looks like
EditString::SetData and EditString::SetText operate to different values while working with SetData/GetData is a common way of operating internal control value for all other controls. I believe EditString::SetData should set control's text.


It does, indirectly. (If not, provide an example please).

As for SetData and SetText differences, they are trivial with EditString, but important for e.g. EditInt...

Mirek
Re: Why EditString::SetData doesn't set text value of control? [message #26285 is a reply to message #26283] Tue, 20 April 2010 19:12 Go to previous message
Mindtraveller is currently offline  Mindtraveller
Messages: 916
Registered: August 2007
Location: Russia, Moscow rgn.
Experienced Contributor

Thanks for quick reply.
It is strange, simplified version works properly. It looks like bug was somewhare else. Sorry for bothering, Mirek. Please delete this topic.

[Updated on: Tue, 20 April 2010 19:13]

Report message to a moderator

Previous Topic: Dead chars not handled correctly on non-English keyboards
Next Topic: BUG: DocEdit: undo/redo works on ReadOnly DocEdit
Goto Forum:
  


Current Time: Thu Apr 25 04:53:03 CEST 2019

Total time taken to generate the page: 0.00792 seconds