Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » U++ Core » Xmlize problem with Nulls
Xmlize problem with Nulls [message #44455] Fri, 13 March 2015 13:25 Go to next message
koldo is currently offline  koldo
Messages: 3377
Registered: August 2008
Senior Veteran
Now when a Null EditNotNull field is Xmlized, an error is set in the xml file, so when the xml file is opened a "invalid Value type" error is thrown so xml file is not opened.

The reason is that EditFields get data from Scan(), and it returns "error" type and an error message ("Null value not allowed.") when field is Null (or out of max/min limits, with "Number must be between %d and %d." message).

IMHO if an EditMinMaxNotNull or EditNotNull field is saved in a xml, the original data should be saved instead of an error. Other way could be to ignore ERROR type values when opening a xml file, instead of throwing an error.

What do you think?


Best regards
Iñaki

[Updated on: Fri, 13 March 2015 13:31]

Report message to a moderator

Re: Xmlize problem with Nulls [message #44464 is a reply to message #44455] Sat, 14 March 2015 11:58 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13996
Registered: November 2005
Ultimate Member
I agree, this is a bug.

Do you have some simple testcase so that I do not have to invent one?

Mirek
Re: Xmlize problem with Nulls [message #44481 is a reply to message #44464] Mon, 16 March 2015 09:20 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3377
Registered: August 2008
Senior Veteran
Smile
  • Attachment: XmlNull.7z
    (Size: 0.93KB, Downloaded 239 times)


Best regards
Iñaki
Re: Xmlize problem with Nulls [message #44484 is a reply to message #44481] Mon, 16 March 2015 13:30 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13996
Registered: November 2005
Ultimate Member
Hopefully fixed.

However, it really feels like shadow area: Usually I do not store dialogs in invalid state...

Mirek
Re: Xmlize problem with Nulls [message #44487 is a reply to message #44484] Mon, 16 March 2015 17:32 Go to previous message
koldo is currently offline  koldo
Messages: 3377
Registered: August 2008
Senior Veteran
Thank you Mirek

That is true. My problem was that a new variable was not initialized by default, so it was saved inadvertedly in invalid state so XML file was in fact corrupted.


Best regards
Iñaki
Previous Topic: Building from source on Windows
Next Topic: How to get path separator depended on platform?
Goto Forum:
  


Current Time: Wed Jul 24 13:54:05 CEST 2024

Total time taken to generate the page: 0.02044 seconds