Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » U++ Developers corner » seems incompatible with mingw (building failure)
seems incompatible with mingw [message #46452] Thu, 12 May 2016 09:37 Go to next message
bonami is currently offline  bonami
Messages: 186
Registered: June 2007
Location: Beijing
Experienced Member
My project worked long ago.
Then I updated U++ to 9818 on windows. When I built my project again with MinGW, it complained many errors. So I updated MinGW, including libc, etc.
It still complained C++11 not supported, so I had to add a -std=c++11 option.
But it still complained _hypot, PCONDITION_VARIABLE, CONDITION_VARIABLE and stricmp not declared.
Re: seems incompatible with mingw [message #46493 is a reply to message #46452] Mon, 16 May 2016 09:02 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12837
Registered: November 2005
Ultimate Member
This is weird.

Are you using 'mingw' nightly build? (http://www.ultimatepp.org/www$uppweb$nightly$en-us.html)

It comes with the latest mingw and autosetups itself...

Mirek
Re: seems incompatible with mingw [message #46505 is a reply to message #46493] Wed, 18 May 2016 05:02 Go to previous messageGo to next message
bonami is currently offline  bonami
Messages: 186
Registered: June 2007
Location: Beijing
Experienced Member
I got UPP 9843 nightly build without mingw and checked MINGW is everything up to date.
still failed to compile.
Then I installed VC 2015.
Now TheIDE does not detect either Mingw or VC2015 when I choose setup->Instant Setup.
If I manually set VC in setup->Legacy compiler automatic setup, which is 14 and I can set it to 12 only, numerous VC header files are not found and the directories are not in header paths in setup->Build methods.
stuck.

[Updated on: Wed, 18 May 2016 05:05]

Report message to a moderator

Re: seems incompatible with mingw [message #46513 is a reply to message #46505] Wed, 18 May 2016 19:47 Go to previous messageGo to next message
Zbych is currently offline  Zbych
Messages: 314
Registered: July 2009
Senior Member
bonami wrote on Wed, 18 May 2016 05:02

Then I installed VC 2015.
Now TheIDE does not detect either Mingw or VC2015 when I choose setup->Instant Setup.


I had similar problem with VS2015 detection when Windows SDK was not selected to install:
http://www.ultimatepp.org/forums/index.php?t=msg&th=9448 &goto=45400&#msg_45400
Re: seems incompatible with mingw [message #46548 is a reply to message #46513] Tue, 24 May 2016 05:26 Go to previous message
bonami is currently offline  bonami
Messages: 186
Registered: June 2007
Location: Beijing
Experienced Member
I had chosen to install Win10 SDK
Previous Topic: my 3d window
Next Topic: far pascal function pointer
Goto Forum:
  


Current Time: Wed Oct 28 06:07:58 CET 2020

Total time taken to generate the page: 0.01120 seconds