Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Strange behavior of clipboard in TheIde 609-dev1 on Linux
Re: Strange behavior of clipboard in TheIde 609-dev1 on Linux [message #5501 is a reply to message #5500] Wed, 27 September 2006 14:54 Go to previous messageGo to previous message
nicomesas is currently offline  nicomesas
Messages: 104
Registered: September 2006
Location: Barcelona, Spain
Experienced Member
I have not been able to wait for more and I have test it.

Then, if we did not comment line 26 of X11Clip.cpp is not called to xclipboard().Clear(); in line 140 of X11Wnd.cpp.

If we commented line 26 then everything it works correctly. Then I propose to eliminate or to comment that line in next releases:

void Ctrl::Xclipboard::Write(int fmt, const String& _data)
{
	LLOG("SetSelectionOwner " << XAtomName(fmt));
	data.GetAdd(fmt) = _data;
	//if(XGetSelectionOwner(Xdisplay, XAtom("CLIPBOARD") != win))
		XSetSelectionOwner(Xdisplay, XAtom("CLIPBOARD"), win, CurrentTime);
}



Now if that I am going away to eat Laughing

Nico
 
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Install U++ in Ubuntu-6.06.1 Desktop 64bits
Next Topic: "Package organizer" and other dialogs are size incorrect in linux
Goto Forum:
  


Current Time: Thu Apr 02 09:08:34 CEST 2020

Total time taken to generate the page: 0.01569 seconds