Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Problems installing in Ubuntu 6.06
Problems installing in Ubuntu 6.06 [message #7715] Tue, 16 January 2007 23:09 Go to previous message
negroheider is currently offline  negroheider
Messages: 2
Registered: January 2007
Junior Member
Hey everyone,

It's been a while since I've worked in Linux, and I found some good comments on this IDE on the web. I've been trying to compile it in Ubuntu 6.06 but I've hit a couple of problems. First I had to edit the Makefile's first line to make it read this:

UPPDIR1 = ./upp/uppsrc/

Else it wouldn't start compiling. Next I got this error message:

In file included from /usr/include/X11/Xft/Xft.h:41,
from ./upp/uppsrc/Draw/Draw.h:24,
from ./upp/uppsrc/CtrlCore/CtrlCore.h:4,
from ./upp/uppsrc/CtrlLib/CtrlLib.h:4,
from ./upp/uppsrc/ide/Common/Common.h:4,
from ./upp/uppsrc/ide/ide.h:4,
from ./upp/uppsrc/ide/SelectPkg.cpp:1:
/usr/include/ft2build.h:56:38: error: freetype/config/ftheader.h: No such file or directory


and a couple others. As far as I understand, I'm missing some linking to some package, but if I run

aptitude search freetype

I get the following output:

v freetype-tools
p freetype1-tools
i freetype2
p freetype2-demos
v freetype2-dev
i libfreetype6
i libfreetype6-dev

Now correct me here, I have the freetype package installed, right? Any idea what I'm missing?
 
Read Message
Read Message
Read Message
Read Message
Read Message
Previous Topic: Uninstall doesn't remove the upp directory
Next Topic: Look of the IDE on kubuntu 6.10
Goto Forum:
  


Current Time: Fri Dec 06 02:19:15 CET 2019

Total time taken to generate the page: 0.02164 seconds