Bug #75

Assertion failed in void Rasterizer::LineRaw

Added by Massimo Del Fedele over 8 years ago. Updated over 8 years ago.

Status:RejectedStart date:07/10/2011
Priority:NormalDue date:
Assignee:Massimo Del Fedele% Done:

0%

Category:GeneralSpent time:-
Target version:-

Description

Trying to paint an image created by painter onto a report triggers assertion failed.
Attached the qtf string with the offending image (hopefully....)

Max

PainterBug.qtf.zip (1.57 MB) Massimo Del Fedele, 07/10/2011 09:20 PM

History

#1 Updated by Miroslav Fidler over 8 years ago

  • Category set to General
  • Assignee set to Massimo Del Fedele

The problem is caused by providing NANs as endpoints in Line.

I have added some logging to Painter and this is what is in the provided file:

MoveOp [0, 0], false
LineOp [0, 480], false
LineOp [6700, 2824.993933], false
LineOp [13400, 480], false
LineOp [13400, 0], false
LineOp [NAN, NAN], false
ArcOp [6700, NAN], [NAN, NAN], NAN, NAN, false
LineOp [NAN, NAN], false
LineOp [0, 0], false
CloseOp
CloseOp

#2 Updated by Konstantin Hartwich over 8 years ago

the IsNaN defintion switch in Defs.h is buggy. it should use

#ifdef PLATFORM_WIN32

as condition, because GCC / MINGW under windows use the same _isnan()
linux and derivates use isnan()..

could anyone change that?

#3 Updated by Miroslav Fidler over 8 years ago

Konstantin Hartwich wrote:

the IsNaN defintion switch in Defs.h is buggy. it should use

#ifdef PLATFORM_WIN32

as condition, because GCC / MINGW under windows use the same _isnan()
linux and derivates use isnan()..

could anyone change that?

Resolved.

#4 Updated by Miroslav Fidler over 8 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF