Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » RichText,QTF,RTF... » Random missing separating lines(V or H) in report table display
Random missing separating lines(V or H) in report table display [message #13033] Thu, 06 December 2007 09:38 Go to next message
fuqr is currently offline  fuqr
Messages: 16
Registered: July 2007
Location: Singapore
Promising Member
Hi UPP experts,
The report example at UPP web site is very good and stright forward. But I noticed some separating lines (V & H) are missing random in display window. And it will change when you change the size of window. But the printed paper is O.K.
Same error occured in my program even if I output to PDF format.
If it's a bug in called Report package?

===============================================
#include <Report/Report.h>
using namespace Upp;

GUI_APP_MAIN
{

Report r;

r.Header("[A2> Page $$P");

r << "This is some [* QTF text";

r << "&&Let's report some table:";

String tab;

tab << "{{1:1:1:1:1:1:2 A:: B:: C:: D:: E:: F:: G (wider)";

for(int row = 0; row < 20; row++)

for(int column = 0; column < 7; column++)

tab << ":: " << row << ":" << column;

r << tab;

r.NewPage();

int y = r.GetY();

r.DrawEllipse(300, y + 50, 3000, 2000, LtRed, 20);

r.DrawText(500, y + 50 + 950, "Some free drawing in this page!", Arial(100));

r.SetY(y + 50 + 3000);

r << "More of [/ QTF] [C6* text";

Perform(r);

}

=====================================================
Thanks for your help!
Re: Random missing separating lines(V or H) in report table display [message #13043 is a reply to message #13033] Thu, 06 December 2007 21:12 Go to previous messageGo to next message
zsolt is currently offline  zsolt
Messages: 584
Registered: December 2005
Location: Budapest, Hungary
Contributor
This is normal behaviour, I think, as it lacks sub-pixel rendering. Acroread lacks it also.
Re: Random missing separating lines(V or H) in report table display [message #13047 is a reply to message #13043] Fri, 07 December 2007 02:23 Go to previous messageGo to next message
fuqr is currently offline  fuqr
Messages: 16
Registered: July 2007
Location: Singapore
Promising Member
Thanks Zsolt,
But any method to improve it for display?
Re: Random missing separating lines(V or H) in report table display [message #13058 is a reply to message #13047] Fri, 07 December 2007 12:19 Go to previous message
zsolt is currently offline  zsolt
Messages: 584
Registered: December 2005
Location: Budapest, Hungary
Contributor
Using AGG would help. There is a topic somewhere in this forum about AGG.
Previous Topic: Failed to set String format in report from SQLite3
Next Topic: [BUG?] Black background in QTF embedded PNG-image
Goto Forum:
  


Current Time: Mon Sep 23 00:55:28 CEST 2019

Total time taken to generate the page: 0.01341 seconds