Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » No more graphic display after installing UPP
No more graphic display after installing UPP [message #19485] Sun, 07 December 2008 23:05 Go to next message
Vephil is currently offline  Vephil
Messages: 7
Registered: September 2008
Location: Paris - France
Promising Member
Hi all

I have big problem after installing UPP upp_2008.1_i386.deb on fedora dist.
The display manager doesn't run any more.

I first install upp just by uncompress archive from the kde desktop and file manager.
Ran TheIde but abort the config dialog boxe that set the environment installation. That, because I realized I was working as root and wanted to change to user log.
When closed session, KDE ended and system went rouggly on command line state. Since this time it's impossible to get KDE or launch any graphic application.
Surely made stupid things but so newbie with Linux, that's it...

Before writing here, read so many forums & sites...

So, can someone say which files upp modify on the system at first running? If it does...

I would like to uninstall upp. How do it? Just delete files ? Which one ?

Lost guy
Re: No more graphic display after installing UPP [message #19489 is a reply to message #19485] Mon, 08 December 2008 09:01 Go to previous messageGo to next message
chickenk is currently offline  chickenk
Messages: 168
Registered: May 2007
Location: Grenoble, France
Experienced Member
Hello,

this happened to me before. First, here is a rule to always follow:

NEVER INSTALL A .DEB BY EXTRACTING IT ON YOUR FILESYSTEM ROOT !!!

The fact is that when you do that, the permissions of the extracted file tree is changed. You should even discover that the permisisons of '/' has changed !!! And that's what causes all these problems. Here is a way to fix it: as root, type:

chmod 755 / /usr /usr/bin /usr/bin/theide /usr/share /usr/share/pixmaps /usr/share/pixmaps/theide.png
chmod -R 755 /usr/share/upp

Then reboot your computer and see if your problem is fixed.

regards,
Lionel
Re: No more graphic display after installing UPP [message #19492 is a reply to message #19489] Mon, 08 December 2008 14:08 Go to previous message
Vephil is currently offline  Vephil
Messages: 7
Registered: September 2008
Location: Paris - France
Promising Member
Thanks a lot chickenk.

That's a very good track. I can launch desktop with startx now.
Still the problem with no log window at boot.

I go on looking for directories permissions.

I' ll give news if any.
Previous Topic: Usb memory stick mobile TheIde
Next Topic: how to rebuild TheIDE on Win32?
Goto Forum:
  


Current Time: Fri Jul 03 15:01:56 CEST 2020

Total time taken to generate the page: 0.01139 seconds