Status & Roadmap
Authors & License
Funding Ultimate++
Search on this site
Search in forums

SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Invalid memory access in Ubuntu Natty
Invalid memory access in Ubuntu Natty [message #32903] Sun, 19 June 2011 03:10 Go to next message
goyo is currently offline  goyo
Messages: 4
Registered: June 2011
Junior Member
Trying to launch TheIDE in natty I was getting an "Invalid memory access!" error (and no TheiDE at all). The problem was some package in this repository:
https://launchpad.net/~guido-iodice/+archive/natty-quasi-rol ling
I don't know what package is to blame but I purged the whole repository and TheIDE is working now:
sudo apt-get install apt-purge
apt-purge ppa:guido-iodice/natty-quasi-rolling

Hope this helps others having this issue.
Re: Invalid memory access in Ubuntu Natty [message #32908 is a reply to message #32903] Sun, 19 June 2011 09:27 Go to previous message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

Glad to hear you got the problem solved Smile

My guess about what happened is that the quasi-rolling ppa made some mess in the libraries that theide depends on. It is compiled against the standard versions in Natty, but this ppa might have installed a newer version of something and that might very easily cause the incompatibility resulting into "Invalid memory access" error.

Best regards,
Previous Topic: A suggestion on VC directory
Next Topic: SOLVED: Problem running in vnc / xen / debian squeeze
Goto Forum:

Current Time: Wed Jul 17 22:34:40 CEST 2024

Total time taken to generate the page: 0.02534 seconds