Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » RichText,QTF,RTF... » Another RTF import bug -- Tables again
Another RTF import bug -- Tables again [message #33123] Fri, 08 July 2011 18:04 Go to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
Here another bug a customer pointed out; tables are wrongly imported, even with latest svn.
I've added 2 images and the rtf file; here the bad behaviour :
index.php?t=getfile&id=3358&private=0

Here the correct one (from libreoffice writer import) :

index.php?t=getfile&id=3359&private=0

As you can see, the FIRST row is imported correctly; next ones get additional empty columns.
The attached RTF contains (among other...) the table.

Ciao

Max
Re: Another RTF import bug -- Tables again [message #33129 is a reply to message #33123] Sat, 09 July 2011 11:22 Go to previous messageGo to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
Here an oversimplified part of same rtf; it has a table with just 3 rows; first of them gets imported correctly, second and third gets additional empty columns.
The file is imported correctly in libreoffice/openoffice.

Here bad behaviour :

index.php?t=getfile&id=3363&private=0

And here the good one :

index.php?t=getfile&id=3364&private=0

Ciao

Max
  • Attachment: TELAIO -1MOD2.RTF
    (Size: 1.11KB, Downloaded 476 times)
  • Attachment: bad.png
    (Size: 13.23KB, Downloaded 433 times)
  • Attachment: good.png
    (Size: 7.17KB, Downloaded 671 times)

[Updated on: Sat, 09 July 2011 11:28]

Report message to a moderator

Re: Another RTF import bug -- Tables again [message #33138 is a reply to message #33129] Mon, 11 July 2011 02:47 Go to previous messageGo to next message
rylek is currently offline  rylek
Messages: 79
Registered: November 2005
Member
Hi there!

I hope I've managed to fix your latest bug; it's on SVN, please check it out.

Regards

Tomas
Re: Another RTF import bug -- Tables again [message #33148 is a reply to message #33138] Mon, 11 July 2011 13:36 Go to previous message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
Hi Tom Smile

It seems all ok.... even better than Libreoffice importer Smile

Ciao

Max
Previous Topic: Bad rtf import after commit r3579 - CtrlCore/ParseRTF.cpp, EncodeRTF.cpp: table & cell border fi
Next Topic: How to include OLE objects
Goto Forum:
  


Current Time: Wed Apr 08 23:45:47 CEST 2020

Total time taken to generate the page: 0.01791 seconds