Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Releasing U++ » PPA for Oneric !
PPA for Oneric ! [message #34075] Fri, 14 October 2011 19:17 Go to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
Hi, I just installed Ubuntu Oneric, and the ppa for nighty builds is missing Sad
There's some plan to add it ?

Max
Re: PPA for Oneric ! [message #34080 is a reply to message #34075] Sat, 15 October 2011 11:17 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

mdelfede wrote on Fri, 14 October 2011 19:17

Hi, I just installed Ubuntu Oneric, and the ppa for nighty builds is missing Sad
There's some plan to add it ?

Max


Hi Max!

I kind of overlooked the release of new Ubuntu... Rolling Eyes I'll add it ASAP, if everything goes well there will be both nightly and release build tomorrow.

Sorry for inconvenience,
Honza
Re: PPA for Oneric ! [message #34081 is a reply to message #34080] Sat, 15 October 2011 13:00 Go to previous messageGo to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
Don't worry and thank you for the release ! Smile

Ah, BTW.... I installed your deb for Natty on Oneric, and it was missing an include path; I'll drop it here, if you get some error of 'gdkconfig.h not found', that's the solution.

/usr/lib/x86_64-linux-gnu/gtk-2.0/include/

Ciao

Max
Re: PPA for Oneric ! [message #34082 is a reply to message #34081] Sun, 16 October 2011 00:16 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

I have tried to make the 3211 release to work, but I have encountered problems with libnotify:
Quote:

uppsrc/CtrlLib/TrayIconX11.cpp: In member function 'void Upp::TrayIcon::Message(int, const char*, const char*, int)':
uppsrc/CtrlLib/TrayIconX11.cpp:109:32: error: too many arguments to function 'NotifyNotification* notify_notification_new(const char*, const char*, const char*)'
/usr/include/libnotify/notification.h:114:21: note: declared here
Didn't you have the same problem? I haven't have time to investigate this further, maybe tomorrow.

I set up the nightly builds as well, but I think there will be similar problems as well. I guess it will take up to few days, until we solve all the details Confused

Best regards,
Honza
Re: PPA for Oneric ! [message #34083 is a reply to message #34082] Sun, 16 October 2011 08:48 Go to previous messageGo to next message
mdelfede is currently offline  mdelfede
Messages: 1259
Registered: September 2007
Senior Contributor
I didn't have this problem, but maybe just because I didn't compile some parts of upp... I don't know.
By now, the only problem I had is the one of gdkconfigure.h missing.

Max
Re: PPA for Oneric ! [message #34084 is a reply to message #34082] Sun, 16 October 2011 11:25 Go to previous messageGo to next message
unknown user
dolik.rce wrote on Sun, 16 October 2011 00:16

I have tried to make the 3211 release to work, but I have encountered problems with libnotify:
Quote:

uppsrc/CtrlLib/TrayIconX11.cpp: In member function 'void Upp::TrayIcon::Message(int, const char*, const char*, int)':
uppsrc/CtrlLib/TrayIconX11.cpp:109:32: error: too many arguments to function 'NotifyNotification* notify_notification_new(const char*, const char*, const char*)'
/usr/include/libnotify/notification.h:114:21: note: declared here
Didn't you have the same problem? I haven't have time to investigate this further, maybe tomorrow.

I set up the nightly builds as well, but I think there will be similar problems as well. I guess it will take up to few days, until we solve all the details Confused

Best regards,
Honza


Hi Honza,

You should define NOTIFY_VERSION_GT_0_7_0 to make it compile, because libnotify didn't had an stable API, so function notify_notification_new signature has changed in newer libnotify release.
Re: PPA for Oneric ! [message #34090 is a reply to message #34075] Mon, 17 October 2011 18:23 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Max: It should all work now, both nightly and stable are in place. Please let me know if you find any problems with the packages.

Andrei: Thanks for pointing me in the right direction, it saved me a lot of searching Wink

Honza
Re: PPA for Oneric ! [message #34094 is a reply to message #34090] Mon, 17 October 2011 22:09 Go to previous messageGo to next message
drjo1952 is currently offline  drjo1952
Messages: 7
Registered: December 2008
Location: Tucson, AZ
Promising Member
Was the PPA updated with the NOTIFY_VERSION fix? I just tried downloading from the PPA and I got the same libnotify error...

BTW - I had to create the following logical link to compile at all to fix a gdkconfig.h include error:

(cd to the /usr/lib/gtk-2.0 directory first...)
sudo ln -s /usr/lib/i386-linux-gnu/gtk-2.0/include/ include


Re: PPA for Oneric ! [message #34095 is a reply to message #34075] Mon, 17 October 2011 22:20 Go to previous messageGo to next message
drjo1952 is currently offline  drjo1952
Messages: 7
Registered: December 2008
Location: Tucson, AZ
Promising Member
I forgot to include another fix I had to make to compile on Oneric:

Algo.h file in uppsrc/Core needed the following std:: added to ptrdiff_t reference at source line 1003:

template <class II, class VI, class K, class Less>
inline void __IndexSort(II begin, II end, VI pair, const Less& less, const K *)
{
Sort(IndexSortIterator<II, VI, K>(begin, pair),
IndexSortIterator<II, VI, K>(end, pair + (int)(std::ptrdiff_t)(end - begin)),
less);
}
Re: PPA for Oneric ! [message #34098 is a reply to message #34094] Tue, 18 October 2011 08:55 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1758
Registered: August 2008
Location: Czech Republic
Senior Contributor

Hi drjo1952

I believe all the necessary fixes were included, otherwise theide wouldn't compile, see the changelog in the package for details. Are you using stable or nightly build? The nightly builds should work well with the current sources.

And yes, I did add the fix in Algo.h, it was actually the first problem I hit Smile

I believe your problem is that the sources copied in your /home/<user>/upp are not synced with those from the package, installed in /usr/share/upp. Are you using the source management features of theide? Or you could try to delete (or move) the /home/<user>/upp and /home/<user>/.upp and start theide again. If the outdated files were the problem, this would solve it for sure.

Best regards,
Honza
Re: PPA for Oneric ! [message #35126 is a reply to message #34098] Sun, 15 January 2012 17:20 Go to previous message
koldo is currently offline  koldo
Messages: 3040
Registered: August 2008
Ultimate Member
Hello Honza

I have just downloaded Ubuntu 11.10 and debs from Launchpad and TheIDE still does not find gdkconfig.h.

Adding "/usr/lib/x86_64-linux-gnu/gtk-2.0/include/" solves the problem.


Best regards
IƱaki

[Updated on: Sun, 15 January 2012 17:20]

Report message to a moderator

Previous Topic: Final round before 11.11 (was 11.10) release
Next Topic: Anyone still using Ubuntu Hardy or Jaunty?
Goto Forum:
  


Current Time: Fri Dec 06 09:51:08 CET 2019

Total time taken to generate the page: 0.01111 seconds