Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » U++ community news and announcements » Testing of migrated and upgraded forum
Testing of migrated and upgraded forum [message #42706] Sun, 30 March 2014 15:19 Go to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
With great and very tedious effort, I have managed to more or less find a way how to migrate the forum data.

It is now in testing mode here:

http://www.ultimatepp.org/forums

It is using some month or two old dump, so no everything is going to be same. Also, structure will have to be restored and theming redone, but all of that can be done later, on production copy.

Please test if you see all message data, attachement, if login works etc...

Thanks!

Mirek
Re: Testing of migrated and upgraded forum [message #42709 is a reply to message #42706] Sun, 30 March 2014 17:44 Go to previous messageGo to next message
koldo is currently offline  koldo
Messages: 3372
Registered: August 2008
Senior Veteran
Hello Mirek

Thank you for your effort. When I try to login I get this:
"Your account was permanently banned from accessing the site, due to a violation of the forum's rules."


Best regards
Iñaki
Re: Testing of migrated and upgraded forum [message #42710 is a reply to message #42709] Sun, 30 March 2014 18:42 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello Mirek,

I have got the same problem like Koldo.

The other issue is that my email adress is publicly visible. Moreover I have got skype address assigned to my profile (I have never given this information).

Sincerely,
Klugier


U++ - one framework to rule them all.

[Updated on: Sun, 30 March 2014 18:49]

Report message to a moderator

Re: Testing of migrated and upgraded forum [message #42711 is a reply to message #42706] Sun, 30 March 2014 18:42 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

Hi Mirek,

Good work. it seems to work fine for me. I was only asked to confirm my email address, but that is no big deal.

The new versions feels much faster than current one. I really like that.

Best regards,
Honza
Re: Testing of migrated and upgraded forum [message #42712 is a reply to message #42711] Sun, 30 March 2014 18:50 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Thanks for reporting. I believe I know how to fix that (more SQL Smile

Mirek
Re: Testing of migrated and upgraded forum [message #42714 is a reply to message #42712] Sun, 30 March 2014 21:01 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Please try now... Should mostly fixed. Unfortunately, I am afraid that personal settings will have to be checked/fixed by user. Also, I had to remove all moderation priviledges, will be restored later.
Re: Testing of migrated and upgraded forum [message #42715 is a reply to message #42714] Sun, 30 March 2014 21:37 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello Mirek,

It seems that all users has got strange date of registretion:
Date Registered: 	Thu, January 01, 1970


Sincerely,
Klugier


U++ - one framework to rule them all.
Re: Testing of migrated and upgraded forum [message #42716 is a reply to message #42715] Sun, 30 March 2014 23:15 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Well, it seems to got lost during the migration... I guess I could fix that by moving registration dates from the current forum.

Is it worth it?
Re: Testing of migrated and upgraded forum [message #42719 is a reply to message #42716] Mon, 31 March 2014 02:15 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
mirek wrote on Sun, 30 March 2014 14:15

Is it worth it?


Yes if it can be done without too much work.
Re: Testing of migrated and upgraded forum [message #42722 is a reply to message #42719] Mon, 31 March 2014 10:07 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
nlneilson wrote on Sun, 30 March 2014 20:15

mirek wrote on Sun, 30 March 2014 14:15

Is it worth it?


Yes if it can be done without too much work.


Should be fixed (for test).
Re: Testing of migrated and upgraded forum [message #42723 is a reply to message #42722] Mon, 31 March 2014 11:44 Go to previous messageGo to next message
Tom1
Messages: 1217
Registered: March 2007
Senior Contributor
Hi,

It seems I have gained a Skype address -- although I have not specified any. (The contents appears to come from the Time Zone field.)

[Send user an e-mail message] may be handy as long as it does not leak the e-mail address.

The Private Messaging seems to have disappeared. Is the email functionality supposed to replace that? Currently it leaks the senders registered e-mail address.

Best regards,

Tom
Re: Testing of migrated and upgraded forum [message #42724 is a reply to message #42723] Mon, 31 March 2014 11:56 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Tom1 wrote on Mon, 31 March 2014 05:44

Hi,

It seems I have gained a Skype address -- although I have not specified any. (The contents appears to come from the Time Zone field.)

[Send user an e-mail message] may be handy as long as it does not leak the e-mail address.

The Private Messaging seems to have disappeared. Is the email functionality supposed to replace that? Currently it leaks the senders registered e-mail address.

Best regards,

Tom


No, those appear to be just more glitches. Thanks for reporting.

To explain what probably causes most troubles here: the forum software has single integer users_opt mysql column per user, where various flags are stored as bit fields. I looks like the meaning of some of those bits has changed, but the migration did not take this into the account. So I have to 'fix' it by SQL, but fix inevitably means I have set the same values for all users in the forum.

Mirek
Re: Testing of migrated and upgraded forum [message #42728 is a reply to message #42723] Mon, 31 March 2014 14:14 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Tom1 wrote on Mon, 31 March 2014 05:44

Hi,

It seems I have gained a Skype address -- although I have not specified any. (The contents appears to come from the Time Zone field.)

[Send user an e-mail message] may be handy as long as it does not leak the e-mail address.

The Private Messaging seems to have disappeared. Is the email functionality supposed to replace that? Currently it leaks the senders registered e-mail address.

Best regards,

Tom


Please check now.
Re: Testing of migrated and upgraded forum [message #42729 is a reply to message #42728] Mon, 31 March 2014 16:16 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1363
Registered: December 2006
Ultimate Contributor
Private Messaging is back. Skype address is still there, but this is not a big deal ...

Regards,
Novo
Re: Testing of migrated and upgraded forum [message #42742 is a reply to message #42729] Tue, 01 April 2014 18:04 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Hopefully fixed remaining flags.

Skype/Google now deleted.

Also fixed Home Page settings.
Re: Testing of migrated and upgraded forum [message #42743 is a reply to message #42742] Tue, 01 April 2014 18:07 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
If no more problems are reported, I will perform the production forum upgrade over the next weekend... (and we will finally be free of those ugly chinese spam farms...)
Re: Testing of migrated and upgraded forum [message #42744 is a reply to message #42743] Tue, 01 April 2014 18:43 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello Mirek,

I have got one technical question. Should not be visible more posts on the forum site. On new forum I see one message per site and I can switch beeteween messages by clicking on the links. It is not super comfortable.

So it is possibility that new forum will work like this forum?

Sincerely,
Klugier
Re: Testing of migrated and upgraded forum [message #42745 is a reply to message #42743] Tue, 01 April 2014 19:19 Go to previous messageGo to next message
dolik.rce is currently offline  dolik.rce
Messages: 1789
Registered: August 2008
Location: Czech Republic
Ultimate Contributor

mirek wrote on Tue, 01 April 2014 18:07

If no more problems are reported, I will perform the production forum upgrade over the next weekend... (and we will finally be free of those ugly chinese spam farms...)

The last problem I see is that my timezone setting is lost (and set to someplace in Africa Smile ), but that is definitely not a big deal...

Honza
Re: Testing of migrated and upgraded forum [message #42747 is a reply to message #42744] Tue, 01 April 2014 19:54 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
klugier wrote on Tue, 01 April 2014 12:43

Hello Mirek,

I have got one technical question. Should not be visible more posts on the forum site. On new forum I see one message per site and I can switch beeteween messages by clicking on the links. It is not super comfortable.

So it is possibility that new forum will work like this forum?

Sincerely,
Klugier



For me it works OK - but perhaps I do not understand the problem.

Could you perhaps send some screenshort?

Mirek
Re: Testing of migrated and upgraded forum [message #42749 is a reply to message #42745] Tue, 01 April 2014 19:59 Go to previous messageGo to previous message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
dolik.rce wrote on Tue, 01 April 2014 13:19

mirek wrote on Tue, 01 April 2014 18:07

If no more problems are reported, I will perform the production forum upgrade over the next weekend... (and we will finally be free of those ugly chinese spam farms...)

The last problem I see is that my timezone setting is lost (and set to someplace in Africa Smile ), but that is definitely not a big deal...

Honza


Should be fixed.

Mirek
Previous Topic: New graph packages
Next Topic: Callback: C++11 lambda support
Goto Forum:
  


Current Time: Sun Jun 16 21:50:27 CEST 2024

Total time taken to generate the page: 0.01467 seconds