Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Successful compilation with error message.
icon5.gif  Successful compilation with error message. [message #43701] Tue, 23 September 2014 08:53 Go to next message
anta40 is currently offline  anta40
Messages: 6
Registered: September 2014
Location: Jakarta, Indonesia
Promising Member
Hello folks,

I just grabbed the latest U++ for Windows package (upp-win32-7719.exe), and set MS VC++ 2013 a.k.a Visual Studio 12 the compiler. When building the AddressBook example, configured as MSC12 Optimal, I got this error (pic attached). The same thing also happened while building httpcli.

Strangely, if you repeat the compilation process, no more error message appear and the compilation done successfully. The executables can be run properly.

Anybody else experiencing this?
  • Attachment: err.jpg
    (Size: 105.27KB, Downloaded 302 times)
Re: Successful compilation with error message. [message #43705 is a reply to message #43701] Wed, 24 September 2014 09:58 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13995
Registered: November 2005
Ultimate Member
anta40 wrote on Tue, 23 September 2014 08:53
Hello folks,

I just grabbed the latest U++ for Windows package (upp-win32-7719.exe), and set MS VC++ 2013 a.k.a Visual Studio 12 the compiler. When building the AddressBook example, configured as MSC12 Optimal, I got this error (pic attached). The same thing also happened while building httpcli.

Strangely, if you repeat the compilation process, no more error message appear and the compilation done successfully. The executables can be run properly.

Anybody else experiencing this?


It is actually a subtle bug in error capturing process (the algorithm wrongly responds to 'error' in 'strerror').

Will fix that soon.

Mirek
Re: Successful compilation with error message. [message #43712 is a reply to message #43705] Thu, 25 September 2014 08:34 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13995
Registered: November 2005
Ultimate Member
Hi,

I have trouble reproducing the problem. Would it be possible to paste here the raw compiler output? You should be able to switch to it using bottom pane right-side buttons.

You can use Build/Rebuild all to force full recompilation (so that these file get compiled again).

Mirek
Re: Successful compilation with error message. [message #43719 is a reply to message #43712] Thu, 25 September 2014 17:32 Go to previous messageGo to next message
anta40 is currently offline  anta40
Messages: 6
Registered: September 2014
Location: Jakarta, Indonesia
Promising Member
Sure. This is the complete, verbose log.
  • Attachment: upplog.zip
    (Size: 11.54KB, Downloaded 203 times)
Re: Successful compilation with error message. [message #43721 is a reply to message #43719] Thu, 25 September 2014 20:48 Go to previous message
mirek is currently offline  mirek
Messages: 13995
Registered: November 2005
Ultimate Member
Thanks, fixed.

Mirek
Previous Topic: [solved] TheIDE does not build
Next Topic: Patch for DragonFly BSD
Goto Forum:
  


Current Time: Fri Jul 19 21:02:14 CEST 2024

Total time taken to generate the page: 0.01509 seconds