Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Layout (Forms) Designer » Newer Layout Designer Is Missing A Control (Compared to upp-2007.1, newer upp is missing DateTimeCtrl in Layout Designer)
Newer Layout Designer Is Missing A Control [message #44580] Sun, 05 April 2015 16:31 Go to next message
jfranks is currently offline  jfranks
Messages: 36
Registered: September 2014
Location: Houston, Texas
Member
We have a large U++ application based on upp-2007-1.

We are migrating to a newer U++ upp-x11-src-8201 and have found that DateTimeCtrl is missing from Layout Designer.

A compile-time error occurs pointing to the following from our application's layout file:

ITEM(DateTimeCtrl, _CalExpDate, LeftPosZ(740, 256).TopPosZ(80, 24))

The error is:

error: Invalid use of template-name 'upp::DateTimeCtrl' without an argument list

DateTimeCtrl no longer exists in the newer Layout Designer.
However, that control does exist in the older upp-2007.1 Layout Designer.

What can we do regarding this?

regards,
Jeff Franks


Re: Newer Layout Designer Is Missing A Control [message #44581 is a reply to message #44580] Mon, 06 April 2015 17:22 Go to previous messageGo to next message
Sender Ghost is currently offline  Sender Ghost
Messages: 299
Registered: November 2008
Experienced Member
Hello, Jeff.
jfranks wrote on Sun, 05 April 2015 14:31
What can we do regarding this?

I think, you could try to replace DateTimeCtrl with DropDate definition:
ITEM(DropDate, _CalExpDate, LeftPosZ(740, 256).TopPosZ(80, 24))

Based on the source code changes, the DateTimeCtrl was converted to (generic) template class, where DropDate and DropTime inherits from it.
Re: Newer Layout Designer Is Missing A Control -- RESOLVED [message #44582 is a reply to message #44581] Mon, 06 April 2015 22:39 Go to previous message
jfranks is currently offline  jfranks
Messages: 36
Registered: September 2014
Location: Houston, Texas
Member
Yes, that worked very well.

Thank you for your help.
Previous Topic: An HTTP style text link, does any one know how?
Next Topic: embeded system
Goto Forum:
  


Current Time: Thu May 28 01:26:06 CEST 2020

Total time taken to generate the page: 0.02827 seconds