Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » Installing UPP on Centos 6.4 (make errors)
Installing UPP on Centos 6.4 [message #44950] Tue, 28 July 2015 23:52 Go to next message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
So with Mirek's help I installed gtk2-devel, libnotify-devel and bzip2-devel which are not included in the standard developer tools package on this distro and it now does lots of building but gets stuck with the following error

CtrlCore/GtkDrawOp.cpp: In member function 'virtual void Upp::SystemDraw::DrawRectOp(int, int, int, int, Upp::Color)':
CtrlCore/GtkDrawOp.cpp:135: error: 'CAIRO_OPERATOR_DIFFERENCE' was not declared in this scope
gmake[1]: *** [_out/CtrlCore//home/upp/Scripts/GCCMK.bm-Gcc-Gui-Linux-Mt-P osix-Shared/GtkDrawOp.o] Error 1
gmake[1]: Leaving directory `/home/nick/upp-x11-src-8227/uppsrc'
cp: cannot stat `uppsrc/ide.out': No such file or directory
make: *** [all] Error 1

Does anyone know what this is or how to fix it please? I have cairo-devel installed as part of the developer tools group install (yum groupinstall 'Development Tools').

Nick


Re: Installing UPP on Centos 6.4 [message #44951 is a reply to message #44950] Wed, 29 July 2015 01:17 Go to previous messageGo to next message
Mindtraveller is currently offline  Mindtraveller
Messages: 916
Registered: August 2007
Location: Russia, Moscow rgn.
Experienced Contributor

Hi Nick,

Which build flags do you build with?
Re: Installing UPP on Centos 6.4 [message #44952 is a reply to message #44951] Wed, 29 July 2015 01:28 Go to previous messageGo to next message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
I am just typing

make

in the extracted folder and that is it so I guess I am using the default flags. To be clear, this is my attempt to build and install theIDE under Centos 6.4.

Nick
Re: Installing UPP on Centos 6.4 [message #44955 is a reply to message #44952] Wed, 29 July 2015 23:43 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 643
Registered: September 2012
Location: Poland, Kraków
Contributor
Hello,

Maybe it is related to cario version on your distribution. It seems that cario is installed well, but for some reason CAIRO_OPERATOR_DIFFERENCE is unavailable. I deduced this, because there is no header inclusion error.

To test that ide compiles without this function you can change line 133 in CtrlCore/GtkDrawOp.cpp to:
#if !GTK_CHECK_VERSION(2,24,0)


Sincerely,
Klugier


Ultimate++ - one framework to rule them all.
Re: Installing UPP on Centos 6.4 [message #44965 is a reply to message #44955] Mon, 03 August 2015 06:38 Go to previous message
nixnixnix is currently offline  nixnixnix
Messages: 415
Registered: February 2007
Location: Kelowna, British Columbia
Senior Member
Thanks Klugier,

Mirek fixed the issue in tarball 8780. The full list of required libraries appears to be

yum groupinstall 'Development Tools'
yum install bzip2-devel
yum install expat-devel
yum install libnotify-devel
yum install gtk2-devel
yum install cairo-devel (not sure needed as might be part of group install)
yum install atk-devel (not sure needed as might be part of group install)
yum install pango-devel (not sure needed as might be part of group install)

Thanks,

Nick
Previous Topic: Installation error for tarball upp-x11-src-8756.tar.gz
Next Topic: missing file domake in nightly build tarball
Goto Forum:
  


Current Time: Sat Dec 07 10:48:17 CET 2019

Total time taken to generate the page: 0.01086 seconds