Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » Big problem updating upp from version 6163 to 9614 (SOLVED updating upp from version 6163 to 9614)
Big problem updating upp from version 6163 to 9614 [message #46157] Mon, 21 March 2016 07:49 Go to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
It seems my updating MSVC 2012 to 2015 is the cause as theide error is Invalid build method. It cannot find a correct compiler.

After installing MSVS 15 three times and the repair twice upp cannot find a compiler.

I must have updated upp 30 plus times from before 5000 to 6163 and MSVS from 8, 10, to 12 without a problem. The last time installing MSVS 15 was with the default setup. Should I try downloading and installing the MS C++ compiler?

[Updated on: Fri, 25 March 2016 02:51]

Report message to a moderator

Re: Big problem updating upp from version 6163 to 9614 [message #46159 is a reply to message #46157] Mon, 21 March 2016 09:11 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
After downloading vc_redist.x86.exe and vc_redist.x64.exe running those just gives errors and attached is a log file:
Re: Big problem updating upp from version 6163 to 9614 [message #46175 is a reply to message #46159] Tue, 22 March 2016 22:13 Go to previous messageGo to next message
Lance is currently offline  Lance
Messages: 536
Registered: March 2007
Contributor
In addition to install VS2015, you need to install certain windows SDK. I read it somewhere in the forum before but wasn't able to locate the exact posts.
Re: Big problem updating upp from version 6163 to 9614 [message #46176 is a reply to message #46159] Tue, 22 March 2016 22:22 Go to previous messageGo to next message
Lance is currently offline  Lance
Messages: 536
Registered: March 2007
Contributor
Did you have Windows SDK 10 installed?

Please follow this thread to find more clues.

http://www.ultimatepp.org/forums/index.php?t=msg&th=9409 &start=0&
Re: Big problem updating upp from version 6163 to 9614 [message #46177 is a reply to message #46176] Tue, 22 March 2016 22:29 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

You can also check that you have selected good options when installing visual studio - http://www.ultimatepp.org/app$ide$install$en-us.html.

Make sure you have selected "Universal Windows App Development Tools". Two months ago I was installing Visual Studio and I didn't checked this options and nothing was working Smile

EDIT: I updated the doc site and required options are now explicitly written on page.

Sincerely,
Klugier


U++ - one framework to rule them all.

[Updated on: Tue, 22 March 2016 22:59]

Report message to a moderator

Re: Big problem updating upp from version 6163 to 9614 [message #46178 is a reply to message #46176] Wed, 23 March 2016 07:30 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Thanks Lance I will check on the SDK installed, I think it was the Win 10 SDK
that is a good thread you linked to. It would be great to have a portable UPP without MINGW but unless you can include the MS cl.exe compiler I don't know how that could be done, maybe another compiler.
Re: Big problem updating upp from version 6163 to 9614 [message #46179 is a reply to message #46177] Wed, 23 March 2016 08:19 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Thanks Klugier.
Apparently the VS enterprise 2015 does not include the cl.exe compiler by default, at least I did not get it.

I tried the Community 2015 with the options selected.

UPP still gives the error: "Invalid build method"
I could not find the cl.exe.

[Updated on: Wed, 23 March 2016 08:22]

Report message to a moderator

Re: Big problem updating upp from version 6163 to 9614 [message #46180 is a reply to message #46157] Wed, 23 March 2016 08:51 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
After tinkering, re-boot, which I had done several times before, trying to open theide several times I got the clock and button examples to compile and run, after 3 days work.

The install doc may need to mention the Community VS 2015 MUST BE USED ??
I hope a new user does not have this problem.
neil
Re: Big problem updating upp from version 6163 to 9614 [message #46181 is a reply to message #46157] Wed, 23 March 2016 15:59 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
No Message Body
Re: Big problem updating upp from version 6163 to 9614 [message #46182 is a reply to message #46157] Wed, 23 March 2016 16:09 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
I downloaded 9622 without the toolchain, unzipped and clicked on "theide.exe, that worked with even the 64 bit.

great work on upp !!

My problem was with the MS VS install.
Re: Big problem updating upp from version 6163 to 9614 [message #46183 is a reply to message #46180] Wed, 23 March 2016 20:10 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
nlneilson wrote on Wed, 23 March 2016 08:51
After tinkering, re-boot, which I had done several times before, trying to open theide several times I got the clock and button examples to compile and run, after 3 days work.

The install doc may need to mention the Community VS 2015 MUST BE USED ??
I hope a new user does not have this problem.
neil


Hello,

Should we still update documentation page? But, maybe the better question here is that upp works with visual studio enterprise or ultimate editor?

Sincerely,
Klugier


U++ - one framework to rule them all.
Re: Big problem updating upp from version 6163 to 9614 [message #46184 is a reply to message #46183] Wed, 23 March 2016 21:58 Go to previous message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
I could not get theide editor (upp) to work with the Enterprise version of VS 2015. Is there some kind of upp installer file ?? I just clicked on the theide.exe . It did not bring up the selection page.

I have been using upp for several years and it is great for my purpose but 3 days to get it to work again ???

I still need to figure how it will pull up the MYAPPS directory.


The installation instructions should be ' more better'
Whatever
Neil
Previous Topic: Ridiculous behavior of the hotkeys Ctrl+Alt+right and Ctrl+Alt+left in the Stacking mode
Next Topic: Selecting MYAPPS after starting theide.exe it is blank
Goto Forum:
  


Current Time: Fri Jun 21 00:03:27 CEST 2024

Total time taken to generate the page: 0.01004 seconds