Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » Connect with an external static library
Connect with an external static library [message #47596] Sat, 04 February 2017 09:27 Go to next message
iST1 is currently offline  iST1
Messages: 107
Registered: August 2013
Experienced Member
Please tell me how to connect to TheIDE an external static library (*.lib)
Re: Connect with an external static library [message #47597 is a reply to message #47596] Sat, 04 February 2017 12:58 Go to previous messageGo to next message
amrein is currently offline  amrein
Messages: 278
Registered: August 2008
Location: France
Experienced Member
Using TheIDE menus options.
To add static libraries:
  • Project > Package organizer..
To add an other path to search for this static library:
  • Setup > Build methods

Re: Connect with an external static library [message #47598 is a reply to message #47597] Sat, 04 February 2017 13:38 Go to previous messageGo to next message
iST1 is currently offline  iST1
Messages: 107
Registered: August 2013
Experienced Member
amrein wrote on Sat, 04 February 2017 12:58
Using TheIDE menus options.


  • Setup > Build methods





the screenshot below I can't find this item

[Updated on: Sat, 04 February 2017 13:39]

Report message to a moderator

Re: Connect with an external static library [message #47599 is a reply to message #47598] Sat, 04 February 2017 14:07 Go to previous messageGo to next message
amrein is currently offline  amrein
Messages: 278
Registered: August 2008
Location: France
Experienced Member
Two tips:
- Click on Core package (upper left), you will see an example on the right.
- Click on the right in the white space for pop up menu.

[Updated on: Sat, 04 February 2017 14:08]

Report message to a moderator

Re: Connect with an external static library [message #47626 is a reply to message #47599] Sat, 18 February 2017 09:30 Go to previous messageGo to next message
iST1 is currently offline  iST1
Messages: 107
Registered: August 2013
Experienced Member
I get "Linking has failed" for MSC9 after:
1) Build Method->LIB directories, append row with path for .lib
2) In Package organizer added .lib file name (see attached screen)
  • Attachment: 1.jpg
    (Size: 73.34KB, Downloaded 173 times)

[Updated on: Sat, 18 February 2017 09:30]

Report message to a moderator

Re: Connect with an external static library [message #47627 is a reply to message #47626] Sat, 18 February 2017 11:59 Go to previous messageGo to next message
Didier is currently offline  Didier
Messages: 671
Registered: November 2008
Location: France
Contributor
Hello IST1
You should remove the '.lib' extension from you're library name.

TIP : if you activate 'menu/setup/be verbose' you will see the complete linker command line: and you will probably see something like 'cpplib.lib.lib' ... which doesn't exist !

[Updated on: Sat, 18 February 2017 12:01]

Report message to a moderator

Re: Connect with an external static library [message #47633 is a reply to message #47627] Sun, 19 February 2017 06:27 Go to previous message
iST1 is currently offline  iST1
Messages: 107
Registered: August 2013
Experienced Member
Didier wrote on Sat, 18 February 2017 11:59
Hello IST1
You should remove the '.lib' extension from you're library name.

TIP : if you activate 'menu/setup/be verbose' you will see the complete linker command line: and you will probably see something like 'cpplib.lib.lib' ... which doesn't exist !



Thanks!
Next question is how to switch DEBUG and RELEASE (in WHRERE) version of .lib-file?
Previous Topic: [SOLVED] Showing elapsed time
Next Topic: Reading from .txt and putting data (double) in array[]
Goto Forum:
  


Current Time: Mon Nov 29 06:06:16 CET 2021

Total time taken to generate the page: 0.01469 seconds