Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » install UPP on a new laptop with Win 10 (problems)
install UPP on a new laptop with Win 10 [message #48019] Wed, 10 May 2017 12:28 Go to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Trying to install upp on a new laptop with Win 10

I downloaded 11040mingw from this website and also 7zip and unzipped 11040mngw and moved the unzipped folder to c/
clicked theide.exe but it could not find the c/myapps
directory

download from sourceforg 605
It got to the page with the terms that needs to be accepted but the bottom of the page says do you accept but there is no Yes box that can be clicked, the page cannot be scrolled down further.

How can I click 'theide in the 11040mingw directory and then find c/myapps ???


edit: it will now pick up c/myapps but: trying to execute any of the apps gives this error:
C:\myapps\Control\Serial.h (5): fatal error: CtrlLib/CtrlLib.h: No such file or directory

so apparently the core upp files are not found.

I have used upp for years but a new user may just give up running into this kind of a problem, too bad as upp is a very good app.

[Updated on: Wed, 10 May 2017 13:27]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48031 is a reply to message #48019] Thu, 11 May 2017 22:35 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

I made fresh installation to c drive and create simply "Test" CtrlLib package with layout. I put this package to MyApps assembly. The test was done on Windows 10. I would like to assure you that we are trying to make U++ as stable as possible.

I strongly believe you have problems with MyApps assemblies dependency. Moreover by default "MyApps" is placed in the upp directory not on pure "C:" drive. So, it must be custom install. Can you post your package configuration?

Here is my configuration (on linux):
/home/klugier/UppApps/MyApps;/home/klugier/upp/uppsrc
(FirstNestPath;SecondNestPath);

Please make sure you the second nest points to uppsrc. If nothing helps - clean upp instalation and copy your previous "MyApps" content to directory bundled with upp instllation. If the folder will not be presented - just run TheIDE once.

Sincerely,
Klugier


U++ - one framework to rule them all.

[Updated on: Thu, 11 May 2017 22:35]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48041 is a reply to message #48031] Fri, 12 May 2017 19:35 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Hi Klugier
Thanks for the reply.
I did have myapps directly under C: C:/myapps

Many times it has been recomended that the myapps should not be under the install directory of u++
because when upp is updated the myapps would be deleted along with all of the installed upp directory.
Or maybe I was confused on that.
On another computer that still has a running upp-mingw10200 the MyApps was directly under C:/
I installed on the new laptop upp-mingw11060 with c:/MyApps. I tinkered and got upp to pull up that directory but then got the fatal error: CtrlLib/CtrlLib.h: No such file or directory.
I deleted that install and did a fresh install of upp-mingw-11066.
(surprise-, there was not a 15 minute search for a compiler, I started a thread on that before.
I executed the clock example without a problem, the CtrlLib was found.
Then I copied MyApps to C:/upp-mingw-11066/upp. It found my apps OK. But:
running one of my apps:
Control.cpp
Serial.cpp
There were errors. (0:00.04)

the red lines that shows what the errors are and at what line does not show up, it did a few times and had a 'linking error'
I did another fresh download and install of C:/upp-mingw-11066/upp same results, no red lines showing what the errors were and the lines in the code where the errors were.

Upp is great when it is running correctly but problems like this takes so much time to get past.
Much of the problem is mine not knowing things.

[Updated on: Fri, 12 May 2017 19:43]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48042 is a reply to message #48041] Fri, 12 May 2017 21:27 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

First of all post the screen shot - how your "MyApps" settings look like. I am strongly interested in "Package nests" field. If you have problem with finding that information - I will post more concrete instructions in the next post. This is the most important information for me in this discussion.

Quote:

because when upp is updated the myapps would be deleted along with all of the installed upp directory.

If you keep evrything in the repository, I believe it shouldn't be the problem Smile

Well - if we want to debug why Serial.cpp does not compile you will probably need to published more information - full compiler output and some source code. The problem could be related to upp version not to the instalation. Make sure the include is made by #include <CtrlLib/CtrlLib.h>.

That's all I can write with information I posses from you by now.

Sincerely and have a nice day,
Klugier


U++ - one framework to rule them all.
Re: install UPP on a new laptop with Win 10 [message #48047 is a reply to message #48042] Sat, 13 May 2017 02:13 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
repository ??
"Package nests" field ??
I got into that years ago but don't remember

"The problem could be related to upp version" I have run into that several times before.
That is the reason I don't update very often.

After tinkering I got the red or pink error message section.

attached are two Screenshots, I don't know if they help.
  • Attachment: Ss1.jpg
    (Size: 198.04KB, Downloaded 213 times)

[Updated on: Sat, 13 May 2017 02:17]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48048 is a reply to message #48047] Sat, 13 May 2017 02:26 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Here is another Screen shot, I could not figure how to add the second to the post above.
  • Attachment: Ss2.jpg
    (Size: 157.30KB, Downloaded 236 times)
Re: install UPP on a new laptop with Win 10 [message #48053 is a reply to message #48048] Sat, 13 May 2017 14:11 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

At the first spot I see that you have not connected CtrlCore to your package - can you do this? You can do this by "Add package operation" and select CtrlCore - if it will not be available it will mean that uppsrc nest is wrongly configured.

I was talking about this window:
index.php?t=getfile&id=5273&private=0
But the two above screen-shots are perfect. Especially the one where there is no CtrlCore connected (Ss2.jpg) Smile

Can you also post .upp package related file. This will help to define what's really happend - it would be good to have the versions where it works and where it is not. The .upp is TheIDE package file and can be found in package directory.

Sincerely,
Klugier


U++ - one framework to rule them all.

[Updated on: Sat, 13 May 2017 14:15]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48054 is a reply to message #48048] Sat, 13 May 2017 14:27 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Attached is a file of the 'error' or whatever is in pink when the app fails to execute app fails to /run it seems to be link errors and not compile errors.
Pasted into Notepad++ there are 1602 lines
Re: install UPP on a new laptop with Win 10 [message #48055 is a reply to message #48054] Sat, 13 May 2017 14:56 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

As I said you do not have CtrlCore connected to your package for some reason - can you add that package to "Control" package?

Sincerely,
Klugier


U++ - one framework to rule them all.
Re: install UPP on a new laptop with Win 10 [message #48056 is a reply to message #48055] Sat, 13 May 2017 16:59 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Klugier wrote on Sat, 13 May 2017 05:56
Hello,

As I said you do not have CtrlCore connected to your package for some reason - can you add that package to "Control" package?

Sincerely,
Klugier



How do I do that in upp?

In a Java app using Eclipse it is setting the path.
IIR much of that is done with an automatic search.
I do not recall how that is done in upp.

Neil
Re: install UPP on a new laptop with Win 10 [message #48057 is a reply to message #48056] Sat, 13 May 2017 19:00 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

Just use main menu bar: "Project" -> "Add package to $(Package name)". In the huge list find "CtrlCore". Alternatively, you could find "Brick with plus" on the main ide toolbar. That's all!

It is one of the ide basic concept to add package, so I believe you should did this in your projects over the time.

Sincerely,
Klugier


U++ - one framework to rule them all.
Re: install UPP on a new laptop with Win 10 [message #48062 is a reply to message #48057] Sat, 13 May 2017 22:43 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Ss3 shows Ctrllib and core

I must have done this before but how and why I don't remember.
  • Attachment: Ss3.jpg
    (Size: 150.57KB, Downloaded 189 times)
Re: install UPP on a new laptop with Win 10 [message #48063 is a reply to message #48062] Sun, 14 May 2017 00:17 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

You still don't append "CtrlCore" to your project. "CtrlLib" without "CtrlCore" will not work. Can you make following steps and can you confirm that CtrlCore is listed on the list in dialog window?

Tutorial:
index.php?t=getfile&id=5278&private=0

EDIT - VERY IMPORTANT:
After last screenshot I can confirm that the nest is wrongly set. Can you make the screen-shot of MyAppps assembly setup this is shown in the message #48053. To open that dialog - open TheIDE and double click on "MyApps" assembly.

Sincerely,
Klugier


U++ - one framework to rule them all.

[Updated on: Sun, 14 May 2017 00:24]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48064 is a reply to message #48063] Sun, 14 May 2017 00:50 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
I clicked Project and found and selected CtrlCore
  • Attachment: Ss5.jpg
    (Size: 162.65KB, Downloaded 199 times)
Re: install UPP on a new laptop with Win 10 [message #48065 is a reply to message #48019] Sun, 14 May 2017 01:21 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Here is a screen shot from another computer that is running an older version of upp: 10200
The same code has been running OK
I am very reluctant to update that to a later version of upp if it will take several days to get it running.
it took a few weeks to get the 'always on top' working.
  • Attachment: 01-Ss4.jpg
    (Size: 166.26KB, Downloaded 185 times)
Re: install UPP on a new laptop with Win 10 [message #48066 is a reply to message #48019] Sun, 14 May 2017 09:23 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Going back in time I think there was a 'stub' file that was created when a type of app was selected

"init" with no extension and was basically a text file that could be edited


#ifndef _GeoCalc_icpp_init_stub
#define _GeoCalc_icpp_init_stub
#include "CtrlLib/init"
#include "Core/init"
#include "Web/init"
#endif



That had
#include "CtrlLib/init"
#include "Core/init"


The 'new' and much improved method of clicking 'project' and then what should be 'included'
is 'more better' but I have a hard time getting used to that method.

I do appreciate the help. But I am still having problems getting upp to run.
  • Attachment: init
    (Size: 0.14KB, Downloaded 178 times)

[Updated on: Sun, 14 May 2017 09:25]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48067 is a reply to message #48066] Sun, 14 May 2017 12:03 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
It sure looks like CtrlCore has been selected correctly by Ss6

but I am still getting the linking error
  • Attachment: Ss6.jpg
    (Size: 162.32KB, Downloaded 211 times)
Re: install UPP on a new laptop with Win 10 [message #48070 is a reply to message #48067] Sun, 14 May 2017 15:35 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

If everything is added correctly, we need to check that "MyAppps" assembly is configured correctly. As I said before - you need to check this by your own and post screenshot.

When you open TheIDE for the first time, the window with main package list will show. On the left site of the window - you will have the list of assemblies. There you will find "MyApps". Double click on it or right click on it and select "Edit assembly..". The make the screen-shot and post it here. I do not need more screen-shot that shows the linking error. The assembly nest for your configuration should look like this
C:\\MyApps;C:\\upp\uppsrc
(ValidPathToMyApps;ValidPathToUppsrc)

I belive "ValidPathToUppsrc" can be accidentally delete by you when you manullay configured "MyApps" custom directory. You need to be carefully there.


If you open the dialog - open "uppsrc" assembly to and make sure the path that is show there is presented in the "MyApps" assembly.

Sincerely,
Klugier


U++ - one framework to rule them all.
Re: install UPP on a new laptop with Win 10 [message #48073 is a reply to message #48019] Sun, 14 May 2017 17:04 Go to previous messageGo to next message
nlneilson is currently offline  nlneilson
Messages: 644
Registered: January 2010
Location: U.S. California. Mojave &...
Contributor
Here is the screenshot of my assembly.

Note that I have copied MyApps into the upp directory.

Also I can not log in to this forum on the new computer, I have been on more than 20 times

something about a cookie expired as a possibility, I am logged in on my older computer
  • Attachment: Ss7.jpg
    (Size: 102.87KB, Downloaded 190 times)

[Updated on: Sun, 14 May 2017 17:07]

Report message to a moderator

Re: install UPP on a new laptop with Win 10 [message #48078 is a reply to message #48073] Sun, 14 May 2017 21:29 Go to previous messageGo to previous message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello,

At the moment i cannot find the reason of the problem. I will let you know if i find some clues. Maybe the problem is related indeed with init file. I have never used this kind of solution, so i will not help in this area. Maybe you should try to drop this and use more straight forward way of developing.

Sincerely,
Klugier


U++ - one framework to rule them all.
Previous Topic: C++11 issue under Linux
Next Topic: PromptOK and \n
Goto Forum:
  


Current Time: Wed Jun 12 20:05:13 CEST 2024

Total time taken to generate the page: 0.01798 seconds