Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » Package Organizer bug?
Package Organizer bug? [message #48713] Mon, 28 August 2017 04:35 Go to next message
arie is currently offline  arie
Messages: 3
Registered: August 2017
Junior Member
Hello,

I have just started to give U++ a try and have already had several occasions where the IDE simply dropped out.

Of course I am playing with the IDE to get the grip on it but have one occasion that is always giving a fatal error.

When I select Package Organizer I receive the following xmessage dialog:
Fatal Error
Assertion failed in /buid/upp-by-QxWM/upp-10804/uppsrc/Core/Value.cpp line 338
type < 0x8000000

I would like to know what I am doing wrong.

This is tested on two system: Mint 17.2 and Bodhi Linux (Ubuntu Xenial clone) with the same results.

Re: Package Organizer bug? [message #48718 is a reply to message #48713] Mon, 28 August 2017 10:07 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13984
Registered: November 2005
Ultimate Member
arie wrote on Mon, 28 August 2017 04:35
Hello,

I have just started to give U++ a try and have already had several occasions where the IDE simply dropped out.

Of course I am playing with the IDE to get the grip on it but have one occasion that is always giving a fatal error.

When I select Package Organizer I receive the following xmessage dialog:
Fatal Error
Assertion failed in /buid/upp-by-QxWM/upp-10804/uppsrc/Core/Value.cpp line 338
type < 0x8000000

I would like to know what I am doing wrong.

This is tested on two system: Mint 17.2 and Bodhi Linux (Ubuntu Xenial clone) with the same results.



Hi,

how have you compiled/got theide?

(This is really interesting, it obviously is a bug, but at the same time, ASSERTs are only active in debug mode, so this would indicate that your binary is somehow compiled in debug mode.)

Can you try to download/compile the latest nightly?

https://www.ultimatepp.org/www$uppweb$nightly$en-us.html

Mirek
Re: Package Organizer bug? [message #48720 is a reply to message #48718] Mon, 28 August 2017 12:38 Go to previous message
arie is currently offline  arie
Messages: 3
Registered: August 2017
Junior Member
I have built the latest version (11304) and the problem has disappeared Razz

The other version that I was using came from Synaptic (I added the repository).

Thanks for the quick support Smile
Previous Topic: Tabctrl
Next Topic: What's the relationship between the U++ GUI and OpenGL?
Goto Forum:
  


Current Time: Sat Jun 15 19:49:41 CEST 2024

Total time taken to generate the page: 0.01477 seconds