Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Installation, Compiling and Running of theide » 608-dev2 command line "make" problem
608-dev2 command line "make" problem [message #5046] Fri, 01 September 2006 08:29 Go to next message
3togo is currently offline  3togo
Messages: 83
Registered: May 2006
Location: Hong Kong SAR
Member
I am trying to make "ide" by typing "make" on the terminal without using "theide" .

I found that I have to add the following lines to the top of CtrlLib/LabelBase.cpp before ide be successfully built from 608-dev2 under Ubuntu (Edgy).

#define IMAGECLASS CtrlsImg
#define IMAGEFILE <CtrlLib/Ctrls.iml>
#include <Draw/iml_source.h>

Please look into it.

Many thanks.

3togo

[Updated on: Fri, 01 September 2006 08:30]

Report message to a moderator

Re: 608-dev2 command line "make" problem [message #5047 is a reply to message #5046] Fri, 01 September 2006 08:51 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12118
Registered: November 2005
Ultimate Member
Have you made a fresh makefile export?

(makefiles are not maintained for dev versions...)

Mirek
Re: 608-dev2 command line "make" problem [message #5048 is a reply to message #5047] Fri, 01 September 2006 09:06 Go to previous messageGo to next message
3togo is currently offline  3togo
Messages: 83
Registered: May 2006
Location: Hong Kong SAR
Member
It is already a fresh Makefile. I guess it is an old problem about Makefile generator failed to recognize ".icpp" .

p.s.
By the way, may I suggest that "ide" should generate Makefile using relative address instead of absolute address.

e.g.
#UPPDIR1 = /home/jc/upp/uppsrc/
#UPPOUT = /home/jc/upp/out/
UPPDIR1 = ..//
UPPOUT = ..//..//out/

Regards,


3togo
  • Attachment: Makefile
    (Size: 811.47KB, Downloaded 1608 times)
Re: 608-dev2 command line "make" problem [message #5088 is a reply to message #5046] Sun, 03 September 2006 22:59 Go to previous message
forlano is currently offline  forlano
Messages: 1071
Registered: March 2006
Location: Italy
Experienced Contributor
3togo wrote on Fri, 01 September 2006 08:29

I am trying to make "ide" by typing "make" on the terminal without using "theide" .

I found that I have to add the following lines to the top of CtrlLib/LabelBase.cpp before ide be successfully built from 608-dev2 under Ubuntu (Edgy).

#define IMAGECLASS CtrlsImg
#define IMAGEFILE <CtrlLib/Ctrls.iml>
#include <Draw/iml_source.h>

Please look into it.

Many thanks.

3togo



I would like to confirm that without the above fix my package is not compiled by the makefile. In the same time theide is not able to compile it.
If the above fix is not applied, only theide can compile the package (607-dev1 under ubuntu)

Luigi
Previous Topic: latest UVS2 link error and fix in CtrlLib
Next Topic: TheIde 608-dev2 crash on linux when mouse-move!
Goto Forum:
  


Current Time: Sat Dec 07 13:25:05 CET 2019

Total time taken to generate the page: 0.02028 seconds