Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » RichText,QTF,RTF... » uword table and ctrl+a (bug)
uword table and ctrl+a (bug) [message #51761] Fri, 17 May 2019 13:02
wqcmaster is currently offline  wqcmaster
Messages: 33
Registered: March 2013
Member
Hello,

i found a strange behaviour when selecting all (ctrl+a) in the uword editor so that just the top subtable gets selected.

Here an example file:
[ $$0,0#00000000000000000000000000000000:Default]
[{_} 
[ {{10000 [ {{5000:5000 [s0;%% test1]
:: [s0;%% test2]}}]
:: [ {{5000:5000 [s0;%% test3]
:: [s0;%% test4]}}]
:: [ {{5000:5000 [s0;%% test5]
:: [s0;%% test6]}}]}}]]


I could not pinpoint the exact cause of the issue, but it goes as deep as the part (not detecting the initial table properly?)
const RichTxt& txt = GetConstText(anchor);


in the function of the TextData.cpp
int  RichText::AdjustCursor(int anchor, int cursor) const



However, when i add breaklines before and after the main table it works just fine (file like this):
[ $$0,0#00000000000000000000000000000000:Default]
[{_}%EN-US 
[s0; &]
[ {{10000 [ {{5000:5000 [s0; test1]
:: [s0; test2]}}]
:: [ {{5000:5000 [s0; test3]
:: [s0; test4]}}]
:: [ {{5000:5000 [s0; test5]
:: [s0; test6]}}]}}&]
[s0; ]]


Sincerly,

wqcmaster

[Updated on: Fri, 17 May 2019 13:03]

Report message to a moderator

Previous Topic: Potential QTF minor bug or misunderstanding
Next Topic: QTF and not UTF8 characters
Goto Forum:
  


Current Time: Sun Aug 25 20:06:54 CEST 2019

Total time taken to generate the page: 0.01149 seconds