Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Mac OS » Input field in dark mode looking ugly
Input field in dark mode looking ugly [message #53571] Mon, 13 April 2020 13:17 Go to next message
forlano is currently offline  forlano
Messages: 1109
Registered: March 2006
Location: Italy
Senior Contributor
Hello,

I do not know where to post this issue. Maybe it is related even to others OSes.
In dark mode the input field does not look good. In the below picture you see the selected input field that is hilighted yellow but its content is not readable. A better combination of colour would be desirable.

Can I do something to improve it?

Thanks,
luigi

index.php?t=getfile&id=6043&private=0
  • Attachment: dark.png
    (Size: 487.51KB, Downloaded 121 times)
Re: Input field in dark mode looking ugly [message #53593 is a reply to message #53571] Tue, 14 April 2020 12:34 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 12850
Registered: November 2005
Ultimate Member
Hi,

it is hard to find out from the screenshot which kind of widget that actually is...

Can you e.g. post a simple testcase?

Mirek
Re: Input field in dark mode looking ugly [message #53610 is a reply to message #53593] Tue, 14 April 2020 19:39 Go to previous messageGo to next message
forlano is currently offline  forlano
Messages: 1109
Registered: March 2006
Location: Italy
Senior Contributor
mirek wrote on Tue, 14 April 2020 12:34

Can you e.g. post a simple testcase?


I tried to make a test case but with no success.
Then looking at the code of my program I found the row responsible of my problem

EditField::StyleDefault().Write().focus = Yellow();

Embarassed After removing it everything was OK.
Sorry for the false alarm.

Luigi
Re: Input field in dark mode looking ugly [message #53612 is a reply to message #53610] Wed, 15 April 2020 10:08 Go to previous message
mirek is currently offline  mirek
Messages: 12850
Registered: November 2005
Ultimate Member
forlano wrote on Tue, 14 April 2020 19:39
mirek wrote on Tue, 14 April 2020 12:34

Can you e.g. post a simple testcase?


I tried to make a test case but with no success.
Then looking at the code of my program I found the row responsible of my problem

EditField::StyleDefault().Write().focus = Yellow();

Embarassed After removing it everything was OK.
Sorry for the false alarm.

Luigi


OK, that explains it Smile

General quick fix is to use SYellow.

Mirek
Previous Topic: [SOLVED] Main bar position and ugly gap
Next Topic: missing libmysqlclient.dylib [SOLVED]
Goto Forum:
  


Current Time: Sun Nov 01 02:33:52 CET 2020

Total time taken to generate the page: 0.00811 seconds