Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Mac OS » Fail to get theIde started with macos
Fail to get theIde started with macos [message #56596] Sat, 27 March 2021 07:47 Go to next message
LeiMing is currently offline  LeiMing
Messages: 21
Registered: September 2009
Location: China
Promising Member

Hello, I just get a macbookpro computer and very newbie to macOs.
I find that upp now support macos and want to have a try upp on macos.
With the upp's macos build downloaded, I extract the xz archive and run theIde application.
After requesting several permissions it comes up with a dialog to fetch source code from svn repository, which I never met when run it on Windows.
Selecting the matched version of upp, it popups with a dialog with a commandline show on it, but doing nothing.

I have checked that the svn command runs in terminal. I have also checked that uppsrc folder does exists.
I don't know where to start with, ending with this thread posted in forum for help Embarassed

The attachment is what happened in the macbookpro computer when I run theIde.
The system version is macos big sur 11.2.2, in simpified chinese.
Re: Fail to get theIde started with macos [message #56598 is a reply to message #56596] Sat, 27 March 2021 10:41 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13990
Registered: November 2005
Ultimate Member
LeiMing wrote on Sat, 27 March 2021 07:47
Hello, I just get a macbookpro computer and very newbie to macOs.
I find that upp now support macos and want to have a try upp on macos.
With the upp's macos build downloaded, I extract the xz archive and run theIde application.
After requesting several permissions it comes up with a dialog to fetch source code from svn repository, which I never met when run it on Windows.
Selecting the matched version of upp, it popups with a dialog with a commandline show on it, but doing nothing.

I have checked that the svn command runs in terminal. I have also checked that uppsrc folder does exists.
I don't know where to start with, ending with this thread posted in forum for help Embarassed

The attachment is what happened in the macbookpro computer when I run theIde.
The system version is macos big sur 11.2.2, in simpified chinese.


Are you trying with 2020/2 release or with nightly build?
Re: Fail to get theIde started with macos [message #56601 is a reply to message #56598] Sat, 27 March 2021 12:49 Go to previous messageGo to next message
LeiMing is currently offline  LeiMing
Messages: 21
Registered: September 2009
Location: China
Promising Member

I'm trying with 2020.2 (svn 15260).
There is no download link for macos on nightly build page.
Re: Fail to get theIde started with macos [message #56602 is a reply to message #56601] Sat, 27 March 2021 19:45 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
LeiMing wrote on Sat, 27 March 2021 07:49
I'm trying with 2020.2 (svn 15260).
There is no download link for macos on nightly build page.

You could try to build it from the source code:
git clone https://github.com/ultimatepp/ultimatepp.git
cd ultimatepp
make -f umkMakefile
./umk ./uppsrc ide CLANG -busr



Regards,
Novo
Re: Fail to get theIde started with macos [message #56606 is a reply to message #56602] Sun, 28 March 2021 09:14 Go to previous messageGo to next message
LeiMing is currently offline  LeiMing
Messages: 21
Registered: September 2009
Location: China
Promising Member

I tried to perform building on macos from github source.

It firstly shows that png.h not found. I use ```brew install libpng``` then re-run ./configure to resolve it.
(I wonder if I should use flags to tell it using the static link one)

After get the umk exectuble file, I tried to build upp with umk.

It comes out openssl/openssl.h not found.
I use ```brew reinstall openssl``` to make sure openssl installed, but the umk build system seems not to find it.
I also try to add CPPFLAGS=-I/usr/local/opt/openssl/include and LDFLAGS=-L/usr/local/opt/openssl/lib to tell it where openssl is, but it didn't work.
Re: Fail to get theIde started with macos [message #56608 is a reply to message #56601] Sun, 28 March 2021 14:40 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13990
Registered: November 2005
Ultimate Member
LeiMing wrote on Sat, 27 March 2021 12:49
I'm trying with 2020.2 (svn 15260).
There is no download link for macos on nightly build page.


You can try now...
Re: Fail to get theIde started with macos [message #56609 is a reply to message #56596] Sun, 28 March 2021 14:50 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
You'd need to install dependencies anyway.
TheIDE is using pkg-config to locate include/lib files. You do not need to run configure.
umk docs.
Take a look at option v.
Additional options are stored in Build Method (bm) files. You can create manually one by yourself.
I've built TheIDE for you just in case ...


Regards,
Novo
Re: Fail to get theIde started with macos [message #56634 is a reply to message #56596] Tue, 30 March 2021 12:02 Go to previous messageGo to next message
LeiMing is currently offline  LeiMing
Messages: 21
Registered: September 2009
Location: China
Promising Member

Hi, when I use the newest svn version, it just behaviors the same as 2020.2, which popuping a dialog to ask me fetch svn repository (same as the video in first post of this thread).

When I try building from source my self, if I download source code from github, then it seems I have to run configure script or it can't make.
After trials and errors I have these libraries installed:
libpng, freetype2, libxcb, fontconfig, libx11
and had "umk" built.

when I try to build the ide by umk, it comes out to be error just as before.
It doesn't add pkg-config for openssl.
it says
jiangjun@jiangjundeMBP ultimatepp-master % ./umk ./uppsrc ide CLANG -busr -H1 -v
Inline assembly: /Users/jiangjun/dev/ultimatepp-master/uppsrc
Output directory: /Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out
Main package: /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/ide.upp
Build flags: GUI
Build method: /Users/jiangjun/.config/u++/umk/CLANG.bm
----- ide/Common ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (1 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Common
----- ide/Core ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (2 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Core
----- ide/LayDes ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (3 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/LayDes
----- ide/IconDes ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (4 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/IconDes
----- ide/Builders ( GUI CLANG SHARED POSIX BSD OSX ) (5 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Builders
----- ide/Debuggers ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (6 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Debuggers
/Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Debuggers/i386.cpu(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Debuggers/Cpu.cpp
/Users/jiangjun/dev/ultimatepp-master/uppsrc/CtrlCore/lay.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Debuggers/Pdb.cpp
----- ide/Browser ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (7 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Browser
----- CodeEditor ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (8 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/CodeEditor
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/t.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/CodeEditor/CodeEditor.cpp
----- CtrlLib ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (9 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/CtrlLib
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/t.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/CtrlLib/CtrlLibInit.cpp
/Users/jiangjun/dev/ultimatepp-master/uppsrc/CtrlLib/XPTheme.dli(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/CtrlLib/ChWin32.cpp
----- plugin/bz2 ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (10 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/plugin/bz2
----- HexView ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (11 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/HexView
----- plugin/astyle ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (12 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/plugin/astyle
----- TextDiffCtrl ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (13 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/TextDiffCtrl
----- TabBar ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (14 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/TabBar
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/t.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/TabBar/TabBar.cpp
----- ide/Designers ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (15 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Designers
----- ide/Android ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (16 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Android
----- ide/Java ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (17 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/Java
----- ide/MacroManager ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (18 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/ide/MacroManager
----- Report ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (19 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/Report
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/t.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/Report/ReportDlg.cpp
----- Core/SSL ( GUI CLANG SHARED BLITZ POSIX BSD OSX ) (20 / 40)
cd /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Util.cpp
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/InitExit.cpp
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Socket.cpp
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h(1) : blocks BLITZ of /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/P7S.cpp
Util.cpp
clang++ -c `pkg-config --cflags freetype2` `pkg-config --cflags x11` `pkg-config --cflags fontconfig` `pkg-config --cflags xcb` `pkg-config --cflags expat`  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Util.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Util.o"
In file included from /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Util.cpp:1:
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h:3:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
/usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Util.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Util.o"
Error executing /usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Util.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Util.o"
compiled in (0:01.06)
InitExit.cpp
clang++ -c `pkg-config --cflags freetype2` `pkg-config --cflags x11` `pkg-config --cflags fontconfig` `pkg-config --cflags xcb` `pkg-config --cflags expat`  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/InitExit.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/InitExit.o"
In file included from /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/InitExit.cpp:1:
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h:3:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
/usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/InitExit.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/InitExit.o"
Error executing /usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/InitExit.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/InitExit.o"
compiled in (0:01.20)
Socket.cpp
clang++ -c `pkg-config --cflags freetype2` `pkg-config --cflags x11` `pkg-config --cflags fontconfig` `pkg-config --cflags xcb` `pkg-config --cflags expat`  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Socket.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Socket.o"
In file included from /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Socket.cpp:1:
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h:3:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
/usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Socket.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Socket.o"
Error executing /usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/Socket.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/Socket.o"
compiled in (0:01.08)
P7S.cpp
clang++ -c `pkg-config --cflags freetype2` `pkg-config --cflags x11` `pkg-config --cflags fontconfig` `pkg-config --cflags xcb` `pkg-config --cflags expat`  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/P7S.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/P7S.o"
In file included from /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/P7S.cpp:1:
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h:3:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
/usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/P7S.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/P7S.o"
Error executing /usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/P7S.cpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/P7S.o"
compiled in (0:01.23)
SSL.icpp
clang++ -c `pkg-config --cflags freetype2` `pkg-config --cflags x11` `pkg-config --cflags fontconfig` `pkg-config --cflags xcb` `pkg-config --cflags expat`  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.icpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/SSL.o"
In file included from /Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.icpp:1:
/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.h:3:10: fatal error: 'openssl/ssl.h' file not found
#include <openssl/ssl.h>
         ^~~~~~~~~~~~~~~
1 error generated.
/usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.icpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/SSL.o"
Error executing /usr/bin/clang++ -c -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libx11/1.7.0/include -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 -I/usr/local/Cellar/fontconfig/2.13.1/include -I/usr/local/opt/freetype/include/freetype2
 -I/usr/local/Cellar/libxcb/1.14_1/include -I/usr/local/Cellar/libxau/1.0.9/include -I/usr/local/Cellar/libxdmcp/1.1.3/include -I/usr/local/Cellar/xorgproto/2021.3/include
 
  -I"/Users/jiangjun/dev/ultimatepp-master/uppsrc" -I"/opt/local/include" -I"/usr/include" -I"/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared" -DflagGUI -DflagCLANG -DflagSHARED -DflagBLITZ -DflagPOSIX -DflagBSD -DflagOSX  -fexceptions -mmacosx-version-min=10.13 -O3 -ffunction-sections -fdata-sections -x c++ -std=c++14 -Wall -Wno-logical-op-parentheses "/Users/jiangjun/dev/ultimatepp-master/uppsrc/Core/SSL/SSL.icpp"  -o "/Users/jiangjun/dev/ultimatepp-master/./.cache/upp.out/Core/SSL/CLANG.Blitz.Gui.Shared/SSL.o"
compiled in (0:01.18)
Core/SSL: 5 file(s) built in (0:05.43), 1087 msecs / file

There were errors. (0:05.93)
jiangjun@jiangjundeMBP ultimatepp-master % pkg-config --cflags openssl                    
-I/usr/local/Cellar/openssl@1.1/1.1.1k/include
jiangjun@jiangjundeMBP ultimatepp-master % pkg-config --libs openssl                    
-L/usr/local/Cellar/openssl@1.1/1.1.1k/lib -lssl -lcrypto
jiangjun@jiangjundeMBP ultimatepp-master % 
Re: Fail to get theIde started with macos [message #56636 is a reply to message #56634] Tue, 30 March 2021 13:50 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13990
Registered: November 2005
Ultimate Member
LeiMing wrote on Tue, 30 March 2021 12:02
Hi, when I use the newest svn version, it just behaviors the same as 2020.2, which popuping a dialog to ask me fetch svn repository (same as the video in first post of this thread).


I see. That probably means sources that are shipped with it are somehow not found.

Novo, can you try nightly on fresh (as in "nothing else installed / activated besides things described in "Install U++ on MacOS" virtual?

Mirek

Re: Fail to get theIde started with macos [message #56638 is a reply to message #56636] Tue, 30 March 2021 15:36 Go to previous messageGo to next message
Klugier is currently offline  Klugier
Messages: 1077
Registered: September 2012
Location: Poland, Kraków
Senior Contributor
Hello Mirek,

I downloaded 15883 following on macOS and I didn't observe any issue. After unpacking archive to home directory everything works as expected. I also checked uppsrc directory and there are no .svn directory.

I also removed following direcotry - just in case:
~/.upp


As, we discussed before - I have OpenSSL location in different place, so the build method should be elastic enough to handle it. Without this change the application requiers OpenSSL will do not work. For more information please read this message.

Klugier


U++ - one framework to rule them all.

[Updated on: Tue, 30 March 2021 15:38]

Report message to a moderator

Re: Fail to get theIde started with macos [message #56639 is a reply to message #56638] Tue, 30 March 2021 15:40 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13990
Registered: November 2005
Ultimate Member
Klugier wrote on Tue, 30 March 2021 15:36
Hello Mirek,

I downloaded 15883 following on macOS and I didn't observe any issue. After unpacking archive to home directory everything works as expected. I also checked uppsrc directory and there are no .svn directory.

I also removed following direcotry - just in case:
~/.upp


As, we discussed before - I have OpenSSL location in different place, so the build method should be elastic enough to handle it. Without this change the application requiers OpenSSL will do not work. For more information please read this message.

Klugier


Well, the problem is that we both have run it already on those systems. It might be some setting or brew install we forgot about already. That is why I thought Nove checking in fresh installed virtual might be helpful.

Mirek
Re: Fail to get theIde started with macos [message #56640 is a reply to message #56636] Tue, 30 March 2021 18:37 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
mirek wrote on Tue, 30 March 2021 07:50

Novo, can you try nightly on fresh (as in "nothing else installed / activated besides things described in "Install U++ on MacOS" virtual?

Missing instruction: "brew install svn".
But even after that initial configurator didn't check source from svn out and created a dummy MyApps nest.
Basically, TheIDE doesn't work out of the box and requires manual editing of var-files.
It would be great to have "latest" and "stable" versions on the Download page ...


Regards,
Novo
Re: Fail to get theIde started with macos [message #56641 is a reply to message #56596] Tue, 30 March 2021 18:44 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
And the Download web-page doesn't explicitly say that this Mac build is for 10.15 and above ...

Regards,
Novo
Re: Fail to get theIde started with macos [message #56642 is a reply to message #56641] Tue, 30 March 2021 19:01 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
Actually, "stable" link is there, but it is called "latest", and it is not in the table Smile

Regards,
Novo
Re: Fail to get theIde started with macos [message #56643 is a reply to message #56634] Tue, 30 March 2021 19:07 Go to previous messageGo to next message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
LeiMing wrote on Tue, 30 March 2021 06:02

After trials and errors I have these libraries installed:
libpng, freetype2, libxcb, fontconfig, libx11
and had "umk" built.

Except of the libpng these libraries are X11-related. This is Linux stuff. You do not need them on Mac.
Below are dependencies of TheIDE on 10.13:
$ otool -L ide 
ide:
 /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation (compatibility version 300.0.0, current version 1455.255.0)
 /System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0, current version 22.0.0)
 /System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0, current version 158.0.0)
 /usr/lib/libbz2.1.0.dylib (compatibility version 1.0.0, current version 1.0.5)
 /usr/lib/libz.1.dylib (compatibility version 1.0.0, current version 1.2.11)
 /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 1252.50.4)
 /usr/lib/libc++.1.dylib (compatibility version 1.0.0, current version 400.9.0)
 /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit (compatibility version 45.0.0, current version 1561.61.100)
 /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation (compatibility version 150.0.0, current version 1455.255.0)
 /System/Library/Frameworks/CoreGraphics.framework/Versions/A/CoreGraphics (compatibility version 64.0.0, current version 1161.21.5)
 /System/Library/Frameworks/CoreText.framework/Versions/A/CoreText (compatibility version 1.0.0, curren


Regards,
Novo
Re: Fail to get theIde started with macos [message #56655 is a reply to message #56596] Thu, 01 April 2021 08:33 Go to previous messageGo to next message
LeiMing is currently offline  LeiMing
Messages: 21
Registered: September 2009
Location: China
Promising Member

Hi, I can't build it from source on macOs (the openssl error) but I find a way to make the pre-built one works.

index.php?t=getfile&id=6411&private=0

Then I find it doesn't support Chinese character input with IME in both code editor or layout editor.
It can support pasting Chinese character though.
  • Attachment: uppide.jpg
    (Size: 551.40KB, Downloaded 404 times)

[Updated on: Thu, 01 April 2021 08:48]

Report message to a moderator

Re: Fail to get theIde started with macos [message #56658 is a reply to message #56655] Thu, 01 April 2021 17:29 Go to previous message
Novo is currently offline  Novo
Messages: 1370
Registered: December 2006
Ultimate Contributor
You should launch TheIDE in a regular Mac way, otherwise certain stuff won't work.

Regards,
Novo
Previous Topic: I cant compile sound example....
Next Topic: Never to able to compile any example.
Goto Forum:
  


Current Time: Tue Jul 16 18:40:06 CEST 2024

Total time taken to generate the page: 0.02679 seconds