Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ Library support » U++ Libraries and TheIDE: i18n, Unicode and Internationalization » [BUG] Translatable menu text of accelerator keys contains invalid characters.
[BUG] Translatable menu text of accelerator keys contains invalid characters. [message #56673] Fri, 02 April 2021 13:11 Go to next message
Oblivion is currently offline  Oblivion
Messages: 961
Registered: August 2007
Experienced Contributor
Hello,

If accelerator keys with translatable ( with t_() ) text are used on GNOME, the menu text contain invalid character(s), See: reference/AK


Code:

void App::MainMenu(Bar& menu)
{
	menu.Sub(t_("AK"), [=](Bar& bar) { AkMenu(bar); });
	menu.Sub(t_("Setup"), [=](Bar& bar) { SetupMenu(bar); });
}



Screenshot:

index.php?t=getfile&id=6412&private=0

This occurs on other applications with translatable text (when Accelarator keys are enabled) as well.

Edit: This happens on menu items with translatable text, not defined in .key file (as is in the above example).

Best regards,
Oblivion.


[Updated on: Fri, 02 April 2021 13:48]

Report message to a moderator

Re: [BUG?] Translatable menu text of accelerator keys contains invalid characters. [message #56674 is a reply to message #56673] Fri, 02 April 2021 14:11 Go to previous message
Oblivion is currently offline  Oblivion
Messages: 961
Registered: August 2007
Experienced Contributor

It appears that tt_() macro can be used to fix this issue, as it does not prepend '\3' to string literals.

But I am not sure if this is a hack or officially supported....


Best regards,
Oblivion


Previous Topic: Missing translation string in CtrlLib/AKeys.cpp
Next Topic: About Chinese font display solutions
Goto Forum:
  


Current Time: Wed Jun 29 05:19:07 CEST 2022

Total time taken to generate the page: 0.01289 seconds