Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Developing U++ » Bugs (& fixes) » strange situation in the ide with package that hasn't opened anymore.
strange situation in the ide with package that hasn't opened anymore. [message #57339] Wed, 14 July 2021 22:59 Go to next message
BetoValle is currently offline  BetoValle
Messages: 203
Registered: September 2020
Location: Brasil Valinhos SP
Experienced Member
Hi

Suddenly the main package of a program that's getting big doesn't open anymore. And to make matters worse, in addition to not opening, the ide tries to open and closes and aborts!
Other packages that are linked to this main package open normally.

What I had to do to get around the situation out of ide. I opened the main package folder, renamed the files, outside the ide.
Inside the ide I created a new package. I closed the ide and copied the renamed files to this new package and it works normally. BUT it made me very unsure of what could have happened!

Another important information: before this happened I noticed that from within the ide , when I opened other files outside the package being edited, the other tabs started to close and I could only operate with files from 1 package. Very strange, or maybe unintentionally I triggered something that could have this behavior, but I don't know.

Please, if anyone has experienced this, despite having performed a procedure that I have described and apparently normalized, give me a light on this occurrence.

Thanks!
Re: strange situation in the ide with package that hasn't opened anymore. [message #57340 is a reply to message #57339] Wed, 14 July 2021 23:03 Go to previous messageGo to next message
BetoValle is currently offline  BetoValle
Messages: 203
Registered: September 2020
Location: Brasil Valinhos SP
Experienced Member
Hi,

additional important info: i can no longer create a package with the previous name, because the ide creates the folder, but then aborts!!!
Re: strange situation in the ide with package that hasn't opened anymore. [message #57341 is a reply to message #57340] Thu, 15 July 2021 01:21 Go to previous messageGo to next message
BetoValle is currently offline  BetoValle
Messages: 203
Registered: September 2020
Location: Brasil Valinhos SP
Experienced Member
HI,

I found file in folder U++/cfg: ffff@AisisPlan.cfg
where "ffff" is the "problem file".

i tried to eliminate it to see if it solved the problem and after that everything seems to have been restored. So the possible solution of a "crash" I believe can be solved by eliminating this file. Can this be considered a recommended solution to reset/rebuild the component?
Re: strange situation in the ide with package that hasn't opened anymore. [message #57343 is a reply to message #57341] Thu, 15 July 2021 09:56 Go to previous message
Xemuth is currently offline  Xemuth
Messages: 387
Registered: August 2018
Location: France
Senior Member
Hello BettoValle,

I think you posted in wrong category. this one is reserved to maintener of U++.
However, I remember facing same issue when recompiling TheIDE in last trunk using Visual C++ compiler. The fatest way to fix that was to retrieve last build in website (and for some reason this one did not had bug). It didn't happen to me a long time in a row
Previous Topic: Problem with MemorySanitizer
Next Topic: A strange bug in std::chrono
Goto Forum:
  


Current Time: Sun Jun 16 20:40:59 CEST 2024

Total time taken to generate the page: 0.01954 seconds