Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Other Features Wishlist and/or Bugs » Navigator window - gone?
Navigator window - gone? [message #60106] Sun, 03 September 2023 15:01 Go to next message
luoganda is currently offline  luoganda
Messages: 203
Registered: November 2016
Experienced Member
I use navigator window from always(Ctrl-J) - probably few others too,
it's much better than navigation bar since it has a broader range of usefulness
and is much more panoramic. The last version i checked with it is 16270.
Couldn't this be reintegrated - or maybe at least make an option to show it in menu?

2)This is just a hint...
upp-13664 version seems is the latest that has word as wchar(2bytes):
since upp is not dependant on c++ standards, this would be nice to have in the future,
since(at least in windows i think) L"" meant exactly that - word(not int).

3) new indexer makes problems(i checked it with clang and msvc17 on w7):
(i mostly use msvc17 on windows since it's faster and usually makes smaller exes)
old one works like a charm, meaning - it works for anything(eg Ctrl-LMButtonClick) on anything,
new one(with latest 16962) i open Examples/Button and click Ctrl-LMButton on TopWindow in editor and... Nothing.
Parser starts parsing but after that it ends and nothing happens.
Does currently settings support so that indexer works like the old one from eg 16270(where all sources are checked/parsed at start)?
I played with settings but no one worked like the old one.
Re: Navigator window - gone? [message #60108 is a reply to message #60106] Mon, 04 September 2023 10:04 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
luoganda wrote on Sun, 03 September 2023 15:01
I use navigator window from always(Ctrl-J) - probably few others too,
it's much better than navigation bar since it has a broader range of usefulness
and is much more panoramic. The last version i checked with it is 16270.
Couldn't this be reintegrated - or maybe at least make an option to show it in menu?


Uhm, OK, I am not sure what that dialog allows compared to navigator pane, but I will do as commanded... (you are second person asking about it...)

Quote:

2)This is just a hint...
upp-13664 version seems is the latest that has word as wchar(2bytes):
since upp is not dependant on c++ standards, this would be nice to have in the future,
since(at least in windows i think) L"" meant exactly that - word(not int).


What exactly would be nice to have in future? Smile

Note that a) you do not really need to use L"" for anything b) you have all tools available to do so. You have char16 and String x = L""; works too. Even if in reality, we do not need L"" for anything (UTF-8 is king).

3) new indexer makes problems(i checked it with clang and msvc17 on w7):
(i mostly use msvc17 on windows since it's faster and usually makes smaller exes)
old one works like a charm, meaning - it works for anything(eg Ctrl-LMButtonClick) on anything,
new one(with latest 16962) i open Examples/Button and click Ctrl-LMButton on TopWindow in editor and... Nothing.
Parser starts parsing but after that it ends and nothing happens.
Does currently settings support so that indexer works like the old one from eg 16270(where all sources are checked/parsed at start)?
I played with settings but no one worked like the old one.[/quote]


clang works fine for me in this particular case.

msvc seems to have header compatibility issues. I will try to mitigate that, no promises.

Mirek

[Updated on: Mon, 04 September 2023 10:04]

Report message to a moderator

Re: Navigator window - gone? [message #60109 is a reply to message #60108] Mon, 04 September 2023 11:49 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Ad 3: It looks like that if I remove

c:/program files (x86)/microsoft visual studio/2017/community/vc/tools/msvc/14.15.26726/include

from build method include paths, asist works with MSVS 17 (but not building). Can you confirm? (Do not forget to eventually reindex if it does not).

Mirek
Re: Navigator window - gone? [message #60111 is a reply to message #60109] Tue, 05 September 2023 13:21 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Please try with current master, I have tried to brind that navigation window back and also to fix MSVC issues.
Re: Navigator window - gone? [message #60112 is a reply to message #60106] Tue, 05 September 2023 14:17 Go to previous messageGo to next message
luoganda is currently offline  luoganda
Messages: 203
Registered: November 2016
Experienced Member
Quote:
Uhm, OK, I am not sure what that dialog allows compared to navigator pane, but I will do as commanded... (you are second person asking about it...)

Probably all have not seen it yet Smile. Ok, thanks.

Quote:
Note that a) you do not really need to use L"" for anything b) you have all tools available to do so. You have char16 and String x = L""; works too. Even if in reality, we do not need L"" for anything (UTF-8 is king).

Yes, true(utf8 is king).
But i had an older win32 code that i use and was dependant on wchar and that L"" being word(altough i think this can be altered with different compilers).
With that i mostly mean older code using WString(which had wchar 2bytes and it's wchar *ptr) and newerVer(which wchar is 4bytes-int).
This is just an hint(could be and option but not on priority list) - since all older code used 2bytes as wchar and never(especially it seems on linux) - 4bytes.

Indexing(written for both: included clang and msvc17) not working correctly(win7x64):
(i have msvc17-build-tools version: but that doesn't make a difference except mine seems is a little newerVer - check opts2.jpg AttachedImg)
i tried without that include path - but no luck(same with default included clang).
I have tried all three new setting togling in different ways and no go(neither clang nor msvc17).
And - only if 1st option is checked(...clang indexer...) dialog appears - altough nothing happens after that.

Note: this was written for and tested with v16963.
  • Attachment: opts2.jpg
    (Size: 324.11KB, Downloaded 38 times)
Re: Navigator window - gone? [message #60113 is a reply to message #60106] Tue, 05 September 2023 21:12 Go to previous messageGo to next message
luoganda is currently offline  luoganda
Messages: 203
Registered: November 2016
Experienced Member
added to upper post...

This is the 1st time that i try to
compile theide via umk on windows, so - i've got a few errors.


>>
cannot open include file: 'clang-c/Index.h': No such file or directory
ok - i've added it to compiler path in CLANG(and MSVC) and then this is ok.

>>
uppsrc\ide\LayDes\LayWin.cpp(180):
modified to "LayDes::Zoom = LayDes::Zoom < 5 ? 5 : LayDes::Zoom < 10 ? 10 : 0;"
and it works without throwing an error(msvc17 compiler used, i don't know if clang would throw the same 'could be this and that...' error).

>>
uppsrc\ide\Errors.cpp(700):
modified to "int sh = Utf32Len(String(txt) << sl, atoi(h[2])) + sl;" after this works without error on msvc17(don't know about clang though).

>>
after this i used clang and then there were linking issues:
Linking...
  ld.lld: error: undefined symbol: __declspec(dllimport) _clang_getCString
  >>> referenced by ...upp/_out/ide/clang/CLANG.Blitz.Gui.Sse2/ide/clang$blitz.o:(FetchString(CXString))

and maaany more "clang_..." linking errors, i think funcs from libclang.cpp are missing.
What and where do i add them to be linked against - a fix in a makefile?
Could be library from upp/bin/llvm/libclang.lib(probably only if clang is used),
or libclang.cpp from uppsrc/ide/clang/libclang.cpp(which is probably the correct one to use).
Re: Navigator window - gone? [message #60122 is a reply to message #60113] Fri, 08 September 2023 08:51 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
luoganda wrote on Tue, 05 September 2023 21:12
added to upper post...

This is the 1st time that i try to
compile theide via umk on windows, so - i've got a few errors.


>>
cannot open include file: 'clang-c/Index.h': No such file or directory
ok - i've added it to compiler path in CLANG(and MSVC) and then this is ok.

>>
uppsrc\ide\LayDes\LayWin.cpp(180):
modified to "LayDes::Zoom = LayDes::Zoom < 5 ? 5 : LayDes::Zoom < 10 ? 10 : 0;"
and it works without throwing an error(msvc17 compiler used, i don't know if clang would throw the same 'could be this and that...' error).

>>
uppsrc\ide\Errors.cpp(700):
modified to "int sh = Utf32Len(String(txt) << sl, atoi(h[2])) + sl;" after this works without error on msvc17(don't know about clang though).

>>
after this i used clang and then there were linking issues:
Linking...
  ld.lld: error: undefined symbol: __declspec(dllimport) _clang_getCString
  >>> referenced by ...upp/_out/ide/clang/CLANG.Blitz.Gui.Sse2/ide/clang$blitz.o:(FetchString(CXString))

and maaany more "clang_..." linking errors, i think funcs from libclang.cpp are missing.
What and where do i add them to be linked against - a fix in a makefile?
Could be library from upp/bin/llvm/libclang.lib(probably only if clang is used),
or libclang.cpp from uppsrc/ide/clang/libclang.cpp(which is probably the correct one to use).


You cannot build theide with msvc easily anymore. (MSVC continues to be supported for user projects, but I see no reason to fight for theide to be MSVC compatible out of box).

Also, I am not sure theide works properly in Win7 anymore and I am not willing to invest time to even check. It is 2023 ffs...

[Updated on: Fri, 08 September 2023 08:54]

Report message to a moderator

Re: Navigator window - gone? [message #60125 is a reply to message #60122] Fri, 08 September 2023 09:04 Go to previous messageGo to next message
mirek is currently offline  mirek
Messages: 13986
Registered: November 2005
Ultimate Member
Anyway, for starters, what about trying with latest nightly build?

Mirek
Re: Navigator window - gone? [message #60175 is a reply to message #60106] Thu, 21 September 2023 21:25 Go to previous message
luoganda is currently offline  luoganda
Messages: 203
Registered: November 2016
Experienced Member
TheIDE works just fine on Win7 with 2Cores x 3GHz.

Indexer is still a little problematic on any os,
altough i didn't test the last v16997, since
i've got Segmentation fault after successfull build on debian 10(buster)
the usual way using ./install script which uses umks32.

[Updated on: Thu, 21 September 2023 22:13]

Report message to a moderator

Previous Topic: [Fixed] TheIde continuously using CPU
Next Topic: version 168847 (stable)
Goto Forum:
  


Current Time: Sun Jun 16 20:08:33 CEST 2024

Total time taken to generate the page: 0.02464 seconds