Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » U++ TheIDE » U++ TheIDE: Other Features Wishlist and/or Bugs » [DONE]Alt-I, Virtual methods - do not work.
[DONE]Alt-I, Virtual methods - do not work. [message #60317] Sat, 18 November 2023 22:13 Go to next message
luoganda is currently offline  luoganda
Messages: 204
Registered: November 2016
Experienced Member
This is probably related to this and i guess it goes less memory for it.
A few 'Assist' commands do not work at all(Alt-I, Alt-V, Alt-T).
I don't care about the others, but Alt-I? one can check stuff that docs don't show(because of updates/etc).
Is there another way to cross jump across the source files quickly?

By the way, i am having an manual ProcessEvents(&quit) loop,
altough quit is never set, so for now i am using while(!topWnd.IsClosed());
Could this be a bug?

By the way 2:
can one set global theme manually for controls - eg GUISTYLE_FLAT, GUISTYLE_CLASSIC, GUISTYLE_XP?
I tried GUI_GlobalStyle_Write(GUISTYLE_XP) - but it does not work.

By the way 3:
i must always compile TheIDE on linux with ...+NOGTK flag, else i always get
segmentation fault after it's build(same with any apps i write). This does not bother me, since i would
anyway use NOGTK for less overhead stuff. Here just to know it(i have libgtk installed - compiled on debian10).

[Updated on: Wed, 17 April 2024 22:14]

Report message to a moderator

Re: Alt-I, Virtual methods - do not work. [message #60318 is a reply to message #60317] Sun, 19 November 2023 14:32 Go to previous messageGo to next message
omari is currently offline  omari
Messages: 266
Registered: March 2010
Experienced Member
I notice that Assist (Alt-I, Alt-V, ..) does not work in .h files, but it works fine in .cpp files.

regards
omari.
Re: Alt-I, Virtual methods - do not work. [message #60321 is a reply to message #60317] Mon, 20 November 2023 19:01 Go to previous messageGo to next message
luoganda is currently offline  luoganda
Messages: 204
Registered: November 2016
Experienced Member
no, i my case it doesn't - tested with 17089(simple examples/Button example).

[Updated on: Mon, 20 November 2023 19:15]

Report message to a moderator

Re: [DONE]Alt-I, Virtual methods - do not work. [message #60545 is a reply to message #60317] Wed, 17 April 2024 22:18 Go to previous message
luoganda is currently offline  luoganda
Messages: 204
Registered: November 2016
Experienced Member
This works for quite some time now,
but i postpone this message to see if this code would work for latest versions, and it does.
I guess it was quite some work under the hood, and it maybe works even better than before,
so - thanks!

ADDED:
it seems that if one clicks eg #include<ctime> somewhere in the code it works ok, but
if #include <c:/path/someHeader.hpp> is there that is not on the compiler/other path - it does not open it.
Can this be fixed?

[Updated on: Wed, 17 April 2024 23:08]

Report message to a moderator

Previous Topic: 16660: UI
Next Topic: Compilation warnings and random crashes
Goto Forum:
  


Current Time: Sun Jun 23 09:45:33 CEST 2024

Total time taken to generate the page: 0.01222 seconds