Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » Tutorial update(s) (Possible inconsistency between tutorial code and UPP updates)
Tutorial update(s) [message #60327] Mon, 04 December 2023 05:42
EspressoMan is currently offline  EspressoMan
Messages: 13
Registered: April 2023
Location: New Zealand
Promising Member
So here I am back making a concerted effort to learn UPP. Working my way through the tutorials, I'm finding the occasional problem which I think is likely due to updates of UPP not being reflected in (previously written) tutorial code. Rest assured that I do not intend to post any of these "problems" without checking for my own typos and making a serious effort to search the forums for previous posts on the topic. I don't necessarily expect anyone to reply but of course I would be most grateful to those who do.

Right now I'm in section 10 of Tutorial Gui01 and there is a section of code 'hanging up' in theIDE

...
void SubMenu(Bar& bar)
{
bar.Add( "Exit", TutorialImg::Exit(), [=] { Exit(); } );
}
...

The error reported is that TutorialImg has no member named "Exit" and I'm perplexed by that. How do I fix it?

Oooops! Already found the problem! - Include path not set to sandbox dirs... Embarassed

[Updated on: Mon, 04 December 2023 12:09]

Report message to a moderator

Previous Topic: Help needed with OptionTree
Next Topic: General questions about theIDE
Goto Forum:
  


Current Time: Sat Jun 22 08:12:29 CEST 2024

Total time taken to generate the page: 0.03320 seconds