Overview
Examples
Screenshots
Comparisons
Applications
Download
Documentation
Tutorials
Bazaar
Status & Roadmap
FAQ
Authors & License
Forums
Funding Ultimate++
Search on this site
Search in forums












SourceForge.net Logo
Home » Community » Newbie corner » gcc 4.4 compatible version?
gcc 4.4 compatible version? [message #48512] Wed, 12 July 2017 11:19 Go to next message
rafiwui is currently offline  rafiwui
Messages: 105
Registered: June 2017
Location: Stuttgart, Germany
Experienced Member
I am planing to develop on a Red Hat 6 machine and the compiler on this is the gcc 4.4.6. Because this compiler is not supported in the current release I want to ask if there is an old release supporting gcc 4.4?

Greetings
Daniel
Re: gcc 4.4 compatible version? [message #48522 is a reply to message #48512] Thu, 13 July 2017 15:04 Go to previous messageGo to next message
rafiwui is currently offline  rafiwui
Messages: 105
Registered: June 2017
Location: Stuttgart, Germany
Experienced Member
So, running "make" of upp version 4179 on the redhat 6 machine with gcc 4.4.6 i get the following error:
In file included from /usr/include/glib-2.0/glib/gasyncqueue.h:34,
                 from /usr/include/glib-2.0/glib.h:34,
                 from CtrlLib/TrayIconX11.cpp:8:
/usr/include/glib-2.0/glib/gthread.h: In function 〘gboolean g_once_init_enter(volatile gsize*)〙:
/usr/include/glib-2.0/glib/gthread.h:347: error: size of array is negative
gmake[1]: *** [_out/CtrlLib/GCCMK-Gcc-Gui-Linux-Posix-Shared/TrayIconX11.o] Error 1
gmake[1]: Leaving directory `/home/danielh/upp-x11-src-4179/uppsrc'
cp: cannot stat `uppsrc/ide.out': No such file or directory
make: *** [all] Error 1

Any idea why this is thrown? Also tried it with version 2361 -> same error.


Greetings
Daniel
Re: gcc 4.4 compatible version? [message #48523 is a reply to message #48522] Thu, 13 July 2017 16:51 Go to previous messageGo to next message
rafiwui is currently offline  rafiwui
Messages: 105
Registered: June 2017
Location: Stuttgart, Germany
Experienced Member
I tried it with the 2015.2 release (version 9251):
cp: cannot stat 'uppsrc/ide.out': No such file or directory

I checked the folder and there is no ide.out so thats correct. But there is a umk.out so sth went wrong compiling TheIDE.
Any ideas? Or did someone face this problem already?


Greetings
Daniel
Re: gcc 4.4 compatible version? [message #48526 is a reply to message #48523] Fri, 14 July 2017 08:59 Go to previous message
rafiwui is currently offline  rafiwui
Messages: 105
Registered: June 2017
Location: Stuttgart, Germany
Experienced Member
So I found an error message inside the output of the make routine:
/usr/lib/gcc/x86_64-redhat-linux/4.4.6/../../../../lib64/libgdk-x11-2.0.so: undefined reference to `_XGetRequest'
collect2: ld returned 1 exit status

And there is a lot of "skipping incompatible..." stuff as well.
Can anyone pls help me??


Greetings
Daniel
Previous Topic: OpenGL demo resulting in Fatal error, Heap leaks detected! error...
Next Topic: Modify richedit component of Uword demo
Goto Forum:
  


Current Time: Fri Aug 23 07:26:55 CEST 2019

Total time taken to generate the page: 0.01460 seconds